Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th April 2009, 12:21
ronee ronee is offline
HowtoForge Supporter
 
Join Date: Oct 2006
Posts: 32
Thanks: 0
Thanked 2 Times in 2 Posts
Default Argument "-" isn't numeric in numeric gt (>) at /usr/sbin/vlogger line 456

Fresh install of Ispconfig 3.0.1.1 on CentOS 5, things appear to be working however the ispconfig web interface periodically becomes unusable, only blank pages show up, cannot log in due to javascript errors and so forth.

Restarting apache temporarily resolves.

Also, the following repeatedly appears in /var/log/httpd/error_log:

Argument "-" isn't numeric in numeric gt (>) at /usr/sbin/vlogger line 456, <STDIN> line 18

I tried this:

http://www.how2forge.org/forums/showthread.php?t=27188

but no real difference, same error shows up in the error_log

perl-TimeDate is installed

which vlogger outputs: /usr/sbin/vlogger

the above two items I have seen mentioned in other threads where the problem appeared similar.
Reply With Quote
Sponsored Links
  #2  
Old 6th April 2009, 13:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

I've added this to our bugtracker.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 27th April 2009, 01:45
cvladan cvladan is offline
Junior Member
 
Join Date: Sep 2007
Location: Beograd
Posts: 9
Thanks: 0
Thanked 7 Times in 3 Posts
Send a message via Skype™ to cvladan
 
Default Solution

I had the same problem. For me, the right solution for this problem is to change only one letter %b from lowercase to uppercase in file /etc/httpd/conf/sites-available/ispconfig.conf,
in LogFormat line. Change:

LogFormat "%v %h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
to this
LogFormat "%v %h %l %u %t \"%r\" %>s %B \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig

Lowercase b to uppercase B. It looks that vlogger does not understand dash - when it's zero it must be zero.
As it is written here already: http://httpd.apache.org/docs/1.3/mod...og_config.html

%B (Bytes sent, excluding HTTP headers),
%b (Bytes sent, in CLF format i.e. a '-' rather than a 0 when no bytes are sent)
Reply With Quote
The Following 5 Users Say Thank You to cvladan For This Useful Post:
Cracklefish (10th June 2009), falcontx (27th April 2009), falko (27th April 2009), till (27th April 2009), uncher (27th April 2009)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix delivery problem erebus Installation/Configuration 8 29th July 2014 20:17
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
Installation Troubles bswinnerton Installation/Configuration 4 29th July 2007 16:56
help on /etc/rc0.d/K20dnsctl -> ../init.d/dnsctl zimele General 13 23rd August 2006 16:06
Installation Big issue OpenVZ VPS jbond007 Installation/Configuration 3 7th March 2006 19:40


All times are GMT +2. The time now is 15:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.