Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 21st April 2009, 20:16
jkrell jkrell is offline
Member
 
Join Date: Oct 2006
Posts: 61
Thanks: 6
Thanked 1 Time in 1 Post
Default Emergency -- Need to Restore File from Clonezilla image

So back in February I made a backup image of my Fedora 10 server machine using the howto on this site. The setup of my server is that I have 3 250Gb HDDs setup as one disk using LVM. The backup process went smoothly and I have my backup stored on an external 1Tb HDD.

Last week, I accidentally erased a file using command line. I was just absent-mindedly doing stuff and what is weird is I don't remember being asked to confirm deletion. In any event, the file is gone and I need it back. I have checked everywhere and the only place it exists is in the Clonezilla live image (normally I have redundancies, but I did not want this file in my other backup spots, which are not as secure as the external HDD I use for my Clonezilla images.

Needless to say, I do not just want to restore the image because now months have gone by and other files have changed, which I do not want to lose by restoring the image. One thing I could do is just backup my /home and /var/www/ folders and then restore the image, and then restore the /home and /var/www/ folders. But this would be risky as I am not sure what else might have changed in the interim.

I have done some research and found the following regarding how to mount a Clonezilla image and pull files from it:

http://ubuntuforums.org/showthread.php?t=872832

Unfortunately, this does not work for me, mostly because I cannot figure out how to reference my image. Like I said above, I made an image of the entire disk, which is set up using LVM, so I do not have a file ending in -img in the subfolder for my backup. I cannot post my directory structure of the backup now because I am at work, but I can do so later and I can also post the output of my attempts at mounting the image.

For now, though, I wanted to ask a question. Is there a way I can simply restore the Clonezilla image to my 1Tb external HDD? Once restored, I could pull the file I need out, and wipe the drive clean. The problem is, as I mentioned above, that my image is of an LVM setup, whereas my external HDD is a single 1Tb drive.

Do you think I could use GParted to create 3 drives the same sizes as my three existing 250Gb drives, and restore the image to those? Would that work?
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix delivery problem erebus Installation/Configuration 8 29th July 2014 21:17
Chroot SSH + ISPConfig Norman Installation/Configuration 27 26th March 2007 04:40
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 18:17
jamed up my table borders?? Boon-Dog-Danny Installation/Configuration 5 23rd September 2006 17:12
64-bit Debian 3.1 Install Issue naruto Installation/Configuration 14 5th September 2006 05:12


All times are GMT +2. The time now is 16:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.