Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th April 2009, 22:37
enissayol enissayol is offline
Junior Member
 
Join Date: Apr 2009
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default RewriteEngine not allowed here

Hi all,

First of all, thanks for your help, i've been looking for an answer to my problem but i couldn't find one, i'v tried all the solutions but it didn't work for me...
Here is my problem:
I have Installed Ispconfig 3, everything is working except the URL rewriting using Wordpress, when i check the logs of the web site i can see the error:RewriteEngine not allowed here
The code of the htaccess is:
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

The code of my conf file is :
<Directory /var/www/fnaire.info>
AllowOverride all
Order Deny,Allow
allow from all
</Directory>

<VirtualHost 87.98.170.131:80>
DocumentRoot /var/www/fnaire.info/web

ServerName fnaire.info
ServerAlias *.fnaire.info
ServerAdmin webmaster@fnaire.info

ErrorLog /var/log/ispconfig/httpd/fnaire.info/error.log

ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

<Directory /var/www/fnaire.info/web>
Options SymLinksIfOwnerMatch
AllowOverride AuthConfig
AllowOverride FileInfo
</Directory>
<Directory /var/www/clients/client1/web4/web>
Options SymLinksIfOwnerMatch
AllowOverride AuthConfig
AllowOverride FileInfo
</Directory>

# mod_php enabled
AddType application/x-httpd-php .php .php3 .php4 .php5
php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@fnaire.info"
php_admin_value upload_tmp_dir /var/www/clients/client1/web4/tmp
php_admin_value session.save_path /var/www/clients/client1/web4/tmp
#php_admin_value open_basedir /var/www/clients/client1/web4:/usr/share/php5
</VirtualHost>

The mid_rewrite is on, i have tried the options :
AllowOverride All
AllowOverride FileInfo

Thanks for your help
Reply With Quote
Sponsored Links
  #2  
Old 16th April 2009, 12:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,083
Thanks: 826
Thanked 5,397 Times in 4,241 Posts
Default

It defiantely works when you use "AllowOverride All", maybe you did not restart apache after your changes?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 16th April 2009, 18:19
enissayol enissayol is offline
Junior Member
 
Join Date: Apr 2009
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I did restart it many times with restart or force-reload
Reply With Quote
  #4  
Old 16th April 2009, 18:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

In which directory is the .htaccess file located?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 16th April 2009, 19:02
enissayol enissayol is offline
Junior Member
 
Join Date: Apr 2009
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

/var/www/fnaire.info/web/
Reply With Quote
  #6  
Old 16th April 2009, 20:01
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Default

Quote:
Originally Posted by enissayol View Post
/var/www/fnaire.info/web/
I had the same problem but this worked for me:
In the ISPCONFIG CP.
Add the following to the Apache directives for the specific site:

Quote:
<Directory /var/www/fnaire.info/web>
Options +Includes -Indexes -ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>

Save the changes then try access the site again.
Reply With Quote
  #7  
Old 16th April 2009, 22:50
enissayol enissayol is offline
Junior Member
 
Join Date: Apr 2009
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i just tried but it didn't work...it adds the code on my fnaire.info.vhost file (apache restarted) and i keep getting the 500 error
Reply With Quote
  #8  
Old 16th April 2009, 23:42
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Default

Quote:
Originally Posted by enissayol View Post
i just tried but it didn't work...it adds the code on my fnaire.info.vhost file (apache restarted) and i keep getting the 500 error
Alright, leave the code in the apache directive that I mentioned in my last post.
In your .htaccess file, comment out "RewriteBase /", this is only used if your wordpress installation is in another directory other then root. So basically comment it out if your WP is installed in /var/www/fnaire.info/web/.

Also, comment out this in your .htaccess file:
Options +FollowSymLinks

Give this a try.
Reply With Quote
  #9  
Old 17th April 2009, 00:06
enissayol enissayol is offline
Junior Member
 
Join Date: Apr 2009
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

grrrrrrrr, it's not working, i did comment out the RewriteBase /
i don't have this line on my .htaccess Options +FollowSymLinks
Reply With Quote
  #10  
Old 17th April 2009, 17:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

The problem probably is that you have
Code:
<Directory /var/www/fnaire.info/web>
Options SymLinksIfOwnerMatch
AllowOverride AuthConfig
AllowOverride FileInfo
</Directory>
in your vhost configuration.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
htaccess, mod_rewrite, rewriteengine, url rewriting

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ftp is very slow and asks for user/passwd continuously chico58 Installation/Configuration 7 8th October 2008 12:43
Server Error 500 devilslayer Installation/Configuration 7 21st November 2007 11:16
how to enable Mod Rewrite AngelDrago Installation/Configuration 9 10th August 2007 23:20
Ispconfig and Virtuemart shajazzi Installation/Configuration 7 21st February 2006 20:25
Number of allowed domains times 2? cstone Installation/Configuration 9 11th October 2005 02:06


All times are GMT +2. The time now is 02:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.