Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 15th April 2009, 23:37
enissayol enissayol is offline
Junior Member
 
Join Date: Apr 2009
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default RewriteEngine not allowed here

Hi all,

First of all, thanks for your help, i've been looking for an answer to my problem but i couldn't find one, i'v tried all the solutions but it didn't work for me...
Here is my problem:
I have Installed Ispconfig 3, everything is working except the URL rewriting using Wordpress, when i check the logs of the web site i can see the error:RewriteEngine not allowed here
The code of the htaccess is:
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

The code of my conf file is :
<Directory /var/www/fnaire.info>
AllowOverride all
Order Deny,Allow
allow from all
</Directory>

<VirtualHost 87.98.170.131:80>
DocumentRoot /var/www/fnaire.info/web

ServerName fnaire.info
ServerAlias *.fnaire.info
ServerAdmin webmaster@fnaire.info

ErrorLog /var/log/ispconfig/httpd/fnaire.info/error.log

ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

<Directory /var/www/fnaire.info/web>
Options SymLinksIfOwnerMatch
AllowOverride AuthConfig
AllowOverride FileInfo
</Directory>
<Directory /var/www/clients/client1/web4/web>
Options SymLinksIfOwnerMatch
AllowOverride AuthConfig
AllowOverride FileInfo
</Directory>

# mod_php enabled
AddType application/x-httpd-php .php .php3 .php4 .php5
php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@fnaire.info"
php_admin_value upload_tmp_dir /var/www/clients/client1/web4/tmp
php_admin_value session.save_path /var/www/clients/client1/web4/tmp
#php_admin_value open_basedir /var/www/clients/client1/web4:/usr/share/php5
</VirtualHost>

The mid_rewrite is on, i have tried the options :
AllowOverride All
AllowOverride FileInfo

Thanks for your help
Reply With Quote
Sponsored Links
 

Bookmarks

Tags
htaccess, mod_rewrite, rewriteengine, url rewriting

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ftp is very slow and asks for user/passwd continuously chico58 Installation/Configuration 7 8th October 2008 13:43
Server Error 500 devilslayer Installation/Configuration 7 21st November 2007 12:16
how to enable Mod Rewrite AngelDrago Installation/Configuration 9 11th August 2007 00:20
Ispconfig and Virtuemart shajazzi Installation/Configuration 7 21st February 2006 21:25
Number of allowed domains times 2? cstone Installation/Configuration 9 11th October 2005 03:06


All times are GMT +2. The time now is 23:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.