Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Closed Thread
 
Thread Tools Display Modes
  #11  
Old 9th April 2009, 13:46
Etienne Etienne is offline
Member
 
Join Date: Nov 2005
Location: Belgium
Posts: 31
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ggohdin View Post
Hi, you need fullstops at the end of your domain names in your dns zone records. e.g "web-world.com." How ever your zone record for dolls-world.com. is correct, just see where the full stops are in that zone and do the same with the other zones.
That makes no sense, because the "web-worlds.com" opens up normally, but the "dolls-world.com" not ???

But I changed them to full stops anyway.

But why could it take up to 3 days considdering that the changes are on my server and dont reflect to the outside world?

Correct me if i'm wrong but when somebody types "http://www.web-worlds.com" then the first to respond is Godaddy because there is the name registered, Godaddy gives the ns1.dnsexit.com.

On DNSExit it looks up the ip adres and then links to that, then on my server it is rerouted to the right web adress???

Is this the right way ??

Thanks in advance,
Etienne
Sponsored Links
  #12  
Old 9th April 2009, 14:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Why do you set up DNS records in ISPConfig when your registrar is running the nameservers for your domains? That makes no sense to me.

Anyway, can you post the vhost configurations of www.web-worlds.com and www.dolls-world.com?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
  #13  
Old 9th April 2009, 14:41
Etienne Etienne is offline
Member
 
Join Date: Nov 2005
Location: Belgium
Posts: 31
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Hi Falko,

What is your suggestion then, to turn of MyDNS in the ISPconfig ??

And vhost.conf I dont have, at least a find / vhost.conf say so.

Thanks,
Etienne
  #14  
Old 10th April 2009, 12:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by Etienne View Post
What is your suggestion then, to turn of MyDNS in the ISPconfig ??
If your registrar is running the nameservers for your domains, then you don't need to configure anything in the DNS part of ISPConfig.

Quote:
Originally Posted by Etienne View Post
And vhost.conf I dont have, at least a find / vhost.conf say so.
Which distribution are you using? For Debian/Ubuntu, the files should be in /etc/apache2/sites-available.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
  #15  
Old 11th April 2009, 11:29
Etienne Etienne is offline
Member
 
Join Date: Nov 2005
Location: Belgium
Posts: 31
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Okay I turned off mydns in ISPconfig, and waited 2 days, but still no change.

The output for web-worlds.com.vhost:

Code:
<Directory /var/www/web-worlds.com>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost *:80>
      DocumentRoot /var/www/web-worlds.com/web
  
    ServerName web-worlds.com
    ServerAlias www.web-worlds.com
    ServerAdmin webmaster@web-worlds.com

    ErrorLog /var/log/ispconfig/httpd/web-worlds.com/error.log
	
    <Directory /var/www/web-worlds.com/web>
        Options FollowSymLinks
        AllowOverride Indexes AuthConfig Limit
        Order allow,deny
        Allow from all
        
        # ssi enabled
        AddType text/html .shtml
        AddOutputFilter INCLUDES .shtml
        Options +Includes
    </Directory>
    <Directory /var/clients/client1/web1/web>
        Options FollowSymLinks
        AllowOverride Indexes AuthConfig Limit
        Order allow,deny
        Allow from all
        
        # ssi enabled
        AddType text/html .shtml
        AddOutputFilter INCLUDES .shtml
        Options +Includes
    </Directory>

    # cgi enabled
	<Directory /var/clients/client1/web1/cgi-bin>
      Order allow,deny
      Allow from all
    </Directory>
    ScriptAlias  /cgi-bin/ /var/clients/client1/web1/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # suexec enabled
    SuexecUserGroup web1 client1
    # mod_php enabled
    AddType application/x-httpd-php .php .php3 .php4 .php5
	php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@web-worlds.com"	
    php_admin_value upload_tmp_dir /var/clients/client1/web1/tmp
    php_admin_value session.save_path /var/clients/client1/web1/tmp
    #php_admin_value open_basedir /var/clients/client1/web1:/usr/share/php5


</VirtualHost>
and of dolls-world.com.vhost:

Code:
<Directory /var/www/dolls-worlds.com>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost *:80>
      DocumentRoot /var/www/dolls-worlds.com/web
  
    ServerName dolls-worlds.com
    ServerAlias www.dolls-worlds.com
    ServerAdmin webmaster@dolls-worlds.com

    ErrorLog /var/log/ispconfig/httpd/dolls-worlds.com/error.log
	
    <Directory /var/www/dolls-worlds.com/web>
        Options FollowSymLinks
        AllowOverride Indexes AuthConfig Limit
        Order allow,deny
        Allow from all
        
        # ssi enabled
        AddType text/html .shtml
        AddOutputFilter INCLUDES .shtml
        Options +Includes
    </Directory>
    <Directory /var/clients/client1/web3/web>
        Options FollowSymLinks
        AllowOverride Indexes AuthConfig Limit
        Order allow,deny
        Allow from all
        
        # ssi enabled
        AddType text/html .shtml
        AddOutputFilter INCLUDES .shtml
        Options +Includes
    </Directory>

    # cgi enabled
	<Directory /var/clients/client1/web3/cgi-bin>
      Order allow,deny
      Allow from all
    </Directory>
    ScriptAlias  /cgi-bin/ /var/clients/client1/web3/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # suexec enabled
    SuexecUserGroup web3 client1
    # mod_php enabled
    AddType application/x-httpd-php .php .php3 .php4 .php5
	php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@dolls-worlds.com"	
    php_admin_value upload_tmp_dir /var/clients/client1/web3/tmp
    php_admin_value session.save_path /var/clients/client1/web3/tmp
    #php_admin_value open_basedir /var/clients/client1/web3:/usr/share/php5


</VirtualHost>

Hope somebody can figure this out...

Thanks,
Etienne
  #16  
Old 11th April 2009, 11:36
Etienne Etienne is offline
Member
 
Join Date: Nov 2005
Location: Belgium
Posts: 31
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Hmm i allready see something strange... there is everywhere written dolls-worlds.com and it should be dolls-world.com ??

Really wondering from where comes the extra s, and why it is not reflected in ISPConfig files???

Any clues ?

TIA
Etienne
  #17  
Old 12th April 2009, 14:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Did you use dolls-worlds.com or dolls-world.com in the ISPConfig web interface?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
  #18  
Old 12th April 2009, 14:58
Etienne Etienne is offline
Member
 
Join Date: Nov 2005
Location: Belgium
Posts: 31
Thanks: 5
Thanked 0 Times in 0 Posts
Default

For some reason I have occassionally used world and occassionally used worlds ..??.. but I changed it now by vi the .host file and making new symlinks, and all is working (trail and error)

Only thing now left is the symlink to the webmail, if you have any fast clues on how to do this because a simple symlink seems to run into permission problems...

Thanks,
Etienne
  #19  
Old 12th April 2009, 15:14
Etienne Etienne is offline
Member
 
Join Date: Nov 2005
Location: Belgium
Posts: 31
Thanks: 5
Thanked 0 Times in 0 Posts
 
Default

Never mind, this is also solved turns out a webmail symlink from the web1/web to usr/share/squirrelmail did the trick.

This thread can be closed

Thanks to all people involved!
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
just the last step...and it works. Postfix...need help config. ubuntusr Installation/Configuration 1 5th January 2009 09:50
rdiff backup works only with "permit root login" on master server adrenalinic HOWTO-Related Questions 1 16th October 2007 11:29
One Domain Works Only Fedora Core 7 earthboi23 Installation/Configuration 1 6th July 2007 17:25
site works but ISPConfig login gone? Boon-Dog-Danny Installation/Configuration 6 4th August 2006 13:01
Autoresponder - works and works not Thunderbirdsei Installation/Configuration 8 8th February 2006 16:11


All times are GMT +2. The time now is 16:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.