Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th April 2009, 10:15
clark61 clark61 is offline
Junior Member
 
Join Date: Mar 2009
Location: Milano
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default Virtual Users And Domains spamassassin don't tag

Hi all,
another question about Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Debian Lenny)
The server works well and redirect on the other mail server but I can not, however, to make spamassassin insert tags **** SPAM **** to the end user can decide.
In the /etc/amavis/conf.d/20-debian_default I have:
$QUARANTINEDIR = "$MYHOME/virusmails";
$quarantine_subdir_levels = 1;
$log_recip_templ = undef;
$DO_SYSLOG = 1;
$syslog_ident = 'amavis';
$syslog_facility = 'mail';
$syslog_priority = 'debug';
$enable_db = 1;
$enable_global_cache = 1;
$inet_socket_port = 10024;
$sa_spam_subject_tag = '***SPAM*** ';
$sa_spam_report_header = 1;
#$sa_tag_level_deflt = 2.0;
$sa_tag_level_deflt = -9999;
$sa_tag2_level_deflt = 6.31;
$sa_kill_level_deflt = 6.31;
$sa_dsn_cutoff_level = 10;
$sa_mail_body_size_limit = 200*1024;
$sa_local_tests_only = 0;
$MAXLEVELS = 14;
$MAXFILES = 1500;
$MIN_EXPANSION_QUOTA = 100*1024;
$MAX_EXPANSION_QUOTA = 300*1024*1024;
$final_virus_destiny = D_DISCARD;
$final_banned_destiny = D_BOUNCE;
#$final_spam_destiny = D_BOUNCE;
$final_spam_destiny = D_PASS;
$final_bad_header_destiny = D_PASS;
$virus_admin = "postmaster\@$mydomain";
$X_HEADER_LINE = "Debian $myproduct_name using ClamAV at $mydomain";
and follow the rest

In /etc/spamassassin/local.cf


# Add *****SPAM***** to the Subject header of spam e-mails
#
# rewrite_header Subject *****SPAM*****


# Save spam messages as a message/rfc822 MIME attachment instead of
# modifying the original message (0: off, 2: use text/plain instead)
#
# report_safe 1


# Set which networks or hosts are considered 'trusted' by your mail
# server (i.e. not spammers)
#
# trusted_networks 212.17.35.


# Set file-locking method (flock is not safe over NFS, but is faster)
#
# lock_method flock


# Set the threshold at which a message is considered spam (default: 5.0)
#
# required_score 5.0

#dcc
use_dcc 1
dcc_path /usr/local/bin/dccproc
#pyzor
use_pyzor 1
pyzor_path /usr/bin/pyzor

#razor
use_razor2 1
razor_config /etc/razor/razor-agent.conf


# Use Bayesian classifier (default: 1)
#
use_bayes 1

use_bayes_rules 1


# Bayesian classifier auto-learning (default: 1)
#
bayes_auto_learn 1


# Set headers which may provide inappropriate cues to the Bayesian
# classifier
#
# bayes_ignore_header X-Bogosity
# bayes_ignore_header X-Spam-Flag
# bayes_ignore_header X-Spam-Status

What's wrong?
many thanks in advance
Reply With Quote
Sponsored Links
  #2  
Old 9th April 2009, 11:28
rieschl rieschl is offline
Junior Member
 
Join Date: Jul 2008
Location: Vienna
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi!

you have to lower the value of the "$sa_tag_level_deflt" variable (in /etc/amavis/20-debian_defaults) to 0 or lower and change the "@local_domains_acl" (in /etc/amavis/50-user) to "( . )" or the domains you would like to have checked.

hth

cheers
thomas
Reply With Quote
  #3  
Old 9th April 2009, 12:20
clark61 clark61 is offline
Junior Member
 
Join Date: Mar 2009
Location: Milano
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by rieschl View Post
hi!

you have to lower the value of the "$sa_tag_level_deflt" variable (in /etc/amavis/20-debian_defaults) to 0 or lower and change the "@local_domains_acl" (in /etc/amavis/50-user) to "( . )" or the domains you would like to have checked.

thomas
Hi thomas and many thanks for your reply.
my $sa_tag_level_deflt = -9999; in /etc/amavis/conf.d/20-debian_default
but I found local_"@local_domains_acl" in 05-domain_id not in 50-user.
So I must add by hand in 50-user?
Reply With Quote
  #4  
Old 9th April 2009, 12:53
rieschl rieschl is offline
Junior Member
 
Join Date: Jul 2008
Location: Vienna
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by clark61 View Post
Hi thomas and many thanks for your reply.
my $sa_tag_level_deflt = -9999; in /etc/amavis/conf.d/20-debian_default
but I found local_"@local_domains_acl" in 05-domain_id not in 50-user.
So I must add by hand in 50-user?
hi

sorry, my mistake.
I've got it in 05-domain_id and 50-user because I do every changes in 50-user to override previous settings so I can easily see all the changes I've made.

feel free to change/add whereever you want

cheers,
thomas
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Couple of questions on virtual users Stampy HOWTO-Related Questions 6 27th October 2008 22:43
Virtual users and domains... connection refused when testing w/ localhost Postman HOWTO-Related Questions 1 15th February 2007 10:02
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs mholownych HOWTO-Related Questions 10 29th May 2006 03:39
Problem with Virtual Users And Domains With Postfix, Courier And MySQL Howto fenix Server Operation 4 11th March 2006 02:53
Another Problem: Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP bluegrass Installation/Configuration 24 8th March 2006 01:41


All times are GMT +2. The time now is 15:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.