Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th March 2009, 19:51
HellMind HellMind is offline
Member
 
Join Date: Jul 2008
Posts: 99
Thanks: 4
Thanked 1 Time in 1 Post
Send a message via ICQ to HellMind Send a message via MSN to HellMind
Default Should I fix "[warn] NameVirtualHost 'ip' has no VirtualHosts

/etc/cron.daily/logrotate:
[Sun Mar 29 06:25:09 2009] [warn] NameVirtualHost 190.210.x.x:80 has no VirtualHosts
[Sun Mar 29 06:25:09 2009] [warn] NameVirtualHost 190.210.x.x:443 has no VirtualHosts

Should/Can I fix it?
Reply With Quote
Sponsored Links
  #2  
Old 30th March 2009, 12:27
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,218 Times in 4,090 Posts
Default

There is no need to do anything, but you can remove the ip's from the ip list as you dont have virtual hosts with these IP's.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 30th March 2009, 18:21
HellMind HellMind is offline
Member
 
Join Date: Jul 2008
Posts: 99
Thanks: 4
Thanked 1 Time in 1 Post
Send a message via ICQ to HellMind Send a message via MSN to HellMind
Default

Then I create a site I use IP * is that bad?
__________________
Ispconfig 3 Latest Version (Stable)
Debian Squeeze (esix vm)
Reply With Quote
  #4  
Old 30th March 2009, 19:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,218 Times in 4,090 Posts
Default

No, why should that be bad? By the way, If you would have created a site with that Ip the error message would not have been appeared.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 30th March 2009, 19:43
HellMind HellMind is offline
Member
 
Join Date: Jul 2008
Posts: 99
Thanks: 4
Thanked 1 Time in 1 Post
Send a message via ICQ to HellMind Send a message via MSN to HellMind
Default

I think that error appear because I configured ispconfig with that ip but not the in sites.
__________________
Ispconfig 3 Latest Version (Stable)
Debian Squeeze (esix vm)
Reply With Quote
  #6  
Old 1st November 2009, 18:13
HellMind HellMind is offline
Member
 
Join Date: Jul 2008
Posts: 99
Thanks: 4
Thanked 1 Time in 1 Post
Send a message via ICQ to HellMind Send a message via MSN to HellMind
Default

Quote:
Originally Posted by till View Post
There is no need to do anything, but you can remove the ip's from the ip list as you dont have virtual hosts with these IP's.
Where is that ip list you are talking about?
__________________
Ispconfig 3 Latest Version (Stable)
Debian Squeeze (esix vm)
Reply With Quote
  #7  
Old 2nd November 2009, 09:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,218 Times in 4,090 Posts
Default

System > Server IP addresses.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 26th May 2011, 04:45
defconjuan defconjuan is offline
Junior Member
 
Join Date: Apr 2011
Posts: 17
Thanks: 1
Thanked 2 Times in 1 Post
 
Default

I know this is old but I came accross this and it bugged the heck out of me (I hate error messages).

[warn] NameVirtualHost *:443 has no VirtualHosts

Simply Put: Apache is listening on 443 but there are no VirtualHosts (websites) defined on that port. (See /etc/apache2/ports.conf):
Code:
NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
    NameVirtualHost *:443
    Listen 443
</IfModule>

<IfModule mod_gnutls.c>
    NameVirtualHost *:443
    Listen 443
</IfModule>
You have two options to get rid of the harmless error message:

Option 1 - Enable the default SSL config (Preferred, less destructive)
Define a site on 443 (the easiest way is to run the following code):
Code:
ln -s /etc/apache2/sites-available/default-ssl 000-default-ssl
# then restart apache
/etc/init.d/apache2 restart
Option 2 - Unbind Apache from Port 443
Comment out the "NameVirtualHost *:443" and "Listen 443" lines of /etc/apache2/ports.conf (e.g. add a # symbol in from of those lines so the new ports config file looks something like
Code:
NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
    # NameVirtualHost *:443
    # Listen 443
</IfModule>

<IfModule mod_gnutls.c>
    # NameVirtualHost *:443
    # Listen 443
</IfModule>
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig 3.0.0.9 ([warn] NameVirtualHost IP...:80 has no VirtualHosts) edge Installation/Configuration 5 2nd August 2009 06:57
Apache2 Errors Web-Sites Won't Load giganet Installation/Configuration 4 1st January 2009 19:00
apache wont start after deleting a site tellar Installation/Configuration 1 2nd October 2008 15:34
apache wont start after deleting a site tellar Installation/Configuration 2 1st October 2008 16:49
NameVirtualHost www.mysite.it has no VirtualHosts gabrix Server Operation 20 23rd March 2007 18:27


All times are GMT +2. The time now is 08:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.