Prev Previous Post   Next Post Next
  #1  
Old 26th August 2005, 04:48
SidSkiba SidSkiba is offline
Junior Member
 
Join Date: Aug 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default Newbie questions

I just installed ISP config following the SuSE how to and I must admit it is a very impressive piece of work. This is my first attempt at using Linux as a Web Host (not that I have done it a lot anyway). Very used to windows so a bit of a learning curve here.

My questions are related to some configuration needs as a result of my setup.

First the setup. I am behind a NAT firewall. I will forward only the ports required by the outside world. WWW, SSL, SMTP, POP, etc. Maybe FTP in the future.

All web development will be behind the NAT firewall and all ISP config access is behind the NAT Firewall.

My question is related to the web site of the ISP machine. For example (not using real domain names). ISPConfig Server is set up as webserver.domain.com. I have 1 web site on the machine called www.domain2.com. If I do http://webserver.domain.com the browser displays www.domain2.com site. Both are on the same IP address. If I use http://192.168.100.1 (IP of machine) it displays www.domain2.com.

domain.com would be a real internet domain. Thus I would like anyone going to the IP address or going to www.domain.com to see a site called www.domain.com and not www.domain2.com as it does now.

Is there a way to do this or what am I missing in the configuration?

Also I notice if I open up port 21 on the NAT and try doing ftp://www.domain.com that I cannot connect. I can connect fine with ftp://192.168.100.1 I am unsure if this is a NAT issue with ProFTP or something like that. Perhaps you can advise? I do not really need FTP access from outside today but may need it in the future.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Quick Question(s) Apache 2 linutzy Technical 19 16th August 2006 16:20
Script questions && Gentoo version hagel Feature Requests 4 7th May 2006 13:19
Newbie question thedude General 2 15th August 2005 14:38


All times are GMT +2. The time now is 11:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.