Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th March 2009, 17:24
NEIM777 NEIM777 is offline
Junior Member
 
Join Date: Feb 2009
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Unhappy Error trying to install mod_ruby using OPenSuse 11.1

Hi I am installing this webserver OPs 11.1..I got this far

cd /tmp
wget http://www.modruby.net/archive/mod_ruby-1.2.6.tar.gz
tar zxvf mod_ruby-1.2.6.tar.gz
cd mod_ruby-1.2.6/
./configure.rb --with-apr-includes=/usr/include/apr-1

error occurs right after executing the ./configure.rb - ......

{/usr/bin/env: python: No such file or directory}



Any assistance will be gladly appreciated
Reply With Quote
Sponsored Links
  #2  
Old 12th March 2009, 17:58
NEIM777 NEIM777 is offline
Junior Member
 
Join Date: Feb 2009
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Default Error trying to install mod_ruby using OPenSuse 11.1

JASI0WEBSVR:/home/neim777 # cd /tmp
JASI0WEBSVR:/tmp # wget http://www.modruby.net/archive/mod_ruby-1.2.6.tar.gz
--2009-03-12 11:28:11-- http://www.modruby.net/archive/mod_ruby-1.2.6.tar.gz
Resolving www.modruby.net... 221.186.184.67
Connecting to www.modruby.net|221.186.184.67|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 110886 (108K) [application/x-tar]
Saving to: `mod_ruby-1.2.6.tar.gz.4'

100%[================================================== ================================================== ==============================>] 110,886 88.5K/s in 1.2s

2009-03-12 11:28:13 (88.5 KB/s) - `mod_ruby-1.2.6.tar.gz.4' saved [110886/110886]

JASI0WEBSVR:/tmp # cd mod_ruby-1.2.6/
JASI0WEBSVR:/tmp/mod_ruby-1.2.6 # ./configure.rb --with-apr-includes=/usr/include/apr-1
/usr/bin/env: ruby: No such file or directory
JASI0WEBSVR:/tmp/mod_ruby-1.2.6 #
Reply With Quote
  #3  
Old 13th March 2009, 15:01
NEIM777 NEIM777 is offline
Junior Member
 
Join Date: Feb 2009
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Angry Error trying to install mod_ruby using OPenSuse 11.1

Good Morning to everyone..I still need someones help.I looked and searched and butchered the Web looking for a solution..I know the answer is just to edit some file header.....but which file..

This is a new install which I am following Falko's how to build the perfect OpenSuse 11.1 server
Reply With Quote
  #4  
Old 13th March 2009, 18:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Please install the packages python and ruby.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 13th March 2009, 20:37
NEIM777 NEIM777 is offline
Junior Member
 
Join Date: Feb 2009
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Default Error trying to install mod_ruby using OPenSuse 11.1

Did that and did it again,,followed your instructions carefully..Same issue

yast -i apache2-devel ruby ruby-devel
Reply With Quote
  #6  
Old 14th March 2009, 06:59
NEIM777 NEIM777 is offline
Junior Member
 
Join Date: Feb 2009
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
 
Default RESOLVED! !!trying to install mod_ruby using OPenSuse 11.1

I reinstalled python and installed ruby 1.3.0 instead of 1.2.6
Reply With Quote
The Following User Says Thank You to NEIM777 For This Useful Post:
falko (14th March 2009)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Install failure -- Apache 1.3 missing? Allen15 Installation/Configuration 11 24th February 2009 10:53
can't help ispconfig to install please help steve51184 Installation/Configuration 17 20th February 2009 11:37
How to install OpenOficeOrg 3.0.0 in Ubuntu 8.04 ernesthagger HOWTO-Related Questions 43 23rd December 2008 15:42
OpenSUSE 11.x and dmraid witn JMircon (GSATA) and isw (ICH10) HOW install on RAID1 ? den812 HOWTO-Related Questions 0 11th September 2008 23:05
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 11:46


All times are GMT +2. The time now is 04:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.