#1  
Old 24th February 2006, 22:08
lerra lerra is offline
Member
 
Join Date: Jan 2006
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts
Default catch all for apache?

Is that posseble? I cant get it working to catch all mail.* domains to point that to a webmail page.

<VirtualHost ip:80>
Servername mail.domain.com
ServerAlias mail.*
ServerAdmin me@domain.com
DocumentRoot /var/www/webmail/
</VirtualHost>

Any tip?
Reply With Quote
Sponsored Links
  #2  
Old 25th February 2006, 10:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,672
Thanks: 819
Thanked 5,317 Times in 4,170 Posts
Default

I'am not sure, but as far as i remember you can do wildcards like *.domain.com but not host.*
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 1st March 2006, 00:14
lerra lerra is offline
Member
 
Join Date: Jan 2006
Posts: 77
Thanks: 0
Thanked 0 Times in 0 Posts
Default

So with other words, there is no sollution? What about site/webmail etc? that woud be nice too..
Reply With Quote
  #4  
Old 1st March 2006, 10:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by lerra
So with other words, there is no sollution?
No.

Quote:
Originally Posted by lerra
What about site/webmail etc? that woud be nice too..
Can you explain a bit more?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 2nd March 2006, 11:10
st2xo st2xo is offline
Member
 
Join Date: Jan 2006
Location: Wiesloch [DE]
Posts: 47
Thanks: 3
Thanked 0 Times in 0 Posts
Default

I set up that webmail-host configuration at my site and it works well.

/etc/apache2/vhosts/Vhosts_ispconfig.conf
Code:
NameVirtualHost 213.133.100.91:80
<VirtualHost 213.133.100.91:80>
  # edit this vHost template in  /root/ispconfig/scripts/lib/config.lib.php
  # otherwise it will be overwritte on every host change in ISPConfig!
  ServerName localhost
  ServerAdmin root@localhost
  # This will be the default root for domains connected on this server 
  # but with no ISPConfig setup
  # put in there a index.html like "this domain is connected - no homepage available"
  DocumentRoot /home/HOSTNAME/public_n05
</VirtualHost>
this is the first virtual host setting in Vhosts_ispconfig.conf and will be overwritten every time you change host settings with ISPConfig - so you have to patch the config.lib.php near line 1231 - search for the textphrase "NameVirtualHost schreiben"

now adding the subdomain webmail.* for every host on the system:

/etc/apache2/vhosts.d/HOSTNAME.conf
Code:
<VirtualHost 192.168.0.1:80>
  ServerName webmail.HOSTNAME.de
  ServerAlias webmail.*
  ServerAdmin root@localhost
  DocumentRoot /home/USER/public_webmail
  CustomLog /var/log/apache2/webmail.HOSTNAME.de.log combined
</VirtualHost>
I dont know what happens, if you add a subdomain "webmail" directly in the ISPConfig Hostsetting. Look in httpd.conf which *conf-directory will be read by apache at first. I think the first *.conf wins the match ...

other virtual hosts in vhosts.d will work with the same procedure, e.g.
ServerAlias config.*
ServerAlias phpmyadmin.*
the index.html´s in that public_html - directorys redirects the users to the correct sites
https://HOSTNAME.de:81/phpmyadmin/
https://HOSTNAME.de:81/login.php
and so the users only have to know the easy to type hostname like webmail.MySite.de or phpmyadmin.MySite.com and what ever you like.

hope that helps ....
__________________
regards,
Stefan.
Reply With Quote
  #6  
Old 2nd March 2006, 11:29
st2xo st2xo is offline
Member
 
Join Date: Jan 2006
Location: Wiesloch [DE]
Posts: 47
Thanks: 3
Thanked 0 Times in 0 Posts
 
Default

I forget something

you have to edit the /etc/apache/httpd.conf
insert

Code:
<directory ~ "/public_webmail|public_phpmyadmin|public_config/">
    AllowOverride None
    Order allow,deny
    Allow from all
</directory>
__________________
regards,
Stefan.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
E-mail only works w/ web#_user Geoinline Installation/Configuration 12 31st January 2006 18:07


All times are GMT +2. The time now is 18:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.