Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th February 2009, 21:43
richi richi is offline
HowtoForge Supporter
 
Join Date: Apr 2007
Posts: 12
Thanks: 1
Thanked 1 Time in 1 Post
Default Postfix - Reject incoming email for specific user

Hi Folks,

while using ISPconfig for quite a long time i was confronted with the fact of growing files within the /var/spool/mail directory.

I think this happens because postfix accepts mail for every system user which is the normal behaviour?!

So even when postfix is configured to accept mail only for "valid email users" that are mapped via virtusertable to "real system users", emails for the Linux "default users" like nobody uucp or mail are accepted and delivered.

One solution to this is to reject those unwanted mails using smtpd_recipient_restrictions defined within main.cf.

Adding there "check_recipient_access hash:/etc/postfix/denied_recipients" before the "permit_mynetworks" statement allows you to reject those unwanted mails.

After adding them to this file (one address per line) in the form of

uucp@mydomain.tld REJECT recipient rejected

dont forget to run

postsuper /etc/postfix/denied_recipients

and restart postfix.

On my systems i am using Debian Etch and perhaps there are other ways to achieve this, but for me it did the trick.

Last edited by richi; 18th February 2009 at 00:14.
Reply With Quote
The Following User Says Thank You to richi For This Useful Post:
CubAfull (9th March 2009)
Sponsored Links
  #2  
Old 18th February 2009, 10:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Quote:
I think this happens because postfix accepts mail for every system user which is the normal behaviour?!
If you dont wabt this behaviour, change the email style from sendmail to postfix in the config.inc.php file and then change a email user in ispconfig to update the config files.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 19th February 2009, 14:43
richi richi is offline
HowtoForge Supporter
 
Join Date: Apr 2007
Posts: 12
Thanks: 1
Thanked 1 Time in 1 Post
Default

Thanks for the Info, but since the "sendmail style" is the default for ISPconfig i would have to change this with every update of the Software. So the other solution keeps working after the update without additional configuration, or do i miss something here?
Reply With Quote
  #4  
Old 19th February 2009, 16:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
 
Default

ISPConfig remembers its config settings
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
debian, postfix, reject

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail server using Postfix, Dovecot, Mysql... Postfix virtual maps doesn't work?? tarasbuljba HOWTO-Related Questions 33 28th May 2010 15:33
Postfix Email Delivery Problem sedat1903 HOWTO-Related Questions 2 22nd December 2008 12:19
Create user and email script TheRudy Programming/Scripts 0 7th June 2008 12:15
Ruby / FastCGI Problem Chad Server Operation 1 8th March 2008 21:38
Verify email setup meekish Installation/Configuration 28 27th October 2006 16:36


All times are GMT +2. The time now is 16:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.