#1  
Old 24th January 2009, 14:18
altaibskt altaibskt is offline
Member
 
Join Date: Jan 2009
Posts: 33
Thanks: 4
Thanked 0 Times in 0 Posts
Default DNS problem with ubuntu

Hi there!

please help me with my dns configuration, i am not good in linux and and i am so beginner, i made the dns configure mentioned in the tutorial but it didn't work at all,

now the problem that i missed with the dns files...

i need some hep to re-install the dns and reconfigure it i am so triad i spent to weeks trying to fixed and i googled it many mant time and did not find any good tutorials for beginners.

when i want to start the dns

Quote:
root@aaaa:~# /etc/init.d/bind9 restart
* Stopping domain name service... bind9
rndc: connect failed: 127.0.0.1#953: connection refused [fail]
* Starting domain name service... bind9 [fail]


my network interface is:

Quote:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).
# The loopback network interface
auto lo
iface lo inet loopback
# The primary network interface
the output from
sudo vi /etc/hosts
is

Quote:
127.0.0.1 localhost server.localhost
172.17.207.33 iraqi-eng.homelinux.local server server01.local
theoutput from
sudo /etc/init.d/named start

Quote:
root@iraqi-eng:~# sudo /etc/init.d/named start
sudo: /etc/init.d/named: command not found
root@iraqi-eng:~#


pls i need help to reconfigure the dns and fix all my files...

Reply With Quote
Sponsored Links
  #2  
Old 24th January 2009, 16:11
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,158
Thanks: 4
Thanked 58 Times in 54 Posts
Default

what tutorial did you follow?
__________________
"Common sense is not as common as commonly believed" by sjau

Auto-Install Script for ISPConfig and Horde on a Vanilla Debian Stable

Need more Repos for Ubuntu? Repository Generator
Need more Repos for Debian? Debian Repository Generator
Reply With Quote
  #3  
Old 24th January 2009, 18:58
altaibskt altaibskt is offline
Member
 
Join Date: Jan 2009
Posts: 33
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by sjau View Post
what tutorial did you follow?
thanx fot the reply

i did the configuration in these tutorials
http://www.howtoforge.com/perfect-server-ubuntu-8.10
http://www.howtoforge.com/nat-gatewa...tu-8.10-server
Reply With Quote
  #4  
Old 25th January 2009, 15:47
altaibskt altaibskt is offline
Member
 
Join Date: Jan 2009
Posts: 33
Thanks: 4
Thanked 0 Times in 0 Posts
Default

up
up..
up..
Reply With Quote
  #5  
Old 25th January 2009, 17:42
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,158
Thanks: 4
Thanked 58 Times in 54 Posts
Default

try to purge bind and reinstall it.
__________________
"Common sense is not as common as commonly believed" by sjau

Auto-Install Script for ISPConfig and Horde on a Vanilla Debian Stable

Need more Repos for Ubuntu? Repository Generator
Need more Repos for Debian? Debian Repository Generator
Reply With Quote
  #6  
Old 25th January 2009, 19:26
altaibskt altaibskt is offline
Member
 
Join Date: Jan 2009
Posts: 33
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by sjau View Post
try to purge bind and reinstall it.
i did and still have the same problems
Reply With Quote
  #7  
Old 25th January 2009, 20:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
 
Default

Try
Code:
/etc/init.d/bind9 start
Also make sure that AppArmor is disabled.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
dns problem, install dns, reconfigure dns, ubuntu 8.10

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
#Problem# DNS SERVER #Problem# symmathites Installation/Configuration 2 28th June 2008 18:24
Virtual users... Ubuntu 8.04 spaceuser HOWTO-Related Questions 12 19th June 2008 09:04
DNS confusion and setting up subdomains on ISPConfig on Ubuntu 6.06 wctaelectronics Installation/Configuration 3 9th May 2008 01:25
Problem on restart bind9 satimis Server Operation 6 30th October 2007 03:01
two-in-one DNS server - problem with views sPENKMAN HOWTO-Related Questions 5 20th February 2007 18:32


All times are GMT +2. The time now is 16:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.