Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd February 2006, 19:33
mojosound mojosound is offline
Junior Member
 
Join Date: Feb 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default New Site Shows Apache Default page not uploaded index.html

I am new to this and learning so please bear with me. I have mandriva 2006. I setup ispconfig. My router is assigned ip 216.144.242.27. The pc has a static ip of 192.168.4.2. I created a new site www.cjt-design.com. I set the ip address to 216.144.242.27. I did not set dns, because I have other dns already. This was an existing site, so I changed the zone file a record for www.cjt-design.com to 216.144.242.27. The propogation is still in progress, but I have been able to see that the page that comes up for www.cjt-design.com just shows "It Works" which is the default apache web page for the mandriva linux. I have uploaded an index page that is different through the web ftp. I have tried changing the ip address in the site settings to 192.168.4.2, but this made no difference. I tried to search, but perhaps don't know the right terms to search for. Any help is appreciated.
Reply With Quote
Sponsored Links
  #2  
Old 23rd February 2006, 19:56
Plascual Plascual is offline
Junior Member
 
Join Date: Feb 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I got the same problem. It comes up with the apache2-default page instead of the "Welcome to ... !" page.

http://www.howtoforge.com/forums/showthread.php?t=2653

I searched anything related to "apache2-default", "vhost", etc... but didn't find a solution yet.
Reply With Quote
  #3  
Old 23rd February 2006, 22:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,729 Times in 2,567 Posts
Default

Quote:
Originally Posted by mojosound
I am new to this and learning so please bear with me. I have mandriva 2006. I setup ispconfig. My router is assigned ip 216.144.242.27. The pc has a static ip of 192.168.4.2. I created a new site www.cjt-design.com. I set the ip address to 216.144.242.27. I did not set dns, because I have other dns already. This was an existing site, so I changed the zone file a record for www.cjt-design.com to 216.144.242.27. The propogation is still in progress, but I have been able to see that the page that comes up for www.cjt-design.com just shows "It Works" which is the default apache web page for the mandriva linux. I have uploaded an index page that is different through the web ftp. I have tried changing the ip address in the site settings to 192.168.4.2, but this made no difference. I tried to search, but perhaps don't know the right terms to search for. Any help is appreciated.
What's in your Vhosts_ispconfig.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 24th February 2006, 01:48
mojosound mojosound is offline
Junior Member
 
Join Date: Feb 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The file Vhost_ispconfig.conf is empty.
Reply With Quote
  #5  
Old 24th February 2006, 02:43
mojosound mojosound is offline
Junior Member
 
Join Date: Feb 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Upon further research I discovered that there were several files with date and time stamps in their names. I picked the newest one and put into the Vhost_ispconfig.conf file. I was then able to get the site. I tried adding another site but the conf file did not get updated. Again I copied from the file with the newest timestamp and both sites are up. What do I need to do to get this to update?
Reply With Quote
  #6  
Old 24th February 2006, 10:51
dfriis dfriis is offline
Junior Member
 
Join Date: Feb 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same problem too and since I've reinstalled this machine ten times now I'm starting to get a bit desperate.

When I comment out
Code:
RedirectMatch ^/$ /apache2-default/
I only see a listing of apache2-default, sharedip and webalizer. You can see what it looks like at http://friisweb.se.

My Vhosts_ispconfig.conf is NOT blank and looks like it is in order. The file is also included in apache2.conf.

I've followed the guide for "The perfect setup - debian sarge", but I get this same problem over and over. All looks good, nothing works.

I will give you all the information you need if you feel like helping me with this.

Thanks
Reply With Quote
  #7  
Old 24th February 2006, 12:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,729 Times in 2,567 Posts
Default

Quote:
Originally Posted by mojosound
Upon further research I discovered that there were several files with date and time stamps in their names. I picked the newest one and put into the Vhost_ispconfig.conf file. I was then able to get the site. I tried adding another site but the conf file did not get updated. Again I copied from the file with the newest timestamp and both sites are up. What do I need to do to get this to update?
If Vhosts_ispconfig.conf is empty it is likely that some module that is needed is not included in your Apache configuration.
After you've renamed one of these Vhosts_ispconfig.conf files with a date appended to Vhosts_ispconfig.conf, please run
Code:
httpd -t
What's the output?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 24th February 2006, 12:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,729 Times in 2,567 Posts
Default

Quote:
Originally Posted by dfriis
I have the same problem too and since I've reinstalled this machine ten times now I'm starting to get a bit desperate.

When I comment out
Code:
RedirectMatch ^/$ /apache2-default/
I only see a listing of apache2-default, sharedip and webalizer. You can see what it looks like at http://friisweb.se.

My Vhosts_ispconfig.conf is NOT blank and looks like it is in order. The file is also included in apache2.conf.

I've followed the guide for "The perfect setup - debian sarge", but I get this same problem over and over. All looks good, nothing works.

I will give you all the information you need if you feel like helping me with this.

Thanks
Please post the output of
Code:
httpd -V
Anything in the Apache error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 24th February 2006, 12:16
dfriis dfriis is offline
Junior Member
 
Join Date: Feb 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

httpd -V gives:

Server version: Apache/2.0.54
Server built: Sep 5 2005 11:15:09
Server's Module Magic Number: 20020903:9
Architecture: 32-bit
Server compiled with....
-D APACHE_MPM_DIR="server/mpm/prefork"
-D APR_HAS_SENDFILE
-D APR_HAS_MMAP
-D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
-D APR_USE_SYSVSEM_SERIALIZE
-D APR_USE_PTHREAD_SERIALIZE
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D HTTPD_ROOT=""
-D SUEXEC_BIN="/usr/lib/apache2/suexec2"
-D DEFAULT_PIDLOG="/var/run/httpd.pid"
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
-D DEFAULT_LOCKFILE="/var/run/accept.lock"
-D DEFAULT_ERRORLOG="logs/error_log"
-D AP_TYPES_CONFIG_FILE="/etc/apache2/mime.types"
-D SERVER_CONFIG_FILE="/etc/apache2/apache2.conf"

I found one error in the logs. Seems apache is looking in /var/www/web1 for the added site, but standard is /home/www..., isn't it? Changing that in ispconfig makes changes to the added site but I still only see a file listing, and it seems I end up at the server root, not in web1. Should I change it in apache? There's too many things to configure and I'm confused here.
Reply With Quote
  #10  
Old 24th February 2006, 13:20
mojosound mojosound is offline
Junior Member
 
Join Date: Feb 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

[root@cjt-design-server chris]# httpd -V
Server version: Apache/2.0.54
Server built: Jan 5 2006 11:10:01
Server's Module Magic Number: 20020903:9
Architecture: 32-bit
Server compiled with....
-D APACHE_MPM_DIR="server/mpm/prefork"
-D APR_HAS_SENDFILE
-D APR_HAS_MMAP
-D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
-D APR_USE_FCNTL_SERIALIZE
-D APR_USE_PTHREAD_SERIALIZE
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D HTTPD_ROOT="/etc/httpd"
-D SUEXEC_BIN="/usr/sbin/suexec"
-D DEFAULT_PIDLOG="/var/run/httpd.pid"
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
-D DEFAULT_LOCKFILE="/var/run/accept.lock"
-D DEFAULT_ERRORLOG="logs/error_log"
-D AP_TYPES_CONFIG_FILE="conf/mime.types"
-D SERVER_CONFIG_FILE="conf/httpd.conf"
[root@cjt-design-server chris]#
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Default Mail scan settings for new users timehost Installation/Configuration 3 26th October 2007 12:05
Sites that are added using ISPConfig Tool direct to Apache page gimhan90 Installation/Configuration 11 13th February 2006 10:27
Easy One - ISPConfig Default Holding Page mphayesuk General 1 27th November 2005 18:30
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs pontifex HOWTO-Related Questions 2 26th October 2005 17:54
WHere is the default domain's web page? Bedevere Installation/Configuration 4 28th August 2005 20:14


All times are GMT +2. The time now is 07:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.