Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 6th January 2009, 11:47
Antennipasi Antennipasi is offline
ISPConfig Developer
 
Join Date: Dec 2008
Location: Finland
Posts: 67
Thanks: 6
Thanked 13 Times in 12 Posts
Default ISPC3: spamfilter_policy-problem with php-mail

yesterday i had first major problem with ISPC3.
i am taking it to production in steps, moving our own domains to it from Plesk. yesterday i moved one wich had forum in it. forum send mails with php-mail function to thread subscribes, and because forum is finnish language, message headers contain local characters.

problem was that those messages did not go thru ISPConfig to mailboxes in other domains allready moved to ISPC3 because they gor blocked by Amavisd&postfix with message:

Code:
amavis[2023]: (02023-08) Blocked BAD-HEADER ....snip...
postfix/smtp[17449]: ..snip.. (250 2.6.0 Ok, discarded, id=16826-01 - BAD_HEADER: Non-encoded 8-bit data ..snip..
when searching for reason, i found out that ISPConfigs own greetings-messages got stuck too because same reason. but these got passed earlier. so my eyes missed changes somewhere.

i fixed this by changing all spamfilter_policy:bypass_header_checks to "Y" in database.
i dont think this is really bug, amavis is just following settings that is given to it, and php-mail is not coding headers righ. but this behavior could cause lot of problems if not known by admin.

otherwise, it seemed messages was blocked also when smamfilter was off for destination domain, and that is a bug. i try to verify this later.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
just the last step...and it works. Postfix...need help config. ubuntusr Installation/Configuration 1 5th January 2009 09:50
ispconfig php 5 errors itamarjp Installation/Configuration 8 25th April 2008 10:20
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 09:40


All times are GMT +2. The time now is 17:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.