Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd December 2008, 00:15
Taxick Taxick is offline
Junior Member
 
Join Date: Dec 2008
Posts: 28
Thanks: 9
Thanked 4 Times in 4 Posts
Default User unknown in relay recipient table

Hallo,

Sorry for my bad english, im from denmark

I have some problems. I have just follow this guide and installed ISPConfig 2 x!

I can send mail to all, and thay reserve my mails, but some peple can´t send mails to me.

When thay try to send mail to me, thay get this mail back:
Code:
'******@wub.nu' den 21-12-2008 23:44
550 5.1.1 <******@wub.nu>: Recipient address rejected: User unknown in relay recipient table
Code:
'******@halfdaner.dk' den 21-12-2008 23:44
550 5.1.1 <******@halfdaner.dk>: Recipient address rejected: User unknown in relay recipient table
Before i install debian, and run with windows all peple cud send me mail, but not now.

I have check my server, and the server is not blacklisted.

Serverip 1: 87.118.126.228
Serverip 2: 87.118.127.228
Hostname: server.wub.nu

What can be wrong???? Hope someone can help me with my problem.



main.cf


Code:
 See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = server.wub.nu
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
#mydestination = server.wub.nu, localhost.wub.nu, , localhost.localdomain, localhost
relayhost = 
mynetworks = 127.0.0.0/8
mailbox_command = 
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain = 
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names


postconf -n


Code:
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
home_mailbox = Maildir/
inet_interfaces = all
inet_protocols = all
mailbox_command = 
mailbox_size_limit = 0
mydestination = /etc/postfix/local-host-names
myhostname = server.wub.nu
mynetworks = 127.0.0.0/8
myorigin = /etc/mailname
recipient_delimiter = +
relayhost = 
smtp_tls_note_starttls_offer = yes
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
smtp_use_tls = yes
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = 
smtpd_sasl_security_options = noanonymous
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom


mail.log


Code:
Dec 21 23:50:06 server postfix/local[13161]: 7CB7134EC1F4: to=<web12_******@server.wub.nu>, orig_to=<******@halfdaner.dk>, relay=local, delay=3.4, delays=0.65/0/0/2.8, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Dec 21 23:50:06 server postfix/qmgr[3264]: 7CB7134EC1F4: removed
Dec 21 23:50:29 server courierpop3login: Connection, ip=[::ffff:80.162.96.198]
Dec 21 23:50:29 server courierpop3login: LOGIN, user=web12_*******, ip=[::ffff:80.162.96.198]
Dec 21 23:50:33 server courierpop3login: LOGOUT, user=web12_*******, ip=[::ffff:80.162.96.198], top=0, retr=4151, rcvd=56, sent=4527, time=4
Dec 21 23:50:33 server courierpop3login: Connection, ip=[::ffff:80.162.96.198]
Dec 21 23:50:33 server courierpop3login: LOGIN, user=web12_msn, ip=[::ffff:80.162.96.198]
Dec 21 23:50:33 server courierpop3login: LOGOUT, user=web12_msn, ip=[::ffff:80.162.96.198], top=0, retr=0, rcvd=12, sent=39, time=0
Dec 21 23:50:33 server courierpop3login: Connection, ip=[::ffff:80.162.96.198]
Dec 21 23:50:34 server courierpop3login: LOGIN, user=web12_mail, ip=[::ffff:80.162.96.198]
Dec 21 23:50:34 server courierpop3login: LOGOUT, user=web12_mail, ip=[::ffff:80.162.96.198], top=0, retr=0, rcvd=12, sent=39, time=0
Dec 21 23:50:34 server courierpop3login: Connection, ip=[::ffff:80.162.96.198]
Dec 21 23:50:34 server courierpop3login: LOGIN, user=web14_contact, ip=[::ffff:80.162.96.198]
Dec 21 23:50:35 server courierpop3login: LOGOUT, user=web14_contact, ip=[::ffff:80.162.96.198], top=0, retr=0, rcvd=12, sent=39, time=1
Dec 21 23:50:35 server courierpop3login: Connection, ip=[::ffff:80.162.96.198]
Dec 21 23:50:35 server courierpop3login: LOGIN, user=web14_taxick, ip=[::ffff:80.162.96.198]
Dec 21 23:50:35 server courierpop3login: LOGOUT, user=web14_taxick, ip=[::ffff:80.162.96.198], top=0, retr=0, rcvd=12, sent=39, time=0
Dec 21 23:50:35 server courierpop3login: Connection, ip=[::ffff:80.162.96.198]
Dec 21 23:50:36 server courierpop3login: LOGIN, user=web14_no-reply, ip=[::ffff:80.162.96.198]
Dec 21 23:50:36 server courierpop3login: LOGOUT, user=web14_no-reply, ip=[::ffff:80.162.96.198], top=0, retr=0, rcvd=12, sent=39, time=0
Dec 21 23:51:53 server courierpop3login: Connection, ip=[::ffff:80.162.96.198]
Dec 21 23:51:53 server courierpop3login: LOGIN, user=web12_*******, ip=[::ffff:80.162.96.198]
Dec 21 23:51:53 server courierpop3login: LOGOUT, user=web12_*******, ip=[::ffff:80.162.96.198], top=0, retr=0, rcvd=12, sent=39, time=0
Dec 21 23:51:53 server courierpop3login: Connection, ip=[::ffff:80.162.96.198]
Dec 21 23:51:54 server courierpop3login: LOGIN, user=web12_msn, ip=[::ffff:80.162.96.198]
Dec 21 23:51:54 server courierpop3login: LOGOUT, user=web12_msn, ip=[::ffff:80.162.96.198], top=0, retr=0, rcvd=12, sent=39, time=0
Dec 21 23:51:54 server courierpop3login: Connection, ip=[::ffff:80.162.96.198]
Dec 21 23:51:54 server courierpop3login: LOGIN, user=web12_mail, ip=[::ffff:80.162.96.198]
Dec 21 23:51:54 server courierpop3login: LOGOUT, user=web12_mail, ip=[::ffff:80.162.96.198], top=0, retr=0, rcvd=12, sent=39, time=0
Dec 21 23:51:54 server courierpop3login: Connection, ip=[::ffff:80.162.96.198]
Dec 21 23:51:55 server courierpop3login: LOGIN, user=web14_contact, ip=[::ffff:80.162.96.198]
Dec 21 23:51:55 server courierpop3login: LOGOUT, user=web14_contact, ip=[::ffff:80.162.96.198], top=0, retr=0, rcvd=12, sent=39, time=0
Dec 21 23:51:55 server courierpop3login: Connection, ip=[::ffff:80.162.96.198]
Dec 21 23:51:55 server courierpop3login: LOGIN, user=web14_taxick, ip=[::ffff:80.162.96.198]
Dec 21 23:51:55 server courierpop3login: LOGOUT, user=web14_taxick, ip=[::ffff:80.162.96.198], top=0, retr=0, rcvd=12, sent=39, time=0
Dec 21 23:51:56 server courierpop3login: Connection, ip=[::ffff:80.162.96.198]
Dec 21 23:51:56 server courierpop3login: LOGIN, user=web14_no-reply, ip=[::ffff:80.162.96.198]
Dec 21 23:51:56 server courierpop3login: LOGOUT, user=web14_no-reply, ip=[::ffff:80.162.96.198], top=0, retr=0, rcvd=12, sent=39, time=0
Dec 21 23:53:24 server postfix/anvil[12924]: statistics: max connection rate 1/60s for (smtp:212.97.132.190) at Dec 21 23:44:57
Dec 21 23:53:24 server postfix/anvil[12924]: statistics: max connection count 1 for (smtp:212.97.132.190) at Dec 21 23:44:57
Dec 21 23:53:24 server postfix/anvil[12924]: statistics: max cache size 2 at Dec 21 23:45:29
Dec 21 23:59:01 server postfix/master[3258]: terminating on signal 15
Dec 21 23:59:01 server postfix/master[13575]: daemon started -- version 2.3.8, configuration /etc/postfix

Last edited by Taxick; 22nd December 2008 at 04:56.
Reply With Quote
Sponsored Links
  #2  
Old 22nd December 2008, 11:39
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Are the domains wub.nu and halfdaner.dk listed in /etc/postfix/local-host-names ?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Taxick (24th December 2008)
  #3  
Old 22nd December 2008, 14:57
Taxick Taxick is offline
Junior Member
 
Join Date: Dec 2008
Posts: 28
Thanks: 9
Thanked 4 Times in 4 Posts
Default

Quote:
Originally Posted by till View Post
Are the domains wub.nu and halfdaner.dk listed in /etc/postfix/local-host-names ?
Yes..

Code:
###################################
#
# ISPConfig local-host-names Configuration File
#         Version 1.0
#
###################################
localhost
server.wub.nu
localhost.server.wub.nu
localhost.wub.nu
localhost.localdomain
www.wub.nu
www.forum.wub.nu
www.clan.wub.nu
www.stats.wub.nu
www.webmail.wub.nu
www.sd-5.dk
www.sd-6.dk
www.tsadmin.wub.nu
wub.nu
webmail.halfdaner.dk
webmail.wub.nu
stats.wub.nu
clan.wub.nu
halfdaner.dk
forum.wub.nu
sd-5.dk
sd-6.dk
tsadmin.wub.nu
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
Reply With Quote
  #4  
Old 23rd December 2008, 00:26
Taxick Taxick is offline
Junior Member
 
Join Date: Dec 2008
Posts: 28
Thanks: 9
Thanked 4 Times in 4 Posts
Default

Any help, to fix this problem????
Reply With Quote
  #5  
Old 23rd December 2008, 09:52
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

And the complete email addresses are listed in /etc/postfix/virtusertable?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Taxick (24th December 2008)
  #6  
Old 23rd December 2008, 10:10
Taxick Taxick is offline
Junior Member
 
Join Date: Dec 2008
Posts: 28
Thanks: 9
Thanked 4 Times in 4 Posts
Default

Quote:
Originally Posted by till View Post
And the complete email addresses are listed in /etc/postfix/virtusertable?
Yes.... Alt the mails addresses are in the file...
Reply With Quote
  #7  
Old 23rd December 2008, 10:18
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Ok, then the error message above is most likely not from your server. This means that eiter the MX record for these domains points to another server or the server that the sender uses as its smtp servre is not forwarding the email to your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Taxick (24th December 2008)
  #8  
Old 23rd December 2008, 10:35
Taxick Taxick is offline
Junior Member
 
Join Date: Dec 2008
Posts: 28
Thanks: 9
Thanked 4 Times in 4 Posts
Default

Quote:
Originally Posted by till View Post
Ok, then the error message above is most likely not from your server. This means that eiter the MX record for these domains points to another server or the server that the sender uses as its smtp servre is not forwarding the email to your server.
Its there a way to tjek the correct settings for the mx record?????

EDIT:

I don't think the problem is my MX Record... If users send mail to me from Gmail, hotmail, and some other host - it works fine...

But some other hosts, can´t send mails to me...

EDIT 2:

I can see in main.cf & postconf myhostname is server.wub.nu, should the hostname not be mail.wub.nu

Last edited by Taxick; 23rd December 2008 at 11:08.
Reply With Quote
  #9  
Old 24th December 2008, 16:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Can you check if the MX records are correct?

Code:
dig mx wub.nu
dig mx halfdaner.dk
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
Taxick (24th December 2008)
  #10  
Old 24th December 2008, 18:13
Taxick Taxick is offline
Junior Member
 
Join Date: Dec 2008
Posts: 28
Thanks: 9
Thanked 4 Times in 4 Posts
 
Default

Quote:
Originally Posted by falko View Post
Can you check if the MX records are correct?

Code:
dig mx wub.nu
dig mx halfdaner.dk
Yes it semes to work...???

Code:
; <<>> DiG 9.3.4-P1.1 <<>> mx wub.nu
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58171
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;wub.nu.                IN    MX

;; ANSWER SECTION:
wub.nu.            43200    IN    MX    10 mail.wub.nu.

;; Query time: 151 msec
;; SERVER: 208.67.222.222#53(208.67.222.222)
;; WHEN: Wed Dec 24 18:11:04 2008
;; MSG SIZE  rcvd: 45
Code:
; <<>> DiG 9.3.4-P1.1 <<>> mx halfdaner.dk
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 62370
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;halfdaner.dk.            IN    MX

;; ANSWER SECTION:
halfdaner.dk.        43200    IN    MX    10 mail.halfdaner.dk.

;; Query time: 183 msec
;; SERVER: 208.67.222.222#53(208.67.222.222)
;; WHEN: Wed Dec 24 18:12:25 2008
;; MSG SIZE  rcvd: 51
Very Happy Holiday and Happy New Year

Last edited by Taxick; 24th December 2008 at 19:13.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
CentoS doesn't send the emails vaio1 Installation/Configuration 18 5th November 2008 17:51
network issues now it says "401 The web site is blocked by administrator" Check General 3 26th February 2008 14:22
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18
configuring IPTABLES firewall adityavpratap HOWTO-Related Questions 9 27th May 2006 21:42


All times are GMT +2. The time now is 21:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.