#1  
Old 19th February 2006, 19:10
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Default SuSe 10

I just finshed 3 long days of doing a new hard drive setup with Windows/Suse10. Windows was the hardest part because it was refusing to recognize the new unformatted SATA drive but I finally googled the topic to death.

All is fine so far... I used the Perfect Install here for SuSe9.3 thinking there can not be that much difference. I did have a couple hiccups and hopefully someone can provide some guidance. During...

Postfix With SMTP-AUTH And TLS I got this;
Code:
Reading Package Lists... Done
Building Dependency Tree... Done
cyrus-sasl is already the newest version.
cyrus-sasl-crammd5 is already the newest version.
cyrus-sasl-digestmd5 is already the newest version.
cyrus-sasl-plain is already the newest version.
cyrus-sasl-saslauthd is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  cyrus-sasl-devel: Depends: cyrus-sasl (= 2.1.20) but 2.1.21-3 is to be installed
E: Broken packages
Courier-IMAP/Courier-POP3 I got;
Code:
Reading Package Lists... Done
Building Dependency Tree... Done
fam-server is already the newest version.
The following packages will be REMOVED:
  imap
The following NEW packages will be installed:
  courier-imap
0 upgraded, 1 newly installed, 1 removed and 5 not upgraded.
Need to get 1412kB of archives.
After unpacking 649kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 ftp://ftp.gwdg.de SuSE/9.3-i386/base courier-imap 3.0.8-3 [1412kB]
Fetched 1412kB in 30s (45.6kB/s)
Checking GPG signatures...
Committing changes...
Preparing...                ########################################### [100%]
        file /etc/pam.d/pop3 from install of courier-imap-3.0.8-3 conflicts with file from package qpopper-4.0.5-181
E: Error while running transaction
E: Handler silently failed
and during Apache/PHP5 I got;
Code:
Reading Package Lists... Done
Building Dependency Tree... Done
apache2 is already the newest version.
apache2-prefork is already the newest version.
libapr0 is already the newest version.
perl-HTML-Parser is already the newest version.
perl-HTML-Tagset is already the newest version.
perl-URI is already the newest version.
perl-libwww-perl is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  apache2-devel: Depends: apache2 (= 2.0.53) but 2.0.54-10.3 is to be installed
  apache2-mod_perl: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
  perl-Tie-IxHash: Depends: perl (= 5.8.6) but 5.8.7-5.3 is to be installed
E: Broken packages
I'm still pretty much a newb w/Linux but it seems some addtional packages need to be installed maybe? Seems like FC4 took care of dependacies, is this a feature I will lose with SuSe?
Reply With Quote
Sponsored Links
  #2  
Old 19th February 2006, 20:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by latcarf
Seems like FC4 took care of dependacies, is this a feature I will lose with SuSe?
No, but you used the SuSE 9.3 tutorial for SuSE 10, that's why you have these problems. You'd have the same problems on Fedora if you used the FC3 tutorial for FC4.
You should have tried this one: http://www.howtoforge.com/perfect_setup_suse_10.0
It's for SuSE 10.0.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 19th February 2006, 21:56
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Default

aahhh...

I have been using your main site http://falkotimme.com/howtos/ and didn't see a SuSe10 set up.

Can I pick up with this one after the basic install and start over without any issues from using the SuSe9.3?
Reply With Quote
  #4  
Old 20th February 2006, 00:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by latcarf
aahhh...

I have been using your main site http://falkotimme.com/howtos/ and didn't see a SuSe10 set up.
The newest tutorials are always on HowtoForge. I haven't posted new tutorial on falkotimme.com for a few months now because it doesn't make sense to maintain two copies.

Quote:
Originally Posted by latcarf
Can I pick up with this one after the basic install and start over without any issues from using the SuSe9.3?
I'd continue with page 4 of the SuSE 10 tutorial: http://www.howtoforge.com/perfect_setup_suse_10.0_p4
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 20th February 2006, 01:55
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko
I'd continue with page 4 of the SuSE 10 tutorial: http://www.howtoforge.com/perfect_setup_suse_10.0_p4
I went ahead and gave it a shot figuring worst case I would have to reinstall.

I cannot get any additional Installation Sources to install. I tried yours first then went to the list. I keep getting the same error "InstSrc: E_no_intsrc_on_media" As I write this I am wondering if I shouldn't delete the Disk source then reinstall it after, the word "media" gave me that thought.

I tried Install Some Software also and could not get openssl-devel-32bit there or in MySQL. I stopped there realizing there is a problem somewhere. I don't know if it makes a difference but the SuSe I have is the Official version which I just bought last week. I assume this is supposed to be a "stable" version.
Reply With Quote
  #6  
Old 20th February 2006, 17:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Did you use yast to install the packages?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 21st February 2006, 02:33
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko
Did you use yast to install the packages?
Yes, but I finally figured it out. I was not giving the complete address. I am still not sure why the one you referenced would not work but when I clicked the link you gave and followed the path allthe way to the end "/inst-source" they worked.

I still had problems with this
Code:
yast -i findutils readline libgcc glibc-devel findutils-locate gcc flex lynx compat-readline4 db-devel wget openssl-devel-32bit
Yast could not find openssl-devel-32bit. When I removed -32bit if found and loaded everything.

So far so good. I still have some stuff to run but I think all should be well now.
Reply With Quote
  #8  
Old 21st February 2006, 11:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by latcarf
I still had problems with this
Code:
yast -i findutils readline libgcc glibc-devel findutils-locate gcc flex lynx compat-readline4 db-devel wget openssl-devel-32bit
Yast could not find openssl-devel-32bit. When I removed -32bit if found and loaded everything.

So far so good. I still have some stuff to run but I think all should be well now.
I added openssl-devel-32bit to the tutorial last week because it's necessary for 64-bit systems; I didn't test then because I thought this package is available also for 32-bit systems, but it seems that it is not. So I have removed the package again from the tutorial.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 22nd February 2006, 03:37
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Quote:
Originally Posted by falko
I added openssl-devel-32bit to the tutorial last week because it's necessary for 64-bit systems; I didn't test then because I thought this package is available also for 32-bit systems, but it seems that it is not. So I have removed the package again from the tutorial.
no worry, thanks! cool you updated the HowTo also.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 10 RAID 1 How To mphayesuk Installation/Configuration 2 11th February 2006 05:56
Is there also a Perfect Setup for SuSE 9.1 bluegrass Installation/Configuration 7 18th January 2006 18:16
The Perfect Setup - SUSE 9.3 (firewall?!) bogdinator HOWTO-Related Questions 7 12th December 2005 13:31
Suse 9.3 - Setting up the basics (File and Print Services) creativehook Suggest HOWTO 1 16th October 2005 21:50
Upgrading from SUSE 9.3 to 10.0 dlplnx Installation/Configuration 1 6th October 2005 11:37


All times are GMT +2. The time now is 05:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.