Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 24th November 2008, 18:36
nbakewell nbakewell is offline
Junior Member
 
Join Date: Nov 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default DNS Master/Slave - unexpected rcode servfail

Hello,

I'm having some troubles setting up a master/slave configuration for my DNS. Right now I have a Redhat server (dnsnsbrhgate.linux.cs460) and a Windows server (dnsnsbwingate.windows.cs460) and I am trying to set the Windows DNS up as a slave on the Redhat server. My named.conf looks like this (snipped to important part):

Code:
zone "linux.cs460." IN {
     type master;
     file "linux.cs460.zone";
};

zone "10.68.192.in-addr.arpa." IN {
     type master;
     file "192.168.10.zone";
};

zone "windows.cs460." IN {
     type slave;
     file "windows.cs460.zone";
     masters { 192.168.10.120 ; };
};
I have a windows.cs460.zone file where all my other zone files are, however it is empty (I am under the impression that this does not need to be filled in?)

The error that I am getting when I try to ping dnsnsbwingate.windows.cs460 is:

Code:
ping: unknown host dnsnsbwingate.windows.cs460
When I restart named.conf my logs show this:

Code:
zone windows.cs460/IN: refresh: unexpected rcode (SERVFAIL) from master 192.168.10.120#53 (source 0.0.0.0#0)
The results of me digging dnsnsbwingate.windows.cs460 is:

Code:
; <<>> DIG 9.3.4-P! <<>> dnsnsbwingate.windows.cs460
;; global options:     printcmd
;; Got answer
;; ->>HEADER<<- opcode: query, status: SERVFAIL, id: 21161
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION
; dnsnsbwingate.windows.cs460.   IN   A

;; Query time 6 msec
;; SERVER 192.168.10.120#53(192.168.10.120)
;; WHEN Mon Nov 24 12:20:27 2008
;; MSG SIZE rcvd: 45
Any ideas?
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 20:51
Google Apps dayjahone General 19 29th March 2008 18:25
named logs RCODE REFUSE? lyndros Installation/Configuration 5 10th September 2007 21:31
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 15:40
Unable send receive emails vassilis3 Installation/Configuration 15 19th May 2007 15:34


All times are GMT +2. The time now is 18:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.