Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 22nd November 2008, 23:10
httpDee httpDee is offline
Junior Member
 
Join Date: Jan 2008
Posts: 10
Thanks: 2
Thanked 1 Time in 1 Post
Default Phantom DNS entry causing problems

I am running around 30 web sites on an ISPConfig machine. The system is also providing DNS (thorugh ISPConfig). I recently removed an old site, and ever since, each time I add a site or make a change to an existing site through ISPConfig, DNS will fail to restart.

The first time this happened, it took me a while to figure out what was causing the problem, but eventually I noticed that named.conf still had an entry for the old site:

Code:
zone "sneakyolddomain.com" {
type master; file "pri.sneakyolddomain.com"; allow-query{"any";};
};
but that the zonefile listed ("pri.sneakyolddomain.com") no longer existed.

I deleted the entry in named.conf manually, then restarted DNS with /etc/init.d/named restart

Everything worked fine, until the next time I added a new domain through ISPConfig. Once again DNS failed to restart. I checked named.conf and sure enough the entry for sneakyolddomain.com was back ...

This has reoccurred many times now, and I have gotten used to manually editing named.conf and restarting, but I would love a way to fix this. Can anyone tell me where the sneakyolddomain.com entry in named.conf is coming from?

Thanks in advance
__________________
httpDee
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 19:51
Google Apps dayjahone General 19 29th March 2008 17:25
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 14:40
Unable send receive emails vassilis3 Installation/Configuration 15 19th May 2007 14:34
No SPF record. beryl Installation/Configuration 6 17th May 2007 19:52


All times are GMT +2. The time now is 20:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.