#1  
Old 21st October 2008, 01:38
dexjul dexjul is offline
Member
 
Join Date: May 2007
Posts: 53
Thanks: 0
Thanked 3 Times in 2 Posts
Default Tomcat problem

Hi,

I installed apache-tomcat-6.0.14-src and jdk1.6.0_10.

I'll run tomcat

[root@dexter bin]# ./startup.sh
Using CATALINA_BASE: /usr/local/tomcat/apache-tomcat-6.0.14-src
Using CATALINA_HOME: /usr/local/tomcat/apache-tomcat-6.0.14-src
Using CATALINA_TMPDIR: /usr/local/tomcat/apache-tomcat-6.0.14-src/temp
Using JRE_HOME: /usr/java/jdk1.6.0_10/

And I go to my browser http://localhost:8080, error failed to connect.

And I stop tomcat and I get this messages.

[root@dexter bin]# ./shutdown.sh
Using CATALINA_BASE: /usr/local/tomcat/apache-tomcat-6.0.14-src
Using CATALINA_HOME: /usr/local/tomcat/apache-tomcat-6.0.14-src
Using CATALINA_TMPDIR: /usr/local/tomcat/apache-tomcat-6.0.14-src/temp
Using JRE_HOME: /usr/java/jdk1.6.0_10/
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/catalina/startup/Bootstrap
Caused by: java.lang.ClassNotFoundException: org.apache.catalina.startup.Bootstrap
at java.net.URLClassLoader$1.run(URLClassLoader.java: 200)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.j ava:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:3 07)
at sun.misc.Launcher$AppClassLoader.loadClass(Launche r.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:2 52)
at java.lang.ClassLoader.loadClassInternal(ClassLoade r.java:320)
Could not find the main class: org.apache.catalina.startup.Bootstrap. Program will exit.

Any Idea?

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 21st October 2008, 10:45
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

What is being logged ? Have u checked with netstat if the port is open ?
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #3  
Old 21st October 2008, 18:16
dexjul dexjul is offline
Member
 
Join Date: May 2007
Posts: 53
Thanks: 0
Thanked 3 Times in 2 Posts
Default

Hi,

Here's the log of catalina.out.

Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/catalina/startup/Bootstrap
Caused by: java.lang.ClassNotFoundException: org.apache.catalina.startup.Bootstrap
at java.net.URLClassLoader$1.run(URLClassLoader.java: 200)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.j ava:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:3 07)
at sun.misc.Launcher$AppClassLoader.loadClass(Launche r.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:2 52)
at java.lang.ClassLoader.loadClassInternal(ClassLoade r.java:320)
Could not find the main class: org.apache.catalina.startup.Bootstrap. Program will exit.


Also I checked the netstat for the running port and there is no running 8080.

[root@dexter logs]# nmap localhost -p1-65355

Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2008-10-20 19:04 PHT
Interesting ports on localhost.localdomain (127.0.0.1):
Not shown: 65350 closed ports
PORT STATE SERVICE
22/tcp open ssh
25/tcp open smtp
111/tcp open rpcbind
631/tcp open ipp
825/tcp open unknown

Please help. Thank you
Reply With Quote
  #4  
Old 28th October 2008, 08:48
dexjul dexjul is offline
Member
 
Join Date: May 2007
Posts: 53
Thanks: 0
Thanked 3 Times in 2 Posts
Default

This problem has been resolved...

Thank you..
Reply With Quote
  #5  
Old 6th November 2008, 21:24
helikart helikart is offline
Junior Member
 
Join Date: Nov 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by dexjul View Post
This problem has been resolved...

Thank you..
Would you please share how you resolved the problem - I'm having the same issue.

Thanks,

TH
Reply With Quote
  #6  
Old 7th November 2008, 02:59
dexjul dexjul is offline
Member
 
Join Date: May 2007
Posts: 53
Thanks: 0
Thanked 3 Times in 2 Posts
Default

Hi,

I think you,ve download a wrong version of tomcat in apache.org. You need to download the Binary Distributions not the Source Code Distributions if you install the java in binary (" java_ee_sdk-5_06-linux.bin").

I hope this can solve your problem.

Regards,
Reply With Quote
  #7  
Old 7th November 2008, 03:27
helikart helikart is offline
Junior Member
 
Join Date: Nov 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Hi,
the downloaded version was fine. I did resolve this after all. The problem was that the conf/ folder was missing the logging.properties file (which was due to my manipulation and setting up the server for multiple tomcat instances available to each user).

Thanks,

Tom
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Virtual users... Ubuntu 8.04 spaceuser HOWTO-Related Questions 12 19th June 2008 08:04
Problem Installing Tomcat ART_MEX Installation/Configuration 3 12th April 2006 23:02
Apache and Tomcat problem! Urgent maroonworks Server Operation 3 24th February 2006 15:14


All times are GMT +2. The time now is 12:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.