Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th October 2008, 16:48
chua_jose chua_jose is offline
Member
 
Join Date: Nov 2007
Posts: 70
Thanks: 6
Thanked 2 Times in 2 Posts
Default i dont recive any mail of any domain

Hi
i have a problem,I cannot receive e-mails of any user of my ispconfig.
I can send email correctly, but I cannot receive them.

my maillog:
Oct 30 15:03:29 SD1111100130 postfix/local[24055]: 443AB3101B1: to=<xxxxxx.com_sistemas@SD1111100130.xxxxxxxxx.com >, orig_to=<sistemas@xxxxxxxxxxx.com>, relay=local, delay=1.5, delays=1.5/0/0/0.01, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Oct 30 15:03:29 SD1111100130 postfix/qmgr[23966]: 443AB3101B1: removed
Oct 30 15:12:52 SD1111100130 postfix/qmgr[27460]: 9BA983101B1: from=<chua_josesss@yahoo.es>, size=1745, nrcpt=1 (queue active)

The user to whom I try to send the e-mail this one in the file /etc/postfix/virtusertable and the domain of this user is in /etc/postfix/local-host-names

Which can be the problem?
Reply With Quote
Sponsored Links
  #2  
Old 31st October 2008, 12:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,983
Thanks: 825
Thanked 5,372 Times in 4,219 Posts
Default

Please enable the maildir checkbox under management > server > settings
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 31st October 2008, 12:21
chua_jose chua_jose is offline
Member
 
Join Date: Nov 2007
Posts: 70
Thanks: 6
Thanked 2 Times in 2 Posts
Default

hy till
this opction its checked.
It was going working correctly up to yesterday..
Reply With Quote
  #4  
Old 31st October 2008, 16:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please try this:

Code:
postconf -e 'home_mailbox = Maildir/'
postconf -e 'mailbox_command ='
/etc/init.d/postfix restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 2nd November 2008, 01:38
chua_jose chua_jose is offline
Member
 
Join Date: Nov 2007
Posts: 70
Thanks: 6
Thanked 2 Times in 2 Posts
Default

this is my postfix configuration:
Code:
queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
inet_interfaces = all
unknown_local_recipient_reject_code = 550
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
home_mailbox = Maildir/
debug_peer_level = 2
debugger_command =
         PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
         xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.3.3/samples
readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
mynetworks = 127.0.0.0/8
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
smtpd_sasl_authenticated_header = yes
myhostname =xxxxxxxx.com
mailbox_command =
message_size_limit = 30971520
if i deleted line "| /usr/bin/procmail -f-" of the file /root/ispconfig/isp/conf/forward.master, then it works and i can recive mails, but antispam dont work
which can be the problem??
Reply With Quote
  #6  
Old 2nd November 2008, 15:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Is procmail installed on your system? What's the output of
Code:
which procmail
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 3rd November 2008, 00:17
chua_jose chua_jose is offline
Member
 
Join Date: Nov 2007
Posts: 70
Thanks: 6
Thanked 2 Times in 2 Posts
Default

Hi falko
yes its
output:

Code:
#which procmail
/usr/bin/procmail

Last edited by chua_jose; 3rd November 2008 at 00:33.
Reply With Quote
  #8  
Old 3rd November 2008, 15:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Is there a file /etc/procmailrc? If so, what's in it?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 3rd November 2008, 16:01
chua_jose chua_jose is offline
Member
 
Join Date: Nov 2007
Posts: 70
Thanks: 6
Thanked 2 Times in 2 Posts
Default

Hi Falko
there isnt file /etc/procmailrc
but if i search procmailrc, i find:

Code:
#locate procmailrc 
/home/admispconfig/.procmailrc
/root/ispconfig/isp/conf/procmailrc.master
/usr/share/doc/procmail-3.22/telsas_procmailrc
/usr/share/doc/procmail-3.22/examples/1procmailrc
/usr/share/doc/procmail-3.22/examples/2procmailrc
/usr/share/doc/procmail-3.22/examples/3procmailrc
/usr/share/man/man5/procmailrc.5.gz
/var/www/web1/.procmailrc
/var/www/web1/user/xxxx.net_admin/.procmailrc
/var/www/web11/.procmailrc
/var/www/web11/user/xxxxxx.com_admision/.procmailrc
/var/www/web2/.procmailrc
...
etc
and /root/adminispconfig/.procmailrc is:
Code:
[root@isp objects]# vi /home/admispconfig/.procmailrc
SHELL=/bin/sh

USERNAME=`formail -xSubject:  | awk '{print $2}'`

:0
* ^Subject:.*Mailsize:*
{
:0
| formail -I "" | sed -e '/^$/d' >> /home/admispconfig/mailstats/${USERNAME}
}
And /rot/ispconfig/isp/conf/procmailrc.master is
Code:
{MAILDIR_COMMENT}MAILDIR=$HOME/Maildir/
{MAILDIR_COMMENT}DEFAULT=$MAILDIR
{MAILDIR_COMMENT}ORGMAIL=$MAILDIR
{QUOTA}
INCLUDERC={PMDIR}/.mailsize.rc
{QUOTA_COMMENT}INCLUDERC={PMDIR}/.quota.rc
{ANTIVIRUS_COMMENT}INCLUDERC={PMDIR}/.antivirus.rc
{MAILSCAN_COMMENT}INCLUDERC={PMDIR}/.local-rules.rc
{MAILSCAN_COMMENT}INCLUDERC={PMDIR}/.html-trap.rc
{SPAMASSASSIN_COMMENT}INCLUDERC={PMDIR}/.spamassassin.rc
{AUTORESPONDER_COMMENT}INCLUDERC={PMDIR}/.autoresponder.rc

Last edited by chua_jose; 4th November 2008 at 13:12.
Reply With Quote
  #10  
Old 4th November 2008, 14:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Did you maybe change the permissions of the directories? What's the output of
Code:
ls -la /var/www/web1/
and
Code:
ls -la /var/www/web1/user/
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't login SquirrelMail satimis Server Operation 23 10th June 2008 13:51
Virtual Users And Domains With Postfix, Courier And MySQL - TLS not working c4rdinal HOWTO-Related Questions 22 29th April 2008 01:44
Postfix problem: lost connection after CONNECT from unknown fernando_torrez Server Operation 5 30th November 2007 14:17
Postfix reject connections gabrix Server Operation 27 25th January 2007 08:37
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47


All times are GMT +2. The time now is 22:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.