Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 13th February 2006, 06:21
jchaven jchaven is offline
Junior Member
 
Join Date: Feb 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default SSI with Apache2 on Debian

I have several .shtml pages that I have moved from Apache2 on Windows to Apache2 on Debian that are not loading. I can visit the individual pages that are included on the index page and they load normally -- they just do get included.

With Apache2 on Windows I configured SSI using the "httpd.conf" file just as in Apache1. On Debian it appears Apache is configured with the config "apache2.conf" instead of "httpd.conf" -- there is no apache2.conf on my Windows machine.

Furthermore, it appears Apache2 is automatically configured to parse .shtml files. According to information found on the Apache2 documentation site to enable SSI I have to use the httpd.conf or .htaccess files:

http://httpd.apache.org/docs/2.0/howto/ssi.html
"To permit SSI on your server, you must have the following directive either in your httpd.conf file, or in a .htaccess file: Options +Includes"


Yet, according to the comments in the /etc/apache2/httpd.conf file this is only meant for backward compatibility:
# This is here for backwards compatability reasons and to support

And according to the Apache2 documentation you should never use .htaccess:

http://httpd.apache.org/docs/2.0/howto/htaccess.html
"In general, you should never use .htaccess files unless you don't have access to the main server configuration file."


So, what am I supposed to do? Should I edit the httpd.conf? Use .htaccess? I would like to configure this the recommended way but, the documentation appears to contradict itself.

Thanks in advance,
Joey
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Perfect Setup - Debian Woody (3.0)... sending mail from my XP box? ExCIA HOWTO-Related Questions 17 27th June 2007 19:31
PHP on Apache2 no longer works after ISPconfig azorman Installation/Configuration 6 23rd July 2006 23:06
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 15:42
Where to Start with Apache2? Vorlon Server Operation 2 20th October 2005 02:12
Perfect setup (debian sarge) Pelle Installation/Configuration 4 11th October 2005 18:17


All times are GMT +2. The time now is 02:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.