Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th February 2006, 21:08
ColdDoT ColdDoT is offline
Senior Member
 
Join Date: Jan 2006
Location: Netherland
Posts: 178
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to ColdDoT
Default asp and asp.net on apache debian

Hallo

just to clear things up i'm a php programmer and a netwerk controller
so wat i want to offer my clients is asp and asp.net support

i've tried a lot of things but i can't figure it out
so who know IF you can run asp on apache (with vb support so no APACHE:ASP)
and how you can do it i know that i can use chilisoft but it must be free
and for apache 2.2

and second how can i make apache run aspx files(asp.net)?

does somone has an answer on this ?

greets colddot
(this place rules)
__________________
2B or not 2B (a pro)
Reply With Quote
Sponsored Links
  #2  
Old 10th February 2006, 23:52
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Quote:
Originally Posted by ColdDoT
and second how can i make apache run aspx files(asp.net)?
Have you tried this?

http://www.mono-project.com/Mod_mono
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 11th February 2006, 12:59
ColdDoT ColdDoT is offline
Senior Member
 
Join Date: Jan 2006
Location: Netherland
Posts: 178
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to ColdDoT
Default

Yes and i can't get it to work. I have tried a lot of thing but it doesn't works
__________________
2B or not 2B (a pro)
Reply With Quote
  #4  
Old 11th February 2006, 13:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

What exactly did you do? Any error messages?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 11th February 2006, 20:00
ColdDoT ColdDoT is offline
Senior Member
 
Join Date: Jan 2006
Location: Netherland
Posts: 178
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to ColdDoT
Default

i dunno how much you must know but this is my error
Code:
Native stacktrace:
     /home/colddot/mono-1.1.13.2/mono/mini/mono(mono_handle_native_sigsegv+0xc0) [0x813d1d0]
     /home/colddot/mono-1.1.13.2/mono/mini/mono [0x8129616]
     /lib/libpthread.so.0 [0x400ca8cb]
     /lib/libc.so.6 [0x4016f6f0]
     /home/colddot/mono-1.1.13.2/mono/mini/mono(mono_compile_create_var+0x56) [0x810d416]
     /home/colddot/mono-1.1.13.2/mono/mini/mono [0x8126cdd]
     /home/colddot/mono-1.1.13.2/mono/mini/mono [0x81282df]
     /home/colddot/mono-1.1.13.2/mono/mini/mono [0x8128eed]
     /home/colddot/mono-1.1.13.2/mono/mini/mono [0x81291de]
     /home/colddot/mono-1.1.13.2/mono/mini/mono [0x812920a]
     /home/colddot/mono-1.1.13.2/mono/mini/mono(mono_compile_method+0x18) [0x808cca8]
     /home/colddot/mono-1.1.13.2/mono/mini/mono(mono_magic_trampoline+0x1a) [0x813e41a]
     [0x402c1032]
     [0x40cead0c]
     [0x40ba9f44]
     [0x40ba9e9e]
     [0x40ba9e66]
     [0x40ceab07]
     [0x40ceaab9]
     [0x40ceaa8f]
     [0x40ceaa5c]
     [0x40ce89c3]
     [0x40ce873d]
     [0x40ce809e]
     [0x40ce8035]
     [0x40ce76ac]
     [0x40cda5bb]
     [0x40cd6a43]
     [0x40cd64fc]
     [0x40d58ed1]
     [0x40cd30de]
     [0x40cd0c25]
     [0x40cd08de]
     [0x40bab9b7]
     [0x40bab0e2]
     [0x40a119ac]
     /home/colddot/mono-1.1.13.2/mono/mini/mono [0x81294c0]
     /home/colddot/mono-1.1.13.2/mono/mini/mono(mono_runtime_invoke+0x27) [0x808e3a7]
     /home/colddot/mono-1.1.13.2/mono/mini/mono(mono_runtime_exec_main+0xaf) [0x808f38f]
     /home/colddot/mono-1.1.13.2/mono/mini/mono(mono_runtime_run_main+0x19f) [0x808efcf]
     /home/colddot/mono-1.1.13.2/mono/mini/mono [0x805cf91]
     /home/colddot/mono-1.1.13.2/mono/mini/mono(mono_main+0x75c) [0x805d8ac]
     /home/colddot/mono-1.1.13.2/mono/mini/mono [0x805c31b]
     /lib/libc.so.6(__libc_start_main+0xc6) [0x4015be36]
     /home/colddot/mono-1.1.13.2/mono/mini/mono [0x805c251]
make[8]: *** [../../class/lib/net_2_0_bootstrap/Mono.Security.dll] Afgebroken
make[8]: Leaving directory `/home/colddot/mono-1.1.13.2/mcs/class/Mono.Security'
make[7]: *** [do-all] Fout 2
make[7]: Leaving directory `/home/colddot/mono-1.1.13.2/mcs/class/Mono.Security'
make[6]: *** [all-recursive] Fout 1
make[6]: Leaving directory `/home/colddot/mono-1.1.13.2/mcs/class'
make[5]: *** [all-recursive] Fout 1
make[5]: Leaving directory `/home/colddot/mono-1.1.13.2/mcs'
make[4]: *** [profile-do--net_2_0_bootstrap--all] Fout 2
make[4]: Leaving directory `/home/colddot/mono-1.1.13.2/mcs'
make[3]: *** [profiles-do--all] Fout 2
make[3]: Leaving directory `/home/colddot/mono-1.1.13.2/mcs'
make[2]: *** [all-local] Fout 2
make[2]: Leaving directory `/home/colddot/mono-1.1.13.2/runtime'
make[1]: *** [all-recursive] Fout 1
make[1]: Leaving directory `/home/colddot/mono-1.1.13.2'
make: *** [all] Fout 2
__________________
2B or not 2B (a pro)
Reply With Quote
  #6  
Old 11th February 2006, 22:36
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

This happens when you compile mono, run a mono program, run xsp?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 12th February 2006, 13:19
ColdDoT ColdDoT is offline
Senior Member
 
Join Date: Jan 2006
Location: Netherland
Posts: 178
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to ColdDoT
Default

That i don't understand.
when i type mono in my ssh the comand works but i can't open any exe whit it ?
__________________
2B or not 2B (a pro)
Reply With Quote
  #8  
Old 12th February 2006, 14:12
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

The errors you posted above, did they occur during mono installation?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 12th February 2006, 18:33
ColdDoT ColdDoT is offline
Senior Member
 
Join Date: Jan 2006
Location: Netherland
Posts: 178
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to ColdDoT
Default

yes when i was compiling mono whit make command
__________________
2B or not 2B (a pro)
Reply With Quote
  #10  
Old 12th February 2006, 22:17
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
 
Default

Mono is sometimes difficult to compile. Have you tried these debian packages?

http://pkg-mono.alioth.debian.org/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
bgregorasgoglety6746 (28th August 2013)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ASP.NET on suse 10 mphayesuk Server Operation 3 26th January 2006 15:37


All times are GMT +2. The time now is 20:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.