Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th October 2008, 21:18
lschafroth lschafroth is offline
Junior Member
 
Join Date: Oct 2008
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default Changing anything on site re-creates index.html

Any time my users access their Control Panel in ISPConfig and make any changes at all, it creates a new index.html file.

Most of their sites use default.htm or index.php and etc. So the site gives the ispconfig default index page instead of their site.

How can I fix that?

It doesnt appear to be editing the vhosts_ispconfig file at all.

Lannie
Reply With Quote
Sponsored Links
  #2  
Old 25th October 2008, 00:41
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

If you have a index file like index.php, ispconfig will not copy the index.html file again.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 25th October 2008, 05:18
lschafroth lschafroth is offline
Junior Member
 
Join Date: Oct 2008
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thats my problem. I have to delete it otherwise the site wont use the default.htm.

The vhosts file never gets updated so anything I put in ISPConfig for default pages does not work.

I have to delete index.html so the default.htm or default.php and etc will work instead. A few days later it's back to a default ispconfig index.html file.

This needs to be stopped and the vhost file needs to be updated by ispconfig so it will use the correct files.

Lannie
Reply With Quote
  #4  
Old 25th October 2008, 11:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by lschafroth View Post
The vhosts file never gets updated so anything I put in ISPConfig for default pages does not work.
Can you go to the directory where Vhosts_ispconfig.conf is located and post the outptu of
Code:
ls -la
?
Are there any warnings in /home/admispconfig/ispconfig/ispconfig.log?
What's the output of
Code:
ls -la /root/ispconfig
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 25th October 2008, 20:08
lschafroth lschafroth is offline
Junior Member
 
Join Date: Oct 2008
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

[root@webhost vhosts]# ls -la
total 656
drwxr-xr-x 2 root root 4096 Oct 19 19:44 .
drwxr-xr-x 3 root root 4096 Oct 14 00:30 ..
-rwxr-xr-x 1 root root 20363 Oct 19 14:44 Vhostsispconfig.bak
-rwxr-xr-x 1 root root 20655 Oct 25 09:11 Vhosts_ispconfig.conf
-rwxr-xr-x 1 root root 20655 Oct 25 09:11 Vhosts_ispconfig.conf~
-rw-r--r-- 1 root root 21712 Oct 19 10:48 Vhosts_ispconfig.conf_19-10-08_10-48-36
-rw-r--r-- 1 root root 21712 Oct 19 10:49 Vhosts_ispconfig.conf_19-10-08_10-49-48
-rw-r--r-- 1 root root 21712 Oct 19 10:50 Vhosts_ispconfig.conf_19-10-08_10-50-30
-rw-r--r-- 1 root root 21712 Oct 19 10:58 Vhosts_ispconfig.conf_19-10-08_10-58-54
-rw-r--r-- 1 root root 21712 Oct 19 10:59 Vhosts_ispconfig.conf_19-10-08_10-59-26
-rw-r--r-- 1 root root 21712 Oct 19 11:00 Vhosts_ispconfig.conf_19-10-08_11-00-08
-rw-r--r-- 1 root root 21712 Oct 19 11:00 Vhosts_ispconfig.conf_19-10-08_11-00-31
-rw-r--r-- 1 root root 21712 Oct 19 11:00 Vhosts_ispconfig.conf_19-10-08_11-00-42
-rw-r--r-- 1 root root 21712 Oct 19 12:48 Vhosts_ispconfig.conf_19-10-08_12-48-07
-rw-r--r-- 1 root root 21712 Oct 19 12:51 Vhosts_ispconfig.conf_19-10-08_12-51-59
-rw-r--r-- 1 root root 21704 Oct 19 13:09 Vhosts_ispconfig.conf_19-10-08_13-09-01
-rw-r--r-- 1 root root 21696 Oct 19 13:09 Vhosts_ispconfig.conf_19-10-08_13-09-18
-rw-r--r-- 1 root root 21680 Oct 19 13:09 Vhosts_ispconfig.conf_19-10-08_13-09-35
-rw-r--r-- 1 root root 21672 Oct 19 13:09 Vhosts_ispconfig.conf_19-10-08_13-09-50
-rw-r--r-- 1 root root 21656 Oct 19 13:10 Vhosts_ispconfig.conf_19-10-08_13-10-08
-rw-r--r-- 1 root root 21640 Oct 19 13:10 Vhosts_ispconfig.conf_19-10-08_13-10-26
-rw-r--r-- 1 root root 21632 Oct 19 13:10 Vhosts_ispconfig.conf_19-10-08_13-10-43
-rw-r--r-- 1 root root 21632 Oct 19 14:00 Vhosts_ispconfig.conf_19-10-08_14-00-31
-rw-r--r-- 1 root root 21645 Oct 19 14:09 Vhosts_ispconfig.conf_19-10-08_14-09-05
-rw-r--r-- 1 root root 21516 Oct 19 14:10 Vhosts_ispconfig.conf_19-10-08_14-10-30
-rw-r--r-- 1 root root 21600 Oct 19 14:19 Vhosts_ispconfig.conf_19-10-08_14-19-24
-rw-r--r-- 1 root root 21940 Oct 19 14:19 Vhosts_ispconfig.conf_19-10-08_14-19-48
-rw-r--r-- 1 root root 21940 Oct 19 14:20 Vhosts_ispconfig.conf_19-10-08_14-20-15
-rwxr-xr-x 1 root root 21940 Oct 19 16:15 Vhosts_ispconfig.conf_19-10-08_16-15-41


[root@webhost vhosts]#
[root@webhost vhosts]# ls -la /root/ispconfig
total 108
drwxr-xr-x 10 root root 4096 Oct 25 09:11 .
drwxr-x--- 17 root root 4096 Oct 14 15:41 ..
-rwxr-xr-x 1 root root 33074 Oct 14 00:30 cronolog
-rwxr-xr-x 1 root root 9673 Oct 14 00:30 cronosplit
drwxr-xr-x 12 root root 4096 Oct 14 00:15 httpd
drwxr-xr-x 16 root root 4096 Oct 14 00:30 isp
drwxr-xr-x 7 root root 4096 Oct 14 00:16 libmcrypt
-rw-r--r-- 1 root root 8 Oct 25 09:11 .old_path_httpd_root
drwxr-xr-x 6 root root 4096 Oct 14 00:14 openssl
drwxr-xr-x 6 root root 4096 Oct 14 00:24 php
drwxr-xr-x 4 root root 4096 Oct 19 19:44 scripts
drwxr-xr-x 4 root root 4096 Oct 14 00:30 standard_cgis
drwxr-xr-x 2 root root 4096 Oct 14 00:30 sv
-rwx------ 1 root root 9389 Oct 14 00:30 uninstall
[root@webhost vhosts]#


I dont see any errors in the log. It's quite large. Mostly debug and info type stuff. A few warnings when creating imap folders

Lannie
Reply With Quote
  #6  
Old 26th October 2008, 14:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

http://www.howtoforge.com/forums/sho...72&postcount=3
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 26th October 2008, 17:27
lschafroth lschafroth is offline
Junior Member
 
Join Date: Oct 2008
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I followed the commands from the link you provided and it came back with Syntax OK.

I checked the ispconfig.log and it did not show any entries for today.

Lannie

PS what should the owner be for this file? It shows rwx for root.

Last edited by lschafroth; 26th October 2008 at 17:34.
Reply With Quote
  #8  
Old 27th October 2008, 12:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Can you try this?
Code:
mv Vhosts_ispconfig.conf Vhosts_ispconfig.conf_orig
mv Vhosts_ispconfig.conf_19-10-08_16-15-41 Vhosts_ispconfig.conf
httpd -t
What's the output of the last command?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 27th October 2008, 13:33
lschafroth lschafroth is offline
Junior Member
 
Join Date: Oct 2008
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

output of the command is: Syntax OK.

Thats all it says.

Lanne
Reply With Quote
  #10  
Old 28th October 2008, 15:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

And the Vhosts_ispconfig.conf stil doesn't get updated when you change anything in ISPConfig?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
uploading index.html doesn't update site! anubix Installation/Configuration 12 4th February 2009 17:49
chgrp error new user DKA General 15 28th July 2008 17:45
Changing the new site default page MatthewJ Installation/Configuration 1 1st December 2006 12:56
New Site Shows Apache Default page not uploaded index.html mojosound Installation/Configuration 35 18th April 2006 10:59
Changing domainname of a site doesn't remove old dns name joostvdl General 1 25th October 2005 16:30


All times are GMT +2. The time now is 14:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.