Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 25th October 2008, 05:12
dayjahone dayjahone is offline
Senior Member
 
Join Date: Jan 2007
Posts: 421
Thanks: 31
Thanked 0 Times in 0 Posts
Default Remoting Framework

I am trying to set up Remoting Framework so I can add users to a website remotely.

Do we still need to change the ISPConfig install script so it doesn't disable xml? If so, is there a way to do it retroactively as I've already installed ISPConfig 2.2.27.

I also installed remoting framework, added a user, checked all the little boxes under the user, and uncommented the function to add a reseller in the test.php file, and I when I browse to mydomain.com/test.php, I get
Code:
Script end ...
but it doesn't actually create a reseller.

Also, can you still use Remoting Framework to add users? I had this working a long time ago and used the following:

Code:
// Add User
$params = array (         'sid'        => $session_id,
                                        'module'         => 'web',
                                        'function'         => 'user_add',
                                        'params'        => array ( web_title => 'mydomain.com',  // web_title or web_id
                                        user_username => $new_username_field,
                                        user_name => $first_name,
                                        user_email => $new_username_field,
                                        user_passwort => $new_password_field,
                                        user_speicher => 0,
                                        user_mailquota => 1000,
                                        user_admin => 0
                                        ));

$user_id = $soap_client->call('service',$params);
if($err = $soap_client->getError()) die("Error: ".$err);
I tried it and again got "script end..." without it adding a user.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
autosignup remoting framework howto detailed kextra1 Tips/Tricks/Mods 21 1st March 2012 06:59
Remoting Framework / xml instalation issue gauthier Installation/Configuration 7 9th October 2007 10:06
Adding a Web Remoting Framework bigger_travis General 1 13th July 2007 20:26
Remoting framework still show black block under tools mxc Installation/Configuration 2 26th February 2007 07:13
Remoting Framework mlz General 9 18th January 2007 22:52


All times are GMT +2. The time now is 22:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.