#1  
Old 13th November 2006, 23:07
statiic statiic is offline
Senior Member
 
Join Date: Oct 2006
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
Default .htaccess problem

I have installed an perfect setup and now I added an new clients website.

I Inserted an .htaccess file for the website to have smartlinks.

But now it doesnt work. It tells me that the file is incorrect setted or something like that.

Here is the file

Code:
#Php Magic Quotes
php_flag register_globals off
php_flag magic_quotes_gpc off
php_flag magic_quotes_runtime off
# php_flag error_reporting "E_ALL ^ (E_NOTICE | E_WARNING)"


##############################

# Permalinks
RewriteEngine on

##############################

# Google Sitemap
RewriteRule ^sitemap/?$ sitemap.php [NC]

# RSS Feed
RewriteRule ^rss/?$ rss.php [NC]

##############################

# Idioma
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(_([A-Za-z]{2}))/?$ /index.php?l=$2 [L]
RewriteRule ^(.*)/_([A-Za-z]{2})/?$ /index.php?l=$2 [L]

# Secciones
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /index.php [L]
And which httpd.conf file do I need to change if I want to setup the session expire time for all my clients?

Last edited by statiic; 13th November 2006 at 23:12.
Reply With Quote
Sponsored Links
  #2  
Old 14th November 2006, 10:52
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,453
Thanks: 813
Thanked 5,222 Times in 4,092 Posts
Default

Please post the exact error message that you get in the error.log file of the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th November 2006, 13:05
statiic statiic is offline
Senior Member
 
Join Date: Oct 2006
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Where can I find this file??
Reply With Quote
  #4  
Old 14th November 2006, 15:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

The global error log normally is something like /var/log/apache2/error.log or /var/log/httpd/error.log.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 14th November 2006, 17:38
statiic statiic is offline
Senior Member
 
Join Date: Oct 2006
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I use ispconfig and now its in the users personal folder

But here are my errors:

The first one for the full .htaccess without mods:
[Tue Nov 14 17:35:41 2006] [alert] [client 192.168.1.12] /var/www/web2/web/.htaccess: php_flag not allowed here
[Tue Nov 14 17:35:41 2006] [alert] [client 192.168.1.12] /var/www/web2/web/.htaccess: php_flag not allowed here


Then when I take out the php_flags:
[Tue Nov 14 17:36:18 2006] [error] [client 192.168.1.12] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /var/www/web2/web/
[Tue Nov 14 17:36:18 2006] [error] [client 192.168.1.12] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /var/www/web2/web/error/forbidden.html
Reply With Quote
  #6  
Old 14th November 2006, 18:41
statiic statiic is offline
Senior Member
 
Join Date: Oct 2006
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I installed an perfect setup for mandriva 2007 with ispconfig, but where can I find the correct httpd.conf for my client websites??

Because I have 2 of them. And I dont know which one is the right one.

I also cannot find anyting with /var/www/web2/web/

Could someone explain this?
Reply With Quote
  #7  
Old 15th November 2006, 13:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Quote:
Originally Posted by statiic
I use ispconfig and now its in the users personal folder

But here are my errors:

The first one for the full .htaccess without mods:
[Tue Nov 14 17:35:41 2006] [alert] [client 192.168.1.12] /var/www/web2/web/.htaccess: php_flag not allowed here
[Tue Nov 14 17:35:41 2006] [alert] [client 192.168.1.12] /var/www/web2/web/.htaccess: php_flag not allowed here
Make sure you enabled the PHP module in Apache.


Quote:
Originally Posted by statiic
Then when I take out the php_flags:
[Tue Nov 14 17:36:18 2006] [error] [client 192.168.1.12] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /var/www/web2/web/
[Tue Nov 14 17:36:18 2006] [error] [client 192.168.1.12] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /var/www/web2/web/error/forbidden.html
You could put something like
Code:
<Directory /var/www/web2/web/>
  Options +FollowSymLinks
</Directory>
into the vhost configuration.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 15th November 2006, 13:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Quote:
Originally Posted by statiic
I installed an perfect setup for mandriva 2007 with ispconfig, but where can I find the correct httpd.conf for my client websites??
I think it's in /etc/httpd or /etc/httpd2 or something like this. You can search for it:
Code:
updatedb
locate httpd.conf
or run
Code:
httpd -V
Quote:
Originally Posted by statiic
I also cannot find anyting with /var/www/web2/web/

Could someone explain this?
Do you have a Vhosts_ispconfig.conf? What's in there?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 19th October 2008, 17:22
orfi orfi is offline
Junior Member
 
Join Date: Mar 2006
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
 
Thumbs up detailed solution

Quote:
Originally Posted by falko View Post
Make sure you enabled the PHP module in Apache.


You could put something like
Code:
<Directory /var/www/web2/web/>
  Options +FollowSymLinks
</Directory>
into the vhost configuration.
===============================================
add the directive in the panel for apache directives and check if it is ok in : /etc/apache2/vhosts/Vhosts_ispconfig.conf

#--------------------------------
# rewrite on problem in .htaccess
#--------------------------------
<IfModule mod_rewrite.c>
<Directory /srv/www/web1/web/>
Options +FollowSymLinks
</Directory>
</IfModule>
#---------------------------------


and Falko is right again

This was modified on : SUSE11 /php5/

Last edited by orfi; 20th October 2008 at 10:22.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
wordpress MU and ISPconfig .htaccess isues palkat General 4 18th October 2006 11:57
.htaccess login challenge broken with mod_rewrite ozonblue Installation/Configuration 2 13th September 2006 10:09
Postfix+MySQL Problem jasutton Installation/Configuration 1 15th June 2006 16:06


All times are GMT +2. The time now is 18:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.