Prev Previous Post   Next Post Next
  #1  
Old 7th October 2008, 18:38
bobwdn bobwdn is offline
Member
 
Join Date: Dec 2006
Location: Nashville, Tennessee, USA
Posts: 50
Thanks: 7
Thanked 0 Times in 0 Posts
Default ISPConfig Bind offline

Built an Ubuntu 8.04LTS ISPConfig server per Falko's instructions and two weeks ago, all was working fine. Lately, I have been working my way through getting my server recognized by my ISP nameservers.

Because I need to run one nameserver, I followed "How To Run Your Own Name Server With ISPConfig and providerdomain.de" how to. Struggled with the German graphics (on page 2), but I think I got through it with the help of "How To Run Your Own Servers With ISPConfig And GoDaddy" how to.

And now I have discovered that my bind9 is not running. "Services" shows it is "offline" as does natstat -tap shows not listening to ports 53 or 953.

The syslogd captures the following:

Oct 7 10:11:32 web02 named[22030]: starting BIND 9.4.2-P1 -u bind -t /var/lib/named
Oct 7 10:11:32 web02 named[22030]: found 1 CPU, using 1 worker thread
Oct 7 10:11:32 web02 named[22030]: loading configuration from '/etc/bind/named.conf'
Oct 7 10:11:32 web02 named[22030]: none:0: open: /etc/bind/named.conf: permission denied
Oct 7 10:11:32 web02 named[22030]: loading configuration: permission denied
Oct 7 10:11:32 web02 named[22030]: exiting (due to fatal error)
Oct 7 10:11:32 web02 kernel: [950173.520670] audit(1223392292.562:23): type=1503 operation="inode_permission" requested_mask="r::" denied_mask="r::" name="/var/lib/named/etc/bind/named.conf" pid=22031 profile="/usr/sbin/named" namespace="default"

I checked the permissions of /var/lib/named/etc/bind/named.conf and it is bind:bind.

Did something update bind recently that I overlooked when upgrading?

I need help. Please.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Permission Denied Bind Slave Server Problems wxman Server Operation 17 22nd March 2014 13:30
ispconfig web-server offline ProServ-uk.com Server Operation 6 27th July 2009 14:34
BIND version 9.5.0, under chroot /var/named/chroot terranet Tips/Tricks/Mods 0 17th July 2008 19:29
fastcgi and php with ispconfig tosser Tips/Tricks/Mods 3 25th June 2006 22:01
FC4 Setup DNS and ISPCONFIG issues The General Installation/Configuration 7 15th May 2006 10:45


All times are GMT +2. The time now is 01:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.