#1  
Old 25th September 2008, 23:04
doughold doughold is offline
Junior Member
 
Join Date: Sep 2008
Posts: 19
Thanks: 0
Thanked 2 Times in 2 Posts
Default Roundcube and ISPConfig3

I have installed ISPConfig3Beta and while attempting to install Roundcube Webmail, I keep encountering the error

magic_quotes_gpc: NOT OK(is '1', should be '0')

I have added the following directives:

<Directory "/var/clients/client0/web5/web">
php_flag magic_quotes_gpc off
Options FollowSymLinks
AllowOverride All
</Directory>

Even after changing off to 0, changing /clients/client0/web5/web to /www/<domain>/web I have had no luck. I realize that this is still heavily under development and am curious if these directives should work. If so, any thoughts as to why they are not taking?
Reply With Quote
Sponsored Links
  #2  
Old 26th September 2008, 08:51
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Your problem is most likely not related to ISPConfig 3 as every apache supports these directives and ISPCcnfig does nod read or interpretes them.

Please post the complete vhost configuration file of this vhost.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 26th September 2008, 17:22
doughold doughold is offline
Junior Member
 
Join Date: Sep 2008
Posts: 19
Thanks: 0
Thanked 2 Times in 2 Posts
Default

<VirtualHost *:80>
DocumentRoot /var/clients/client0/web5/web

ServerName webmail.westechsolutions.com
ServerAdmin webmaster@webmail.westechsolutions.com
ErrorLog /var/clients/client0/web5/log/error.log

ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html

<Directory /var/www/webmail.westechsolutions.com/web>
Options None
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
</Directory>

<Directory /var/clients/client0/web5/web>
# suphp enabled
suPHP_Engine on
# suPHP_UserGroup web5 client0
AddHandler x-httpd-suphp .php .php3 .php4 .php5
suPHP_AddHandler x-httpd-suphp
php_flag magic_quotes_gpc off
</Directory>

#php_value magic_quotes_gpc 0
#php_value_admin magic_quotes_gpc 0
php_flag magic_quotes_gpc off
#php_flag_admin magic_quotes_gpc off
</VirtualHost>

Note: I commented out:

#php_value magic_quotes_gpc 0
#php_value_admin magic_quotes_gpc 0

and added:

php_flag magic_quotes_gpc off
#php_flag_admin magic_quotes_gpc off

to the bottom, even when these were enabled it was not working.

In addition, I added:

php_flag magic_quotes_gpc off

to the <Directory /> section. Thanks for the reply Till, ISPConfig rocks!
Reply With Quote
  #4  
Old 26th September 2008, 17:39
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

You are using suphp, php_flag and php_admin statements are only working with mod_php. Please be aware that all manualy modifications in the vhost file are removed by the next update of the configuration file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 26th September 2008, 18:20
doughold doughold is offline
Junior Member
 
Join Date: Sep 2008
Posts: 19
Thanks: 0
Thanked 2 Times in 2 Posts
 
Default

Till,

I tried modifying it to mod_php before through the control panel, but it didn't work. I see now that the config file is not being updated when I save. I tried running the two cron jobs manually since I thought that might do the trick but no luck, the config file still has suPHP and my mods in it. Any thoughts?

Doug
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 17:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.