Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 4th September 2008, 11:52
comptcarlik comptcarlik is offline
Junior Member
 
Join Date: Aug 2008
Posts: 10
Thanks: 2
Thanked 0 Times in 0 Posts
Default

hello falko .
i have got 10 websites admistrated by ISPconfig . what part of the files do you need .. the whole thing or just the domain i want the htaccess to work for
Reply With Quote
Sponsored Links
  #12  
Old 5th September 2008, 12:12
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

I need the vhost configuration of the web site where you want the .htaccess to work.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 17th September 2008, 15:43
dimas dimas is offline
Senior Member
 
Join Date: Jul 2006
Posts: 125
Thanks: 7
Thanked 27 Times in 8 Posts
Default

Dear Falko, I wonder how I could permanently 'fix' this
AllowOverride All
setting in Vhosts_ispconfig.conf?

I change it there for one of the websites from AllowOverride None to AllowOverride All, and everything starts to work, but some time later the setting reverts back to AllowOverride None

Also, I can't reset the setting globally.

if I put AllowOverride All inside <Directory /var/www/*/web> in /etc/apache2/apache2.conf, nothing seems to happen.

I have ISPConfig 2.2.25, "perfect setup", Debian Etch.
Reply With Quote
  #14  
Old 18th September 2008, 18:48
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Put something like

Code:
<Directory "/var/www/web#/web">
AllowOverride All
</Directory>
in the Apache Directives field of that web site in the ISPConfig interface.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 19th October 2008, 07:10
gamera gamera is offline
Junior Member
 
Join Date: Oct 2008
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Everytime I try and add anything to the directives box withing Basis tab of ISPconfig I get the following:
You cannot assign HTTPD Includes to this website.

Now from what I have read to include .htaccess globally you have to edit:
/etc/apache2/apache2.conf

But this simply does not exist on centos5.2 I am guessing this is the directory to edit /etc/httpd/conf/http.conf but I did try the edit from the FAQ. But alas no change everytime I add a .htaccess file it disapears from the directory. Even after restarting httpd.

Can someone please confirm the .conf I need to edit in centos 5.2 and if someone has successfully done it confirm the necessary additional coding please. I would like to allow .htacess globally and not individually.

Thanks for any advice.
Reply With Quote
  #16  
Old 19th October 2008, 11:21
gamera gamera is offline
Junior Member
 
Join Date: Oct 2008
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Default

in the httpd.conf file in the directory I stated I changed the setting to AllowOverride All

Restarted the server. Still wont allow .htaccess files.


And now I seem to have broken it somehow:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@mythicalsystems.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.3 (CentOS) Server at www.mythicalsystems.com Port 80


*****NOW FIXED*****

I logged into server with WinSCP and saw the .ht files sitting there. Funnily enough once gone no more server error. Weird. I am trying to install ravennuke CMS which uses a set of .ht files.

I am still bewildered that the files go missing in FTP but im sure its a permission issue root vs admin. Interesting that it resulted in server error even though ISPconfig said all is well. Maybe the error was from the CMS and not actual server problem.

Will try again and hope it works.

*****NO*****

Afraid not. the .htaccess files are causing server conflicts. Thus the AllowOverride All did not work. back to the drawing board.


I have worked out how to use the:
<Directory "/var/www/web#/web">
AllowOverride All
</Directory>

But still nothing.

Last edited by gamera; 19th October 2008 at 15:10.
Reply With Quote
  #17  
Old 20th October 2008, 12:49
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's in Apache's overall error log (should be in /var/log/httpd) and in the web site's error log (in /var/www/web#/logs)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #18  
Old 22nd October 2008, 03:11
gamera gamera is offline
Junior Member
 
Join Date: Oct 2008
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Default

There are a few error logs in the directory /var/log/httpd

Here is a link to them:
www.spookyink.net/gamera/varloghttpd.rar

For the error log in /var/www/web#/log:
www.spookyink.net/gamera/varloghttpd.rar

Funny thing about the second log as I see a heap of:
Options not allowed here
[Wed Oct 22 10:03:48 2008] [alert] [client 203.26.95.65] /var/www/web7/web/.htaccess: Options not allowed here
Reply With Quote
  #19  
Old 22nd October 2008, 13:27
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Can you post the vhost configuration of web7?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 22nd October 2008, 14:44
gamera gamera is offline
Junior Member
 
Join Date: Oct 2008
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Sure thing.

www.spookyink.net/gamera/Vhosts_ispconfig.rar

Thanks for taking the time to help.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upload ins't working good in ispconfig on ubuntu 6.06 djmostek Installation/Configuration 11 24th August 2007 22:14
vhost not working on ISPConfig 2.2.13 tannnk Installation/Configuration 2 22nd June 2007 14:31
fastcgi and php with ispconfig tosser Tips/Tricks/Mods 3 25th June 2006 21:01
FC4 Setup DNS and ISPCONFIG issues The General Installation/Configuration 7 15th May 2006 09:45
ISPconfig not working Venkatesh.S Installation/Configuration 2 28th July 2005 13:28


All times are GMT +2. The time now is 10:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.