Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 18th September 2008, 16:05
almeister9 almeister9 is offline
Member
 
Join Date: Sep 2008
Posts: 36
Thanks: 6
Thanked 3 Times in 3 Posts
Thumbs up [RESOLVED] help posting logs to forum and saslauth problem

Hi to all.
I am quite experienced in windows and averagely experienced in mac but this is my first foray into linux of any flavour.
I have just completed the howto "Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 8.04 LTS)".
As I said I am an absolute begginer so I had to learn from scratch (had to google how to use vi and how to shutdown). I have built a mail server from a fresh install as described in the above howto, on a brand new box (amd64) by plugging it in to a KVM switch. My other computers on my small network are windows, including the machine I am writing this post on.

I have hit a problem with sasl. I have been reading as many posts on this forum as I can and have worked out how to see logs by tail -f
I believe that I am going to need to post the results of these logs if anyone can help me.

I am looking for a kind, kind, soul who could possibly describe to me in great detail, how to get the results of these logs from the ubuntu server onto my windows machine so that I could post them, or alternatively how to post them from within the ubuntu server (comand line only - no gui).

My first problem appears when I tail -f /var/log/auth.log and I noticed straight away:
Quote:
scribalmail saslauthd[5011]:pam_mysql - required option "db" is not set
I have checked the only two configurations that I could see for sasl in the howto, and they both are exactly as in the howto
Quote:
vi /etc/pam.d/smtpd
Quote:
auth required pam_mysql.so user=username passwd=password host=127.0.0.1 db=mail table=users usercolumn=email passwdcolumn=password crypt=1
account sufficient pam_mysql.so user=username passwd=passwordpassword host=127.0.0.1 db=mail table=users usercolumn=email passwdcolumn=password crypt=1
and
Quote:
vi /etc/postfix/sasl/smtpd.conf
Quote:
pwcheck_method: saslauthd
mech_list: plain login
allow_plaintext: true
auxprop_plugin: mysql
sql_hostnames: 127.0.0.1
sql_user: username
sql_passwd: password
sql_database: mail
sql_select: select password from users where email = '%u'
And yes as you may have already surmised, I copied all that with pen and paper then typed it all out here.
I am prepared to do just that if that is what it takes.

If anyone in here could possibly help me with either of these problems, I would be greatly appreciative.:confused:

Thanx in advance.

Last edited by almeister9; 21st September 2008 at 14:17. Reason: resolved
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
...my next problem - now with saslauth... TobiasTM Installation/Configuration 8 14th April 2006 01:30


All times are GMT +2. The time now is 02:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.