Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th September 2008, 23:51
adobe adobe is offline
Member
 
Join Date: Sep 2008
Posts: 39
Thanks: 0
Thanked 1 Time in 1 Post
Default ISPConfig stuck with error: The URL is not reachable!

Hello,

I am trying to install ISPConfig Control Panel onto my Debian 4.0 Etch server, so I followed this guide first in preparing my server for ISPConfig -> http://www.howtoforge.com/perfect_setup_debian_etch

Once that was complete, I was following this guide here http://www.ispconfig.org/manual_installation.htm and im at the stage where it asks me this question:

Quote:
All prerequisites are fulfilled.
Here we go...
Please enter your MySQL server:localhost
OK
Please enter your MySQL user:root
Please enter your MySQL password:
OK
Please enter a name for the ISPConfig database (e.g. db_ispconfig):db_ispconfig
Please enter the IP address of the ISPConfig web (e.g. 192.168.0.1):xxx.xxx.xxx.xxx
OK
Please enter the host name (e.g. www):www
Please enter the domain (e.g. xyz.de):mydomain.com
The URL is not reachable!
Since, I am trying to setup my server to run on "mydomain.com", i gave those url, it errors like so:

Quote:
The URL is not reachable!
The ./setup script is confusing, why would it ask for a domain name to run the ispconfig, if it's the first time i am actually running the ispconfig so i can create the nameserver for the "mydomain.com" and have it point to server.
Reply With Quote
Sponsored Links
  #2  
Old 16th September 2008, 18:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

www.mydomain.com must already be pingable when you install ISPConfig because the installer tries to ping it to verify the address. As a workaround, you can add www.mydomain.com to /etc/hosts for now.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 18th September 2008, 05:42
adobe adobe is offline
Member
 
Join Date: Sep 2008
Posts: 39
Thanks: 0
Thanked 1 Time in 1 Post
Default

Out of curiosity, what if i were to enter the address as localhost ?

Will the ISPConfig forever be locked to http://localhost:81

or is it possible to edit some config and have it working on desired domain name?

Quote:
As a workaround, you can add www.mydomain.com to /etc/hosts for now.
how does the entry on /etc/hosts supposed to look like for "www.mydomain.com" ?

Also, do i have to edit my domain name and have it point to my server ip or something using my domain registrar e.g. Godaddy or setting the /etc/hosts file alone is enough???
Reply With Quote
  #4  
Old 18th September 2008, 05:46
adobe adobe is offline
Member
 
Join Date: Sep 2008
Posts: 39
Thanks: 0
Thanked 1 Time in 1 Post
Default

Okay, here's a new problem i discovered post-installation.

When ever I login, I get this error:

Quote:
Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (12) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (12) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:77) in /home/admispconfig/ispconfig/lib/classes/ispconfig_auth.lib.php on line 99
When I reboot my server, the error goes away and then somehow, it creeps up again.

Does anyone know a permanent fix to this problem, instead of server reboot every time this error comes on?
Reply With Quote
  #5  
Old 18th September 2008, 11:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,072
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
 
Default

This means just that either the mysql login details were wrong that you entered in the ispconfg installer or that the mysql database is not running.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig Roadmap till Developers' Forum 26 10th June 2007 22:38
Ubuntu 6.06 LTS during ISPConfig MySQL root password error...stuck?? Randall Hoffman General 5 13th March 2007 15:01
ISPConfig Mysql root password issue ?? Stuck at install Randall Hoffman Installation/Configuration 1 16th January 2007 20:53
SuSE 10.1 - ISPConfig admin/admin login help. Wrongway Installation/Configuration 11 20th November 2006 19:09
the URL is not reachable during setup! maroonworks Installation/Configuration 1 30th November 2005 17:07


All times are GMT +2. The time now is 12:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.