Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 6th February 2006, 11:25
st2xo st2xo is offline
Member
 
Join Date: Jan 2006
Location: Wiesloch [DE]
Posts: 47
Thanks: 3
Thanked 0 Times in 0 Posts
Default write access to wwwrun/www-data in users DocumentRoot

Hi everybody - itīs monday and the problems are with me, again
Is there a - practicable - way to give apache/mod_php write access to the users public web directorys?

I have to make the users public web directories write accessible for wwwrun (or www-data). With the default ISPconfig installation (Suse10, perfect setup) that isīnt possible (or Iīm wrong?). So I made following changes and it works:

Add user wwwrun to the web10-group
Code:
groupmod --add-user wwwrun web10
make web10-dir writeable for all group members
Code:
chmod 775  /home/www/web10
make web-dir writeable for everybody
Code:
chmod 777  /home/www/web10/web
(actual it should be enough to give 775 - but it isnīt and I dont understand why - but for the asked problem I will ignore this at this time)
That works - but isnt very smart of course.
At last it is now very unsecure to give users shell access because all users would have write access to the directories from the other users But that is for me the smaller problem, so wouldīnt give shell access.

Now I would go to patch the ispconfig scripts which create the users directories and would set the above values with chmod/chown and so on.

So my questions:
- which ISPConfig script/s I have to patch?
- is there another way to give write access to the public dirs?

thanks in advance!
__________________
regards,
Stefan.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
VSFTPD is not working after install the ISPConfig gimhan90 Server Operation 8 3rd February 2006 10:25
Ability to add components for users webstergd Feature Requests 1 20th December 2005 11:25
regarding proftpd and users with shell access Ovidiu Server Operation 2 5th December 2005 14:03


All times are GMT +2. The time now is 04:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.