Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #31  
Old 15th July 2008, 18:32
misiek04 misiek04 is offline
Junior Member
 
Join Date: Jul 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Send to another server. I solve this problem. In /etc/mailname change hostname.mydomain.com to mydomain.com. Now everything works.
Reply With Quote
Sponsored Links
  #32  
Old 4th October 2008, 15:50
ParDust ParDust is offline
Junior Member
 
Join Date: Oct 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default mail() and pop3 error

Hi i just setup my debian server as mentioned in http://www.howtoforge.com/perfect_setup_debian_etch

All services are on however when i try to send email via php's mail() function i get some errors on mail.log like,

Oct 4 16:23:06 server postfix/smtp[3722]: 186A06443EB: host f.mx.mail.yahoo.com[209.191.88.247] refused to talk to me: 553 Mail from xx.xxx.xxx.xx not allowed - 5.7.1 [BL21] Connections not accepted from IP addresses on Spamhaus PBL; see http://postmaster.yahoo.com/550-bl21.html [550]". mail() function works, it sends the message however recipient blocks message.

Thus my server is in my local network behind an adsl router, when i try to connect to pop3 service via client Kmail 1.9.10 i get those error below on mail.log, what went wrong?

Oct 4 16:23:11 server courierpop3login: Connection, ip=[::ffff:127.0.0.1]
Oct 4 16:23:11 server courierpop3login: Disconnected, ip=[::ffff:127.0.0.1]
Oct 4 16:23:11 server postfix/smtpd[3741]: connect from localhost.localdomain[127.0.0.1]
Oct 4 16:23:11 server postfix/smtpd[3741]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Oct 4 16:23:11 server postfix/smtpd[3741]: disconnect from localhost.localdomain[127.0.0.1]
Oct 4 16:23:19 server postfix/trivial-rewrite[3721]: table hash:/etc/postfix/virtusertable(0,lock|fold_fix) has changed -- restarting
Oct 4 16:23:31 server postfix/smtpd[3741]: table hash:/etc/postfix/virtusertable(0,lock|fold_fix) has changed -- restarting
Oct 4 16:23:31 server courierpop3login: Connection, ip=[::ffff:127.0.0.1]
Oct 4 16:23:31 server courierpop3login: Disconnected, ip=[::ffff:127.0.0.1]
Oct 4 16:23:31 server postfix/smtpd[4026]: connect from localhost.localdomain[127.0.0.1]
Oct 4 16:23:31 server postfix/smtpd[4026]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Oct 4 16:23:31 server postfix/smtpd[4026]: disconnect from localhost.localdomain[127.0.0.1]

telnet localhost 25 output:

server:/var/log# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 server.xxx.org ESMTP Postfix (Debian/GNU)
ehlo localhost
250-server.xxx.org
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
quit
221 2.0.0 Bye
Connection closed by foreign host.

command: "netstat -tap" ouput:

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:43332 *:* LISTEN 2463/rpc.statd
tcp 0 0 *:mysql *:* LISTEN 5605/mysqld
tcp 0 0 *:sunrpc *:* LISTEN 2102/portmap
tcp 0 0 *:81 *:* LISTEN 31794/ispconfig_htt
tcp 0 0 *:auth *:* LISTEN 2429/inetd
tcp 0 0 server.xxx.org:domain *:* LISTEN 3469/named
tcp 0 0 localhost.locald:domain *:* LISTEN 3469/named
tcp 0 0 *:ftp *:* LISTEN 32146/proftpd: (acc
tcp 0 0 localhost.localdoma:953 *:* LISTEN 3469/named
tcp 0 0 *:smtp *:* LISTEN 1651/master
tcp6 0 0 *:imaps *:* LISTEN 7538/couriertcpd
tcp6 0 0 *op3s *:* LISTEN 7458/couriertcpd
tcp6 0 0 *op3 *:* LISTEN 7401/couriertcpd
tcp6 0 0 *:imap2 *:* LISTEN 7491/couriertcpd
tcp6 0 0 *:www *:* LISTEN 3213/apache2
tcp6 0 0 *:ssh *:* LISTEN 2444/sshd
tcp6 0 0 localhost:953 *:* LISTEN 3469/named
tcp6 0 0 *:smtp *:* LISTEN 1651/master
tcp6 0 0 *:https *:* LISTEN 3213/apache2
tcp6 0 0 server.xxx.org:ssh ::ffff:192.168.1.:35839 ESTABLISHED2526/sshd: administ





Thanks in advance..
Reply With Quote
  #33  
Old 5th October 2008, 19:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
Default

The problem is that most dynamic IP addresses are blacklisted nowadays (you can check your IP on http://mxtoolbox.com/blacklists.aspx ).

To circumvent this, you can relay through another server: http://www.howtoforge.com/postfix_re...her_mailserver
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #34  
Old 6th October 2008, 01:35
ParDust ParDust is offline
Junior Member
 
Join Date: Oct 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks!. Problem is dynamic ip address which was blacklisted, i created a reverse zone file now gmail accepts my emails however unlikely yahoo does not.

Today i will try to connect mail server outside local network with a mail client to see if pop3-smtp configuration is ok.
Reply With Quote
  #35  
Old 15th November 2008, 21:52
solutions_linux solutions_linux is offline
Junior Member
 
Join Date: Nov 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by linuxuser1 View Post
How can i set up my debian servers - one with postfix and 1 with sendmail to allow a php script to use the mail() function to send e-mail. Both servers have ISPConfig installed.

What i have in my php.ini =
; For Unix only. You may supply arguments as well (default: "sendmail -t -i").
sendmail_path = /usr/sbin/sendmail

The php.ini is located at /etc/php4/apache2/php.ini


Thanks
Sendmail is legacy MTA of Unix(Its location is hardcoded in many previous apps). So, while postfix installation, we need to first forcibly uninstall sendmail Then postfix installs its own binary named sendmail in /usr/bin/sendmail.
So, I mean to say that sendmail binary exists in both. Your app will work in either cases.
Reply With Quote
  #36  
Old 18th April 2009, 16:09
gamera gamera is offline
Junior Member
 
Join Date: Oct 2008
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Im getting a very similar issue with my server.

When sending to a email account on the server it all works fine. To any external domain it does not.. First noticed the issue as I was not getting monitoring emails to externally hosted email box.

Now php forms and user accounts on site are unable to send validation emails, passwords etc to member accounts.

IP is static and ISP do not filter smtp connections and I am sure of this as I work for them :P

ISPC 2 latest install/version
Centos 5.2 - Perfect Server Installation

Now I am a noob to email server stuff so you will not only have to tell me what I can give you to further assist but also where I can find it.

I originally suspected global php settings to be the issue but not after reading others comments, now suspect postfix or ....

Quote:
Originally Posted by misiek04 View Post
Send to another server. I solve this problem. In /etc/mailname change hostname.mydomain.com to mydomain.com. Now everything works.
...to be the issue.

Any help is very much appreciated.
Reply With Quote
  #37  
Old 19th April 2009, 16:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
Default

Any errors in your mail log?
Please make sure your server isn't blacklisted: http://mxtoolbox.com/blacklists.aspx
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #38  
Old 20th April 2009, 13:52
gamera gamera is offline
Junior Member
 
Join Date: Oct 2008
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Not black listed.

Tried to paste log into reply and keep getting error:

The message you have entered is too short. Please lengthen your message to at least 10 characters.

WTF its a hell of alot more than ten.
Reply With Quote
  #39  
Old 21st April 2009, 12:20
gamera gamera is offline
Junior Member
 
Join Date: Oct 2008
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Fixed by port issue on lns.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not receiving any incoming mail. Jcorrea920 General 11 3rd April 2010 13:08
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Ispconfig + FC4 + mail function vocoder General 15 10th March 2006 12:36
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47
Problem sending mail to 2nd SMTP server inside network kisong Server Operation 2 2nd March 2006 18:05


All times are GMT +2. The time now is 04:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.