Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 12th July 2008, 17:06
satimis satimis is offline
Senior Member
 
Join Date: Oct 2006
Posts: 533
Thanks: 4
Thanked 2 Times in 2 Posts
Default Please help - how to recompile php5

Hi folks,


Ubuntu LAMP 6.06 amd64
SugarCRM 5.0
Postfix
Apache2
php5


I have SugarCRM 5.0 running on this LAMP box. But users can neither send nor receive emails. It comes to my notice that "Inbound Email cannot function without the IMAP c-client libraries enabled/compiled with the PHP module"


$ apt-cache policy php5-imap
Code:
php5-imap:
  Installed: 5.1.2-1
  Candidate: 5.1.2-1
  Version table:
 *** 5.1.2-1 0
        500 http://archive.ubuntu.com dapper/universe Packages
        100 /var/lib/dpkg/status

$ apt-cache policy libc-client2002edebian
Code:
libc-client2002edebian:
  Installed: 7:2002edebian1-13
  Candidate: 7:2002edebian1-13
  Version table:
 *** 7:2002edebian1-13 0
        500 http://archive.ubuntu.com dapper/universe Packages
        100 /var/lib/dpkg/status

I need to recompile php5 with;
Code:
./configure' '---enable-mbstring' '--with-imap' '--with-imap-ssl' '--with-kerberos' '--with-curl'
However I can't find php5 source


$ sudo find / -name src -type d | grep php5
No printout


Also I need Debian package development tools:


$ apt-cache policy build-essential debhelper
Code:
build-essential:
  Installed: (none)
  Candidate: 11.1
  Version table:
     11.1 0
        500 http://hk.archive.ubuntu.com dapper/main Packages
debhelper:
  Installed: (none)
  Candidate: 5.0.7ubuntu13
  Version table:
     5.0.7ubuntu13 0
        500 http://hk.archive.ubuntu.com dapper/main Packages

I suppose need to install them running;
Code:
$ sudo apt-get install build-essential debhelper
and download php5 sourece;
Code:
$ sudo apt-get source php5

plus all the dependencies for building PHP:
Code:
$ sudo apt-get build-dep php5

Here I hesitate on which directory shall I run;
Code:
./configure' '---enable-mbstring' '--with-imap' '--with-imap-ssl' '--with-kerberos' '--with-curl'

On "cd php5-xxx/debian" ???

Kinldy shed me some light assisting me to avoid making mistake. TIA


B.R.
satimis
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
The Perfect Server - 7.10 Server (PHP5 & PHP5 Packages Install Snag) giganet HOWTO-Related Questions 8 9th December 2008 21:05
Copy compiled php5 to another machine cooljai Installation/Configuration 4 11th October 2007 16:15
SuSe10.1 & PHP5 modules latcarf Installation/Configuration 3 11th September 2006 14:31
Apache / php5 recompile HOWTO adrenalinic Installation/Configuration 2 15th June 2006 14:20


All times are GMT +2. The time now is 06:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.