Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 29th January 2006, 22:47
protocol protocol is offline
Member
 
Join Date: Nov 2005
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default Suse 10.0 Installation Problems

Hello all. In the past i have installed the previous version of ISPConfig on Suse 10.0 machines, by following the related 'Perfect Setup' Guides.

On this particular machine, two things have changed. The first one is that now we have this new ISPConfig version (which i have never tested in the past) and the machine has a software raid configuration. These may not be related to the problems i will report, but i mention them for your information.

So the problems are:

a) I fail to run the
Code:
quotaon -avug
, because it reports that

Code:
quotaon: using //aquota.group on /dev/md0 [/]: Invalid argument
quotaon: Maybe create new quota files with quotacheck(8)?
quotaon: using //aquota.user on /dev/md0 [/]: Invalid argument
quotaon: Maybe create new quota files with quotacheck(8)?
which i have no idea what it is.

My /etc/fstab file is :

Code:
/dev/md0             /                    reiserfs   acl,user_xattri,usrquota,grpquota        1 1
/dev/md1             swap                 swap       defaults              0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
/dev/cdrecorder      /media/cdrecorder    subfs      noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0             /media/floppy        subfs      noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0

b) Ultimately, ISPConfig fails to install at all, with this error:

Code:
checking for 8-bit clean memcmp... yes
checking for mcrypt support... no
checking for MCVE support... no
checking OpenSSL dir for MCVE... no
checking for mhash support... no
checking whether to include mime_magic support... no
checking for MING support... no
checking for mnoGoSearch support... no
checking for msession support... no
checking for mSQL support... no
checking for MSSQL support via FreeTDS... no
checking for MySQL support... yes
checking for specified location of the MySQL UNIX socket... no
checking for MySQL UNIX socket location... no
configure: error: Cannot find libmysqlclient under /usr.
Note that the MySQL client library is not bundled anymore.
ERROR: Could not configure PHP
cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
mv: cannot stat `binaries/aps.tar.gz': No such file or directory
mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
mv: cannot stat `binaries/cronolog': No such file or directory
mv: cannot stat `binaries/cronosplit': No such file or directory
mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
mv: cannot stat `binaries/zip': No such file or directory
mv: cannot stat `binaries/unzip': No such file or directory
tar: spamassassin.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `spamassassin': No such file or directory
tar: uudeview.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `uudeview': No such file or directory
tar: clamav.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `clamav': No such file or directory
tar: aps.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
./setup2: line 771: ispconfig_tmp/php/bin/php: No such file or directory
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!
.. which seems to mean that ISPConfig can not find my mysql installation and thus configure php properly, which is very strange because MySQL is really there. Here is my netstat output:

HTML Code:
gateway:/usr/local/src # netstat -tap  
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name   
tcp        0      0 *:mysql                 *:*                     LISTEN      7340/mysqld         
tcp        0      0 *:sunrpc                *:*                     LISTEN      6001/portmap        
tcp        0      0 *:ftp                   *:*                     LISTEN      6253/proftpd: (acce 
tcp        0      0 *:ipp                   *:*                     LISTEN      6184/cupsd          
tcp        0      0 *:smtp                  *:*                     LISTEN      6500/master         
tcp        0      0 *:rockwell-csp2         *:*                     LISTEN      6264/sshd           
tcp        0      0 *:smtp                  *:*                     LISTEN      6500/master
So, what is happening? I was very confident that everything would function properly, that i am very sad about this mess. Please help.

Panos
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISP Config Installation on Suse 9.3 gimhan90 Installation/Configuration 5 20th January 2006 11:24
Installation failure Suse 10 x86_64 beholder Installation/Configuration 4 19th January 2006 08:09
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 03:30
Upgrading from SUSE 9.3 to 10.0 dlplnx Installation/Configuration 1 6th October 2005 11:37
Problems getting through the installation klausagnoletti Installation/Configuration 4 26th September 2005 13:23


All times are GMT +2. The time now is 00:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.