Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 28th January 2006, 21:07
Geekocrat Geekocrat is offline
Junior Member
 
Join Date: Jan 2006
Location: Austin Texas US
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by falko
Recompiling zlib won't break anything. Just do it!
OK, I did it. Did not work. So recompiling zlib with shared libraries is not the issue.

I went back to this thread you recommended
http://www.howtoforge.com/forums/showthread.php?t=1626
and followed instructions by gbjbaanb except I was installing on Breezy Badger (Ubuntu) so did not need to install ssl-devel. Worked perfectly except that I did not write down the correct pwd for MySQL so had to reinstall. [Insert appropriate rough language here...][Lots of it.]

This time I didn't recompile zlib so I could check if the shared libraries were the issue. Just used the tweaks in the link above. ISPConfig installed without a hitch.

Bottom line: I suspect the compiler gives the "recompile with -FPIC" message because it can't find the shared libraries. When you change the ./configure to "--with-openssl" and the MySQL symbolic links, the compiler can find everything it needs.

Thanks to everyone for the help and various links. And thanks to Falko and Till for a most impressive product.

Nick
Reply With Quote
Sponsored Links
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 13:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.