Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st July 2008, 20:27
hunter123 hunter123 is offline
Junior Member
 
Join Date: Jul 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default tftp server failed

Problem solved http://wiki.systemimager.org/index.p...emImager_3.4.1


Hi, I'm stuck on this one error for the last 6 hours and I desperately need help. Help please!
I've found one other thread and there was no solution posted. Here's what everything looks like

[[root@localhost ~]# cat /etc/xinetd.d/tftp
# default: off
# description: The tftp server serves files using the trivial file transfer
# protocol. The tftp protocol is often used to boot diskless
# workstations, download configuration files to network-aware printers,
# and to start the installation process for some operating systems.
service tftp
{
socket_type = dgram
protocol = udp
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -s /var/lib/tftpboot -r blksize
disable = no
}

[root@localhost ~]# si_mkbootserver
WARNING: this script may modify the following files:
--> /etc/services
--> /etc/inetd.conf
--> /etc/xinetd.d/tftp
And can restart inetd, xinetd or tftp servers.
Do you wish to continue (y/[n])? y
Ok, continuing...
/var/lib/tftpboot exists and is a symlink to /usr/share/systemimager/boot.
Checking for a tftp server... found.
Checking if tftp server is H. Peter Anvin's tftp server... yup - right on!
Checking for a running inetd... Not found.
Checking for a running xinetd... 4371.
Looking for update-inetd... not found.
Backing up /etc/xinetd.d/tftp...
Moving /etc/xinetd.d/tftp to /etc/xinetd.d/tftp.si_mkbootserver.bak26...done.
Restaring xinetd ...
Stopping xinetd: [ OK ]
Starting xinetd: [ OK ]
done.
Looking for a tftp client... found.
Checking for loopback interface... up.
Does tftp server work... no.
I couldn't tftp a test file from localhost
ERROR: tftp server test failed.
[root@localhost ~]#


So that's what's going on so far i've heard some things saying that its bugged and you have to hack it a bit. Please i'm lost!

Last edited by hunter123; 11th July 2008 at 17:32.
Reply With Quote
Sponsored Links
  #2  
Old 1st July 2008, 21:44
hunter123 hunter123 is offline
Junior Member
 
Join Date: Jul 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default help

i was told to start tftp manually and go through and make sure tftp was working but i think that there;s a bug with systemimager. Can someone help me ?
Reply With Quote
  #3  
Old 2nd July 2008, 13:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

What's the output of
Code:
netstat -tap
? Did you start xinetd?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 2nd July 2008, 18:41
hunter123 hunter123 is offline
Junior Member
 
Join Date: Jul 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i did start xinetd

heres the output

Code:
 [root@localhost ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name   
tcp        0      0 *:rsync                     *:*                         LISTEN      5362/rsync          
tcp        0      0 *:sunrpc                    *:*                         LISTEN      1714/rpcbind        
tcp        0      0 *:ftp                       *:*                         LISTEN      2069/vsftpd         
tcp        0      0 *:ssh                       *:*                         LISTEN      2050/sshd           
tcp        0      0 localhost.localdomain:ipp   *:*                         LISTEN      2140/cupsd          
tcp        0      0 localhost.localdomain:smtp  *:*                         LISTEN      2089/sendmail: acce 
tcp        0      0 *:36510                     *:*                         LISTEN      1733/rpc.statd      
tcp        0      0 10.0.0.63:60002             www.howtoforge.com:http     TIME_WAIT   -                   
tcp        0      0 10.0.0.63:54781             204.2.241.160:http          ESTABLISHED 7461/firefox        
tcp        0      0 10.0.0.63:38865             od-in-f164.google.com:http  ESTABLISHED 7461/firefox        
tcp        0      0 10.0.0.63:37790             208.46.17.24:http           ESTABLISHED 7461/firefox        
tcp        0      0 10.0.0.63:49392             kubrick.freenode.net:ircd   ESTABLISHED 2866/xchat          
tcp        0      0 10.0.0.63:48991             204.2.241.146:http          ESTABLISHED 7461/firefox        
tcp        0      0 10.0.0.63:59760             prodwebmail-mtc04.evip:http ESTABLISHED 7461/firefox        
tcp        0      0 *:rsync                     *:*                         LISTEN      5362/rsync          
tcp        0      0 *:ssh                       *:*                         LISTEN      2050/sshd           
[root@localhost ~]#
Reply With Quote
  #5  
Old 3rd July 2008, 18:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Can you also post the output of
Code:
netstat -uap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 7th July 2008, 15:53
hunter123 hunter123 is offline
Junior Member
 
Join Date: Jul 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

[root@localhost ~]# netstat -uap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
udp 0 0 *:703 *:* 1733/rpc.statd
udp 0 0 *:bootpc *:* 9085/dhclient
udp 0 0 *:60136 *:* 1733/rpc.statd
udp 0 0 *:mdns *:* 2131/avahi-daemon:
udp 0 0 *:compaq-evm *:* 19100/rpcbind
udp 0 0 *:sunrpc *:* 19100/rpcbind
udp 0 0 *:60529 *:* 2131/avahi-daemon:
udp 0 0 *:ipp *:* 2140/cupsd
udp 0 0 *:tftp *:* 6327/xinetd
Reply With Quote
  #7  
Old 8th July 2008, 13:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by hunter123 View Post
udp 0 0 *:tftp *:* 6327/xinetd
It's running. What's the output of
Code:
iptables -L
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 8th July 2008, 18:18
hunter123 hunter123 is offline
Junior Member
 
Join Date: Jul 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

[root@localhost ~]# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
Reply With Quote
  #9  
Old 8th July 2008, 22:53
hunter123 hunter123 is offline
Junior Member
 
Join Date: Jul 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

right now im trying to get the tftp server to connect to the localhost. I've done

chkconfig tftp on ; service xinetd start ; cp /etc/services /var/lib/tftpboot ; cd /tmp ; tftp localhost ; get services

and it's timing out!

so anyways i need some help ive disabled the firewall using /etc/init.d/iptables stop and setenforce0 to no avail please help!
Reply With Quote
  #10  
Old 9th July 2008, 16:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
 
Default

What happens when you stop vsftpd and set protocol = tcp in /etc/xinetd.d/tftp and restart xinetd?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't start apache Musty Server Operation 12 9th March 2008 14:58
The Perfect Setup - Debian Etch (Debian 4.0) some trouble daniel80 HOWTO-Related Questions 26 1st February 2008 17:30
Mail not working Roadracer Installation/Configuration 16 31st December 2005 00:40
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 03:30
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 18:28


All times are GMT +2. The time now is 21:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.