Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th June 2008, 22:42
NuttyGambler NuttyGambler is offline
Junior Member
 
Join Date: Oct 2006
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default Client SSL send email issues only.

Have had this server up for a couple years. Gets email and sends mail fine inside the network.

Web clients can send and receive mal.

Remote clients can get email, but not send.

Fedora 6 (I know old but so far been able to upgrade apps so why rebuild)
Newest ISPConfig
Newest Postfix.

All done to Falkos Perfect setups.

Have read and read, but most in this seem to end up being client issues. But I have tried many different clients in every possible way.

If I don't require SSL
Jun 25 15:33:30 server04 postfix/smtpd[9011]: warning: 99-203-214-210.area2.spcsdns.net[99.203.214.210]: SASL LOGIN authentication failed: authentication failure
Jun 25 15:33:30 server04 postfix/smtpd[9011]: disconnect from 99-203-214-210.area2.spcsdns.net[99.203.214.210]
If I do.
Jun 25 15:36:59 server04 postfix/smtpd[9011]: setting up TLS connection from 99-203-214-210.area2.spcsdns.net[99.203.214.210]
Jun 25 15:37:02 server04 postfix/smtpd[9011]: TLS connection established from 99-203-214-210.area2.spcsdns.net[99.203.214.210]: SSLv3 with cipher RC4-MD5 (128/128 bits)
In either case the mail doesn't go out.

I'm out of ideas.
Reply With Quote
Sponsored Links
  #2  
Old 26th June 2008, 10:58
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,392
Thanks: 833
Thanked 5,487 Times in 4,319 Posts
Default

Please make sure that you enabled smtp authentication in the client and that the client uses the same username and password for smtp auth that he uses for pop3.

If this wont work, please compare the email setup of your server with the perfect setup for fedora 6, it might be that you have a typo anywere in the initial setup as you post sounds that you never used smtp auth before on this server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 26th June 2008, 14:41
NuttyGambler NuttyGambler is offline
Junior Member
 
Join Date: Oct 2006
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Please make sure that you enabled smtp authentication in the client and that the client uses the same username and password for smtp auth that he uses for pop3.

If this wont work, please compare the email setup of your server with the perfect setup for fedora 6, it might be that you have a typo anywere in the initial setup as you post sounds that you never used smtp auth before on this server.
Well I have been cut and pasting most everything, just changing server names, so unless there is is a typo in the instructions they are identical.

No, I used to have this working before I updated to a new server a couple years ago. Just given it is not critical to our operation I have ignored it, but now need to get it working for someone working remotely.

Looking at the above log clips. What should a working system say? In the one where I required auth, does it not look like the auth is working?
Reply With Quote
  #4  
Old 26th June 2008, 16:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Is SELinux disabled?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 27th June 2008, 18:12
NuttyGambler NuttyGambler is offline
Junior Member
 
Join Date: Oct 2006
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Is SELinux disabled?
Is according to the config file as in the setup page.

Is there a way to test that it is?
Reply With Quote
  #6  
Old 27th June 2008, 23:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

Quote:
Originally Posted by NuttyGambler View Post
Is there a way to test that it is?
Yes, run
Code:
sestatus
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
hotmail rejects outgoing email nzimas Server Operation 3 1st May 2009 03:39
Email SSL jonwatson Installation/Configuration 6 6th June 2008 17:27
how to configure postfix to send email out for a hosted domain nox171 Server Operation 24 13th July 2007 11:48
client 'can not send email' reinier Server Operation 1 17th April 2007 11:38
Can't send email with attachments to another email nysprite Installation/Configuration 2 29th June 2006 18:09


All times are GMT +2. The time now is 17:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.