Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th May 2008, 07:58
nidhintomson nidhintomson is offline
Member
 
Join Date: Nov 2007
Posts: 41
Thanks: 3
Thanked 0 Times in 0 Posts
Default DNS Error : named-sdb dead but pid file exists

Hi All
I configured a DNS on FC8. I followed the howtoforge tutorial

http://howtoforge.net/linux_bind9_an...ing_nameserver

when i try to resolve www.testdomain.net from another machine (a machine other than the one which i configured DNS), it is not able to resolve the same.

[root@localhost ~]# ping www.testdomain.net
ping: unknown host www.testdomain.net


If i ping it from the same machine on which DNS is configured it is pinging.


[root@localhost]# ping www.testdomain.net
PING www.testdomain.net (192.168.0.19) 56(84) bytes of data.
64 bytes from 192.168.0.19: icmp_seq=1 ttl=64 time=0.036 ms
64 bytes from 192.168.0.19: icmp_seq=2 ttl=64 time=0.048 ms

--- www.testdomain.net ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 0.036/0.042/0.048/0.006 ms
[root@localhost]#



When i check for the status of my namd service its giving the following output.


[root@localhost ~]# /etc/init.d/named status
version: 9.5.0b3
number of zones: 16
debug level: 0
xfers running: 0
xfers deferred: 0
soa queries in progress: 0
query logging is OFF
recursive clients: 0/0/1000
tcp clients: 0/100
server is up and running
named-sdb dead but pid file exists
[root@localhost ~]#


what does this named-sdb dead but pid file exists means ?

if i do telnet 192.168.0.19 53 from a remote machine its giving the following error.

telnet 192.168.0.19 53
Trying 192.168.0.19...
telnet: connect to address 192.168.0.19: Connection refused
[root@localhost ~]#



if i do telnet localhost 53 from the same machine where DNS is configured its connecting to port 53.


Why is it happening so ?

Whats wrong with my DNS configuration ?

Looking forward to hear from you

Thanks and Regards
Nidhin Tomson
Reply With Quote
Sponsored Links
  #2  
Old 27th May 2008, 16:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What'S the output of
Code:
netstat -tap
? Any errors in your logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 28th May 2008, 05:45
nidhintomson nidhintomson is offline
Member
 
Join Date: Nov 2007
Posts: 41
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
What'S the output of
Code:
netstat -tap
? Any errors in your logs?
Thanks Falko for your response.


The output for netstat -tap is as follows : -

[root@localhost ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN 29811/mysqld
tcp 0 0 *op3 *:* LISTEN 2291/tcpserver
tcp 0 0 localhost.localdomain:783 *:* LISTEN 1841/spamd.pid
tcp 0 0 *:sunrpc *:* LISTEN 1584/rpcbind
tcp 0 0 192.168.122.1:domain *:* LISTEN 2054/dnsmasq
tcp 0 0 localhost.localdomai:domain *:* LISTEN 1726/named-sdb
tcp 0 0 localhost.localdomain:ipp *:* LISTEN 2065/cupsd
tcp 0 0 *:smtp *:* LISTEN 2295/tcpserver
tcp 0 0 localhost.localdomain:rndc *:* LISTEN 1726/named-sdb
tcp 0 0 *:56251 *:* LISTEN 1603/rpc.statd
tcp 0 0 *:imaps *:* LISTEN 2217/couriertcpd
tcp 0 0 *:courierpassd *:* LISTEN 1831/xinetd
tcp 0 0 *:imap *:* LISTEN 2207/couriertcpd
tcp 0 0 *:http *:* LISTEN 30939/httpd
tcp 0 0 localhost6.localdoma:domain *:* LISTEN 1726/named-sdb
tcp 0 0 *:ssh *:* LISTEN 1821/sshd
tcp 0 0 localhost6.localdomain:rndc *:* LISTEN 1726/named-sdb
tcp 0 0 ::ffff:192.168.0.19:ssh ::ffff:192.168.0.4:28394 ESTABLISHED 5002/0
[root@localhost ~]#



There is no errors in /var/log/messages

If i restart the named service the output of /var/log/messages is as follows : -

May 28 09:06:18 localhost named-sdb[1726]: received control channel command 'stop'
May 28 09:06:18 localhost named-sdb[1726]: shutting down: flushing changes
May 28 09:06:18 localhost named-sdb[1726]: stopping command channel on 127.0.0.1#953
May 28 09:06:18 localhost named-sdb[1726]: stopping command channel on ::1#953
May 28 09:06:18 localhost named-sdb[1726]: no longer listening on ::1#53
May 28 09:06:18 localhost named-sdb[1726]: no longer listening on 127.0.0.1#53
May 28 09:06:19 localhost named-sdb[1726]: exiting
May 28 09:06:21 localhost named-sdb[5108]: starting BIND 9.5.0b3 -u named -t /var/named/chroot
May 28 09:06:21 localhost named-sdb[5108]: found 1 CPU, using 1 worker thread
May 28 09:06:21 localhost named-sdb[5108]: SDB ldap zone database module loaded.
May 28 09:06:21 localhost named-sdb[5108]: SDB postgreSQL DB zone database module loaded.
May 28 09:06:21 localhost named-sdb[5108]: SDB sqlite3 DB zone database module loaded.
May 28 09:06:21 localhost named-sdb[5108]: SDB directory DB zone database module loaded.
May 28 09:06:21 localhost named-sdb[5108]: loading configuration from '/etc/named.conf'
May 28 09:06:21 localhost named-sdb[5108]: the working directory is not writable
May 28 09:06:21 localhost named-sdb[5108]: listening on IPv6 interface lo, ::1#53
May 28 09:06:21 localhost named-sdb[5108]: listening on IPv4 interface lo, 127.0.0.1#53
May 28 09:06:21 localhost named-sdb[5108]: default max-cache-size (33554432) applies
May 28 09:06:21 localhost named-sdb[5108]: automatic empty zone: 127.IN-ADDR.ARPA
May 28 09:06:21 localhost named-sdb[5108]: automatic empty zone: 254.169.IN-ADDR.ARPA
May 28 09:06:21 localhost named-sdb[5108]: automatic empty zone: 2.0.192.IN-ADDR.ARPA
May 28 09:06:21 localhost named-sdb[5108]: automatic empty zone: 255.255.255.255.IN-ADDR.ARPA
May 28 09:06:21 localhost named-sdb[5108]: automatic empty zone: 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0. 0.0.0.0.0.0.0.IP6.ARPA
May 28 09:06:21 localhost named-sdb[5108]: automatic empty zone: D.F.IP6.ARPA
May 28 09:06:21 localhost named-sdb[5108]: automatic empty zone: 8.E.F.IP6.ARPA
May 28 09:06:21 localhost named-sdb[5108]: automatic empty zone: 9.E.F.IP6.ARPA
May 28 09:06:21 localhost named-sdb[5108]: automatic empty zone: A.E.F.IP6.ARPA
May 28 09:06:21 localhost named-sdb[5108]: automatic empty zone: B.E.F.IP6.ARPA
May 28 09:06:21 localhost named-sdb[5108]: default max-cache-size (33554432) applies: view _bind
May 28 09:06:21 localhost named-sdb[5108]: command channel listening on 127.0.0.1#953
May 28 09:06:21 localhost named-sdb[5108]: command channel listening on ::1#953
May 28 09:06:21 localhost named-sdb[5108]: zone 0.in-addr.arpa/IN: NS '0.in-addr.arpa' has no address records (A or AAAA)
May 28 09:06:21 localhost named-sdb[5108]: zone 0.in-addr.arpa/IN: loaded serial 0
May 28 09:06:21 localhost named-sdb[5108]: zone 1.0.0.127.in-addr.arpa/IN: NS '1.0.0.127.in-addr.arpa' has no address records (A or AAAA)
May 28 09:06:21 localhost named-sdb[5108]: zone 1.0.0.127.in-addr.arpa/IN: loaded serial 0
May 28 09:06:21 localhost named-sdb[5108]: zone 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0. 0.0.0.0.0.0.0.ip6.arpa/IN: NS '1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0 .0.0.0.0.0.0.0.ip6.arpa' has no address records (A or AAAA)
May 28 09:06:21 localhost named-sdb[5108]: zone 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0. 0.0.0.0.0.0.0.ip6.arpa/IN: loaded serial 0
May 28 09:06:21 localhost named-sdb[5108]: zone localhost.localdomain/IN: loaded serial 0
May 28 09:06:21 localhost named-sdb[5108]: zone localhost/IN: loaded serial 0
May 28 09:06:21 localhost named-sdb[5108]: zone allgolan.net/IN: loaded serial 42
May 28 09:06:21 localhost named-sdb[5108]: running
May 28 09:06:21 localhost named-sdb[5108]: zone allgolan.net/IN: sending notifies (serial 42)



And one more thing i did not install caching-nameserver since i could not find i t in the FC 8 repose.

[root@localhost ~]# yum install chaching-nameserver
updates 100% |=========================| 2.3 kB 00:00
Setting up Install Process
Parsing package install arguments
No package chaching-nameserver available.
Nothing to do
[root@localhost ~]#






When i do an nslookup its giving non-otherative answer.


[root@localhost ~]# nslookup www.google.com
Server: 127.0.0.1
Address: 127.0.0.1#53

Non-authoritative answer:
www.google.com canonical name = www.l.google.com.
Name: www.l.google.com
Address: 64.233.189.99
Name: www.l.google.com
Address: 64.233.189.147
Name: www.l.google.com
Address: 64.233.189.104

[root@localhost ~]#



whats is wrong with my instllation ?


Looking forward to hear from you

Thanks and Regards
Nidhin Tomson
Reply With Quote
  #4  
Old 28th May 2008, 22:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

dnsmasp is listening on 192.168.122.1, but I can't find any DNS server listening on 192.168.0.19. What's the output of
Code:
ifconfig
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 29th May 2008, 06:15
nidhintomson nidhintomson is offline
Member
 
Join Date: Nov 2007
Posts: 41
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
dnsmasp is listening on 192.168.122.1, but I can't find any DNS server listening on 192.168.0.19. What's the output of
Code:
ifconfig
?

Hi Falko
Thanks for the response. The output of ifconfig is as follows :-

eth0 Link encap:Ethernet HWaddr 00:13:20:EB3:E0
inet addr:192.168.0.19 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::213:20ff:feeb:d3e0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:386721 errors:0 dropped:0 overruns:0 frame:0
TX packets:75141 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:33815639 (32.2 MiB) TX bytes:6860073 (6.5 MiB)
Interrupt:20 Base address:0xe000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2098 errors:0 dropped:0 overruns:0 frame:0
TX packets:2098 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3585737 (3.4 MiB) TX bytes:3585737 (3.4 MiB)

virbr0 Link encap:Ethernet HWaddr 16:A0:FF:CF:6B:1A
inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0
inet6 addr: fe80::14a0:ffff:fecf:6b1a/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:35 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:5654 (5.5 KiB)

[root@localhost src]#



I got rid of the named.sdb faild but pid file exists error by removing the bind-sdb package . Is that the right way to do ?

Why the DNS is not listening on 192.168.0.19 ?

If i check named status it gives the following output :-

[root@localhost src]# /etc/init.d/named status
version: 9.5.0b3
number of zones: 16
debug level: 0
xfers running: 0
xfers deferred: 0
soa queries in progress: 0
query logging is OFF
recursive clients: 0/0/1000
tcp clients: 0/100
server is up and running
named (pid 1721) is running...
[root@localhost src]#


Looking forward to hear from you

Thanks and Regards
Nidhin Tomson
Reply With Quote
  #6  
Old 30th May 2008, 13:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What's in your named.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 2nd June 2008, 12:24
nidhintomson nidhintomson is offline
Member
 
Join Date: Nov 2007
Posts: 41
Thanks: 3
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by falko View Post
What's in your named.conf?
The error was that DNS quieres were listening only on localhost.

i just aaded the ip of the machine wehere DNS is running to the listen -on port option.




options {
listen-on port 53 {
127.0.0.1;
192.168.0.19; <--- This entry will not be there by default. We have to manually add it.
};
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
directories in /home/admispconfig/ispconfig renamed? Spudchat General 10 12th April 2007 19:37
spamassasin/clamAV not working Daisy Installation/Configuration 32 15th February 2007 00:09
Dspam planet_fox General 6 20th January 2007 18:42
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
Debian install error jf1976 Installation/Configuration 25 19th January 2006 22:31


All times are GMT +2. The time now is 06:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.