Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 10th May 2008, 07:48
CH Nathan CH Nathan is offline
Junior Member
 
Join Date: May 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Running Webalizer with runstats

Hi all,

I'm trying to configure an out-of-the-box CentOS VPS. Originally it had apache logs rotating with logrotate on a monthly basis, which ended up being rather too long, as my domlogs tend to hit 2GB in about 4 days. I cranked it down to daily, which has 'fixed' the problem, but necessitates a restart of apache nightly, which kind of sucks.

So, I'd like to switch over to piped logs. That's fine, but I want to make sure Webalizer keeps grabbing the log data properly. First step is to figure out how it works now. As far as I can tell, webalizer is being called from a binary file called 'runstats', which resides in /etc/cron.daily/. So it's called daily, and its also called by logrotate, immediately prior to log rotation (also now daily). Anyway. I can't find any domain-specific conf files for webalizer, and the default webalizer.conf doesn't have any non-default settings in it, so I can only assume that things like the output directories for webalizer stats are set by this runstats file. Because it's binary though, I can't see what it's doing. I also can't find a configuration file for it, a man page, anything on google that describes its operation... anything.

And so I turn to you...

---------------------------------
If it helps, this is for www.craigshelper.com and www.hankshelper.com. Sooo if you like my sites, please lend a hand..

-Nathan
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 4 TPS mail problem Hagforce HOWTO-Related Questions 13 10th February 2010 18:23
Can't do it. Mono-Project BullyWug Installation/Configuration 6 15th April 2007 11:27
webalizer cron msg annoyance domino Server Operation 3 23rd September 2006 16:35
install Net::DNS chrno Installation/Configuration 4 5th September 2006 17:01
WARNING: services not running MicCo Installation/Configuration 31 4th September 2006 12:16


All times are GMT +2. The time now is 09:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.