Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 30th April 2008, 13:46
PhilyWisk PhilyWisk is offline
Junior Member
 
Join Date: Feb 2008
Posts: 9
Thanks: 3
Thanked 0 Times in 0 Posts
Default Apache2 undefined symbol: gzopen64

Hi, I have had the following problem twice now.

The first time I assumed it was because I installed webmin on top of ISPconfig but this time I have kept the install clean and not tried webmin.

I was logged in through ssh and restarted apache2:

Code:
root@localhost:~# /etc/init.d/apache2 restart
* Restarting web server apache2
* We failed to correctly shutdown apache, so we're now killing all running apache processes. This is almost certainly suboptimal, so please make sure your system is working as you'd expect now!
apache2: Syntax error on line 183 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
                                                                         [fail]
I followed the Perfect Server on Ubuntu howto exactly.

Please note I have solved this solution. Using advice from https://bugs.launchpad.net/ubuntu/+s...l2/+bug/151045
(i.e I removed /usr/local/lib/libz* and restarted apache2) but I was interested to know what the issue was.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
upgrade from 2.2.11 andron26 Installation/Configuration 3 25th November 2008 02:00
ispconfig php 5 errors itamarjp Installation/Configuration 8 25th April 2008 10:20
apache not start ( undefined symbol: sqlite3ExprDelete ) qwe010 Server Operation 1 3rd January 2008 15:01
pure-ftpd compile fails fork Installation/Configuration 1 5th November 2007 05:05
Error: undefined symbol SQLAllocEnv at PHP my5660 Technical 8 3rd January 2006 10:17


All times are GMT +2. The time now is 15:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.