#1  
Old 25th October 2005, 18:03
AngelDrago AngelDrago is offline
Senior Member
 
Join Date: Sep 2005
Location: Florida -- USA
Posts: 100
Thanks: 4
Thanked 0 Times in 0 Posts
Exclamation Debian Question

hi everyone with all the problems i was having i deceide to give debian a try the wired thing is it found my domain name and my nameservers anyway my question is this... if i understand it right from the perfect setup for debian

for addional ip's i need to change this from the original (below)
127.0.0.1 localhost.localdomain localhost server1
192.168.0.100 server1.example.com server1
192.168.0.101 virtual-ip1.example.com virtual-ip1

to this...
127.0.0.1 localhost.localdomain localhost server1
192.168.0.100 server1.mydomain.com server1
192.168.0.101 virtual-ip1.mydomain.com virtual-ip1
192.168.0.102 virtual-ip2.mydomain.com virtual-ip2
192.168.0.103 virtual-ip3.mydomain.com virtual-ip3

mydomain= primary domain and not new domain

Correct!!!

anyhelp is alway very appriciated
Thank you all
AngelDrago
Reply With Quote
Sponsored Links
  #2  
Old 25th October 2005, 19:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Question

What's your exact question?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 25th October 2005, 20:09
AngelDrago AngelDrago is offline
Senior Member
 
Join Date: Sep 2005
Location: Florida -- USA
Posts: 100
Thanks: 4
Thanked 0 Times in 0 Posts
Default

i got five ip's that i need to implement and i never used the debian before and i do not like to make mistakes... it guess i like to get conformation i'm doing it right.. if i'm not please advice me.. it's seems so much easier in suse(LOL)

Thank you
AngelDrago
Reply With Quote
  #4  
Old 25th October 2005, 20:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by AngelDrago
for addional ip's i need to change this from the original (below)
127.0.0.1 localhost.localdomain localhost server1
192.168.0.100 server1.example.com server1
192.168.0.101 virtual-ip1.example.com virtual-ip1

to this...
127.0.0.1 localhost.localdomain localhost server1
192.168.0.100 server1.mydomain.com server1
192.168.0.101 virtual-ip1.mydomain.com virtual-ip1
192.168.0.102 virtual-ip2.mydomain.com virtual-ip2
192.168.0.103 virtual-ip3.mydomain.com virtual-ip3
Yes, looks ok.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 25th October 2005, 21:30
themachine themachine is offline
Senior Member
 
Join Date: Oct 2005
Location: Texas, USA
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I believe what your looking for is how to configure the IP address on your network device.

Networking info is found in the file '/etc/network/interfaces' file. In order to add IP's you need to edit this file. For example, it probably looks like:

Code:
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 10.1.1.10
netmask 255.0.0.0
gateway 10.1.1.1
Generally, when you are adding additional IP addresses... you create them as "alias" devices to eth0 (unless you want to add them to a second interface card). Aliases are in the form of "eth0:0, eth0:1, etc". So, you will need to add something like the following for *each* additional IP address:

Code:
auto eth0:0
iface eth0:0 inet static
address 10.1.1.100
netmask 255.0.0.0

auto eth0:1
iface eth0:1 inet static
address 10.1.1.101
netmask 255.0.0.0

...etc

Then of course restart networking and verify...

Code:
/etc/init.d/networking restart

ifconfig -a

Hope that helps.
__________________
themachine
5dollarwhitebox.org

Last edited by themachine; 25th October 2005 at 21:33.
Reply With Quote
  #6  
Old 25th October 2005, 22:16
AngelDrago AngelDrago is offline
Senior Member
 
Join Date: Sep 2005
Location: Florida -- USA
Posts: 100
Thanks: 4
Thanked 0 Times in 0 Posts
Default

thank you themachine... i understood that one but was not sure with the other one and thank you falko for clarification for the above...

Peace
AngelDrago
Reply With Quote
  #7  
Old 18th January 2006, 05:16
stlshawn stlshawn is offline
Junior Member
 
Join Date: Oct 2005
Location: nerdville, missouri
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default I must be doing something wrong

OK, so i'm trying to assign three ip's to this machine on the same nic card, so i go into /etc/network/interfaces and alther things there.

I don't know why, but when i change eth0 to eth0:0 things go badly.
Here's how it sets now,

Quote:
# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 24.182.139.77
netmask 255.255.255.248
network 24.182.139.72
broadcast 24.182.139.79
gateway 24.182.139.73
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 24.217.0.5
dns-search arwenspets.com

#auto eth0:1
#iface eth0:1 inet static
# address 24.182.139.76
# netmask 255.255.255.248
# network 24.182.139.72
# broadcast 24.182.139.79
# gateway 24.182.139.73
# # dns-* options are implemented by the resolvconf package, if installed
# dns-nameservers 24.217.0.5
# dns-search arwenspets.com
#
#auto eth0:2
#iface eth0:2 inet static
# address 24.182.139.75
# netmask 255.255.255.248
# network 24.182.139.72
# broadcast 24.182.139.79
# gateway 24.182.139.73
# # dns-* options are implemented by the resolvconf package, if installed
# dns-nameservers 24.217.0.5
# dns-search arwenspets.coms
now if i change the first eth0 to eth0:0 the machine is unreachable.
This is a debian install, if that makes a difference.
Is there something else i should be doing, is there some other file that needs altered?
__________________
Linux,,,, you mean them penguins, right (or could they be puffins)?
Reply With Quote
  #8  
Old 18th January 2006, 06:25
stlshawn stlshawn is offline
Junior Member
 
Join Date: Oct 2005
Location: nerdville, missouri
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default WOO HOO! got it to work


OK, so i needed to make a change.....
I had to leave the part that said eth0 as eth0 and add one for eth0:0, eth0:1, and so forth.

here's the final one.
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 24.182.139.77
        netmask 255.255.255.248
        network 24.182.139.72
        broadcast 24.182.139.79
        gateway 24.182.139.73
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 24.217.0.5
        dns-search arwenspets.com

auto eth0:0
iface eth0:0 inet static
        address 24.182.139.76
        netmask 255.255.255.248
        network 24.182.139.72
        broadcast 24.182.139.79
        gateway 24.182.139.73
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 24.217.0.5
        dns-search arwenspets.com

auto eth0:1
iface eth0:1 inet static
        address 24.182.139.75
        netmask 255.255.255.248
        network 24.182.139.72
        broadcast 24.182.139.79
        gateway 24.182.139.73
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 24.217.0.5
        dns-search arwenspets.com
ahh, searching for answers, that's what life's all about. I'm lovin' this whole linux thing.

ISPConfig is a wonderful thing, as is the whole linux revolution. I'm having more fun learning than i have in years.

Be Happy!
Shawn
__________________
Linux,,,, you mean them penguins, right (or could they be puffins)?

Last edited by stlshawn; 18th January 2006 at 06:27.
Reply With Quote
  #9  
Old 18th January 2006, 07:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
 
Default

Quote:
Originally Posted by stlshawn

OK, so i needed to make a change.....
I had to leave the part that said eth0 as eth0 and add one for eth0:0, eth0:1, and so forth.
Yes, that's right.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Perfect Setup - Debian Woody (3.0)... sending mail from my XP box? ExCIA HOWTO-Related Questions 17 27th June 2007 19:31
Debian Sarge RAID5 killfrog Installation/Configuration 2 23rd October 2005 22:43
Perfect Debian 3.1 failed of the E-MAIL Server explorer1979 HOWTO-Related Questions 1 21st October 2005 18:43
Debian Sarge "Perfect Setup" question... JeffMN HOWTO-Related Questions 3 4th August 2005 17:23
Why install from source instead of debian packages? TheMike HOWTO-Related Questions 3 27th July 2005 11:40


All times are GMT +2. The time now is 13:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.