Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 25th April 2008, 17:38
DantePasquale DantePasquale is offline
Senior Member
 
Join Date: Feb 2007
Location: Lakewood, OH US
Posts: 107
Thanks: 10
Thanked 3 Times in 3 Posts
Send a message via AIM to DantePasquale
Post /etc/passwd wiped out after updating user via CP

Hi Till,

Maybe we should start a new thread on this, but I'm having major issues with /etc/passwd getting wiped clean whenever I update a user in the ISPConfig control panel.

I had a user that was having problems logging into e-mail, so I reset her password and saved. Now, the only entries in /etc/passwd are for most of my ISPConfig users, no system users are the passwd file!

So, now I can't even become root to fix it - or restore from backup - or even shutdown the server!

What can I do to help debug this problem?

I'm running ISPConfig v 2.2.22 on Ubuntu 7.10 - 64-bit, kernel Linux inferno.cocoanet.us 2.6.22-14-generic #1 SMP Tue Feb 12 02:46:46 UTC 2008 x86_64 GNU/Linux.

I realize that with root gone I'm going to have to boot off of my rescue CD/USB drive and fix things and I can't get back to the server location for a few hours, but what should I do about this problem?

I see that you have v 2.2.23 out, but I understand that's just an update of ClamAV, or should I upgrade anyway?

Oh, I did an upgrade from 2.2.21 to 2.2.22 with no errors indicated and I didn't have this problem prior to upgrade.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hacking attack (ubuntu 7.04 server + local root exploit on kernel) smoko General 4 15th September 2013 05:05
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Anything I can do against illegal login-requests? schmidtedv Installation/Configuration 17 7th November 2008 09:25
Ruby / FastCGI Problem Chad Server Operation 1 8th March 2008 20:38
log files cruz Technical 3 15th May 2007 14:35


All times are GMT +2. The time now is 10:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.