Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th April 2008, 17:34
satimis satimis is offline
Senior Member
 
Join Date: Oct 2006
Posts: 533
Thanks: 4
Thanked 2 Times in 2 Posts
Default Fail to mount remote NFS server

Hi folks,


Server A
Ubuntu server 6.06.4 amd64
hostname=lampserver
IP add - 192.168.0.52

Server B
Ubuntu server 7.04 amd64
hostname=mail.satimis.com
IP add - 192.168.0.10


They are connected to the same router.

Server A

$ sudo /etc/init.d/nfs-kernel-server start
Code:
 * Exporting directories for NFS kernel daemon...                        [ ok ] 
 * Starting rpc nfsd...                                                  [ ok ] 
 * Starting rpc mountd...                                                [ ok ]

Server B
$ sudo /etc/init.d/nfs-kernel-server start
Code:
 * Exporting directories for NFS kernel daemon...                               exportfs: /etc/exports [1]: Neither 'subtree_check' or 'no_subtree_check' specified for export "*:/ubuntu".
  Assuming default behaviour ('subtree_check').
  NOTE: this default will change with nfs-utils version 1.1.0
exportfs: /etc/exports [2]: Neither 'subtree_check' or 'no_subtree_check' specified for export "*:/home".
  Assuming default behaviour ('subtree_check').
  NOTE: this default will change with nfs-utils version 1.1.0
                                                                         [ OK ]
 * Starting NFS kernel daemon                                            [ OK ]
Here it seems having problem. Please advise where to check and how to fix the problem


Server A

$ sudo mount mail.satimis.com:/ubuntu /mnt
Code:
mount to NFS server 'mail.satimis.com' failed: server is down.

B.R.
satimis

Last edited by satimis; 25th April 2008 at 04:33.
Reply With Quote
Sponsored Links
  #2  
Old 20th April 2008, 08:58
zcworld zcworld is offline
Senior Member
 
Join Date: Jul 2006
Location: South Australia
Posts: 329
Thanks: 2
Thanked 37 Times in 37 Posts
Send a message via MSN to zcworld Send a message via Skype™ to zcworld
Default

maybe this will help or not
if u do an ping
ping mail.satimis.com
what IP address do you get
an LAN IP address of the box or your WAN IP


if you getting your WAN IP

on the www host box
vi /etc/hosts

<IP> <TAB> mail.satimis.com

save it and reping
and see if it will fix the failing to mount problem
__________________
Shane Ebert :: Facebok
Reply With Quote
  #3  
Old 24th April 2008, 15:21
satimis satimis is offline
Senior Member
 
Join Date: Oct 2006
Posts: 533
Thanks: 4
Thanked 2 Times in 2 Posts
Default

Hi zcworld,


Thanks for your advice.


Quote:
maybe this will help or not
if u do an ping
ping mail.satimis.com
what IP address do you get
an LAN IP address of the box or your WAN IP
$ ping mail.satimis.com
Code:
PING mail.satimis.com (220.232.213.178) 56(84) bytes of data.
64 bytes from 220.232.213.178: icmp_seq=1 ttl=150 time=1.24 ms
64 bytes from 220.232.213.178: icmp_seq=2 ttl=150 time=0.664 ms
64 bytes from 220.232.213.178: icmp_seq=3 ttl=150 time=0.715 ms
WAN IP


Quote:
if you getting your WAN IP

on the www host box
vi /etc/hosts

<IP> <TAB> mail.satimis.com
Sorry I don't follow. Whether LAN IP or WAN IP


$ cat /etc/hosts
Code:
127.0.0.1       localhost.localdomain   localhost
192.168.0.10    mail.satimis.com        mail

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

Quote:
save it and reping
and see if it will fix the failing to mount problem
Do I need reboot PC after changing /etc/hosts
? ? ?


TIA


B.R.
satimis
Reply With Quote
  #4  
Old 24th April 2008, 18:45
zcworld zcworld is offline
Senior Member
 
Join Date: Jul 2006
Location: South Australia
Posts: 329
Thanks: 2
Thanked 37 Times in 37 Posts
Send a message via MSN to zcworld Send a message via Skype™ to zcworld
Default

no reboot needed when editing the hosts file

ok on the WAN / LAN

if your using
server1.mysite.com

but you dont have setup the server1.mysite.com = 10.10.10.1 in the hosts file
it will try to find the IP

in that case it will be trying the public IP
__________________
Shane Ebert :: Facebok
Reply With Quote
  #5  
Old 24th April 2008, 19:33
satimis satimis is offline
Senior Member
 
Join Date: Oct 2006
Posts: 533
Thanks: 4
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by zcworld
no reboot needed when editing the hosts file

ok on the WAN / LAN

if your using
server1.mysite.com

but you dont have setup the server1.mysite.com = 10.10.10.1 in the hosts file
it will try to find the IP

in that case it will be trying the public IP
Tried 3 setup on /etc/hosts in respect of the line
Code:
220.232.213.178   mail.satimis.com   mail
OR
Code:
192.168.0.10   mail.satimis.com   mail

OR nothing there
Code:
                mail.satimis.com   mail
ping still find the WAN, 220.232.213.178


All
$ sudo mount mail.satimis.com:/ubuntu /mnt
Code:
mount to NFS server 'mail.satimis.com' failed: server is down

satimis
Reply With Quote
  #6  
Old 25th April 2008, 00:07
zcworld zcworld is offline
Senior Member
 
Join Date: Jul 2006
Location: South Australia
Posts: 329
Thanks: 2
Thanked 37 Times in 37 Posts
Send a message via MSN to zcworld Send a message via Skype™ to zcworld
Default

check the firewall and make sure its letting the NFS port out
and restart the NFS server on the remote box

( i take it that you done the /etc/export file as well
there you set the IP / RW or RO settings )
__________________
Shane Ebert :: Facebok
Reply With Quote
  #7  
Old 25th April 2008, 04:32
satimis satimis is offline
Senior Member
 
Join Date: Oct 2006
Posts: 533
Thanks: 4
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by zcworld
check the firewall and make sure its letting the NFS port out
and restart the NFS server on the remote box
On Mail Server - Server B

Edit /etc/rc.local and add following lines on "OUTPUT
Code:
iptables -A OUTPUT -p udp --dport 2049 -j ACCEPT # nfs port
iptables -A OUTPUT -p tcp --dport 2049 -j ACCEPT # nfs port
Remark: I'm not very clear of "udp" function. Just add this line as well. Is "2049" the correct port?

$ sudo /etc/init.d/portmap restart
Code:
 * Stopping portmap daemon...                     [ OK ] 
 * Starting portmap daemon...                      [ OK ]
$ sudo /etc/init.d/nfs-kernel-server restart
Code:
 * Stopping NFS kernel daemon                                            [ OK ] 
 * Unexporting directories for NFS kernel daemon...                      [ OK ] 
 * Exporting directories for NFS kernel daemon...                               
exportfs: /etc/exports [1]: Neither 'subtree_check' or 'no_subtree_check' specif
ied for export "*:/ubuntu".
  Assuming default behaviour ('subtree_check').
  NOTE: this default will change with nfs-utils version 1.1.0
exportfs: /etc/exports [2]: Neither 'subtree_check' or 'no_subtree_check' specif
ied for export "*:/home".
  Assuming default behaviour ('subtree_check').
  NOTE: this default will change with nfs-utils version 1.1.0
                                                                         [ OK ]
 * Starting NFS kernel daemon                                            [ OK ]

$ sudo /etc/init.d/nfs-common restart
Code:
 * Stopping NFS common utilities                                         [ OK ] 
 * Starting NFS common utilities                                         [ OK ]
I'm NOT very clear whether I need to run both of them (above), OR "sudo /etc/init.d/nfs-common" ONLY.


Do I need caring the WARNING there?


Still fail to mout;
$ sudo mount mail.satimis.com:/ubuntu /mnt
Code:
mount to NFS server 'mail.satimis.com' failed: server is down.
Also tried "stop iptables running" with same result.


Quote:
( i take it that you done the /etc/export file
On Server B - Mail Server

$ cat /etc/exports
Code:
/ubuntu  *(ro,sync,no_root_squash)
/home    *(rw,sync,no_root_squash)

On Server A
$ cat /etc/exports
Code:
# /etc/exports: the access control list for filesystems which may be exported
#               to NFS clients.  See exports(5).
/ubuntu  *(ro,sync,no_root_squash)
/home    *(rw,sync,no_root_squash)

Quote:
as well as there you set the IP / RW or RO settings )
Sorry I don't follow. Pls explain in more detail. Thanks


B.R.
satimis

Last edited by satimis; 25th April 2008 at 04:34.
Reply With Quote
  #8  
Old 25th April 2008, 05:03
zcworld zcworld is offline
Senior Member
 
Join Date: Jul 2006
Location: South Australia
Posts: 329
Thanks: 2
Thanked 37 Times in 37 Posts
Send a message via MSN to zcworld Send a message via Skype™ to zcworld
Default

try this

/ubuntu 192.168.0.52(ro,sync,no_root_squash)
/home 192.168.0.52(rw,sync,no_root_squash)

on the server b mail.satimis.com


than " exportfs -ra "

than retry

check out this http://nfs.sourceforge.net/nfs-howto/
page 4
this is what i use to get my NFS up and working
__________________
Shane Ebert :: Facebok
Reply With Quote
  #9  
Old 25th April 2008, 05:21
satimis satimis is offline
Senior Member
 
Join Date: Oct 2006
Posts: 533
Thanks: 4
Thanked 2 Times in 2 Posts
 
Default

Quote:
Originally Posted by zcworld
try this

/ubuntu 192.168.0.52(ro,sync,no_root_squash)
/home 192.168.0.52(rw,sync,no_root_squash)

on the server b mail.satimis.com


than " exportfs -ra "

than retry
Edit /etc/exports (Mail Server)

$ cat /etc/exports
Code:
/ubuntu 192.168.0.52(ro,sync,no_root_squash)
/home   192.168.0.52(rw,sync,no_root_squash)

$ sudo exportfs -ra
Code:
exportfs: /etc/exports [1]: Neither 'subtree_check' or 'no_subtree_check' specified for export "192.168.0.52:/ubuntu".
  Assuming default behaviour ('subtree_check').
  NOTE: this default will change with nfs-utils version 1.1.0
exportfs: /etc/exports [2]: Neither 'subtree_check' or 'no_subtree_check' specified for export "192.168.0.52:/home".
  Assuming default behaviour ('subtree_check').
  NOTE: this default will change with nfs-utils version 1.1.0
Do I need to care the warning?


Still fail.

$ sudo mount mail.satimis.com:/ubuntu /mnt
Code:
Password:
mount to NFS server 'mail.satimis.com' failed: server is down.

Quote:
check out this http://nfs.sourceforge.net/nfs-howto/
page 4
this is what i use to get my NFS up and working
Thanks. I'll go through it first and come back latter


B.R.
satimis
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't start apache Musty Server Operation 12 9th March 2008 14:58
The Perfect Setup - Debian Etch (Debian 4.0) some trouble daniel80 HOWTO-Related Questions 26 1st February 2008 17:30
Questions RE:Setting Up A Highly Available NFS Server ouroborus HOWTO-Related Questions 1 1st September 2007 08:56
Setting Up A Highly Available NFS Server piotr HOWTO-Related Questions 3 16th March 2007 19:17
NFS Locking Failure and Updating solderboy Installation/Configuration 0 29th September 2005 22:59


All times are GMT +2. The time now is 05:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.