Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th April 2008, 03:43
hoggwild hoggwild is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Default Need help configuring network card

I am fairly new to Linux...and I can't seem to get the hang of configuring a network card for a static IP address.

I have a server I'm converting to Linux that resides behind a Linksys wireless router connected to the internet through my phone company. I do have a static IP address from the phone company.

I would like to configure the network card so that it has a static IP address instead of obtaining an address from the router using DHCP. However, every time I try to configure the network card for a static address, I seem to screw everything up, and the server is no longer able to transmit mail over the internet to external addresses (I'm obviously configuring something wrong). If I let the network card obtain an IP address from the router using DHCP, everything works find; however I have to reconfigure the router to route the different ports to the server every time the network IP address changes, which is a major pain.

Is there anyone out there who is willing to help me with this?

I would appreciate any assistance you can offer.
Reply With Quote
Sponsored Links
  #2  
Old 13th April 2008, 21:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Can you post the outputs of
Code:
ifconfig
and
Code:
route -nee
when the system is using DHCP and can connect to the internet?
Which distribution are you using?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
hoggwild (14th April 2008)
  #3  
Old 14th April 2008, 04:37
hoggwild hoggwild is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

Falko,

Thank you for responding. I finally figured out what I was setting up wrong, and everything's working now. Took me forever to figure this out.



I'm learning.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Network Card driver Ubuntu Server pmcun Installation/Configuration 1 6th April 2008 19:40
How do I configure my network card? jhdtolentino Installation/Configuration 1 23rd November 2006 17:18
Perfect Xen 3.0 setup for Debian gurneyzap HOWTO-Related Questions 4 26th March 2006 12:30
Network Card roadrunner Kernel Questions 4 25th March 2006 18:12
Network Card Help logik Installation/Configuration 9 5th March 2006 14:12


All times are GMT +2. The time now is 16:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.