Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th January 2006, 05:51
squallbsr squallbsr is offline
Junior Member
 
Join Date: Jan 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Postfix mail is held in queue indefinitely...

I am running Debian 3.1 on a VMS From TekTonic Hosting.

I installed Postfix, SASL, Courier-IMAP(-SSL), MySQL from this howto: http://www.howtoforge.com/virtual_po..._quota_courier

Postfix 2.1.5

I have gotten the SMTP server authenticating, accepting mail from clients, delivering it to other email servers, but when the mail is destined for the local machine, it just sits in queue. Postfix is successfully chrooted and all authentication is working fine, I do not want to remove it from the chroot, so I cannot remove the proxy:mysql:... entries from the main.cf file. I cannot change those entries to just mysql:... because it breaks the SASL authentication (even when postfix has been removed from chroot mode in master.cf).

Here is a snapshot of my log - which starts with a test email from my personal domain to <username>@hidesato.com.
Code:
Jan 11 22:08:22 mail postfix/smtpd[7407]: connect from cpe-x-x-x-x.satx.res.rr.com[x.x.x.x]
Jan 11 22:08:22 mail postfix/smtpd[7407]: D62AD4832496: client=cpe-xxx-xxx-xxx-xxx.satx.res.rr.com[x.x.x.x], sasl_method=PLAIN, sasl_username=<username>@hidesato.com
Jan 11 22:08:23 mail postfix/cleanup[7423]: D62AD4832496: message-id=<43C5C841.4050103@hidesato.com>
Jan 11 22:08:23 mail postfix/qmgr[5834]: D62AD4832496: from=<username@hidesato.com>, size=568, nrcpt=1 (queue active)
Jan 11 22:08:23 mail postfix/smtpd[7407]: disconnect from cpe-x-x-x-x.satx.res.rr.com[x.x.x.x]
Jan 11 22:08:42 mail postfix/virtual[7798]: fatal: mysql:/etc/postfix/mysql-virtual_mailboxes.cf: proxy map is not allowed for security sensitive data
Jan 11 22:08:43 mail postfix/master[5830]: warning: process /usr/lib/postfix/virtual pid 7798 exit status 1
Jan 11 22:08:43 mail postfix/master[5830]: warning: /usr/lib/postfix/virtual: bad command startup -- throttling
My guess is that this is related to the delivery to Maildir under the username vmail, in order to get the IMAP client to connect to the server I had to manually do a maildirmake /home/vmail/<username>. After those directories existed, the IMAP client (thunderbird) connected just fine - but all my mail is stuck in queue.

Code:
mail:/usr/src# mailq
-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
D62AD4832496*     568 Wed Jan 11 22:08:22  <username>@hidesato.com
                                         <username>@hidesato.com

-- 0 Kbytes in 1 Request.
I really would like to get the mail delivery working, thats the last thing to fix and I can get my email up and going on this new host. Any help would be appreciated. I followed the tutorial very closely, I did change all the references to 127.0.0.1 to localhost in the mysql files because for some reason the loopback ip address wasn't working. I can provide more information if needed of course.
Reply With Quote
Sponsored Links
  #2  
Old 12th January 2006, 13:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Did you run this command, as described in the tutorial:
Code:
postconf -e 'proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps'
Quote:
Originally Posted by squallbsr
I really would like to get the mail delivery working, thats the last thing to fix and I can get my email up and going on this new host. Any help would be appreciated. I followed the tutorial very closely, I did change all the references to 127.0.0.1 to localhost in the mysql files because for some reason the loopback ip address wasn't working. I can provide more information if needed of course.
What's in /etc/hosts? Also post the output of
Code:
ifconfig
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 12th January 2006, 14:55
squallbsr squallbsr is offline
Junior Member
 
Join Date: Jan 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default More Info

Here is the info requested...
I'm in a hurry so here is a big copy/paste with that info

Code:
mail:~# cat /etc/hosts
127.0.0.1  localhost localhost.localdomain
<my-ip> mail.hidesato.com mail
mail:~# ifconfig
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:7881716 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7881716 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1815973554 (1.6 GiB)  TX bytes:1815973554 (1.6 GiB)

venet0    Link encap:UNSPEC  HWaddr 00-00-FF-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:127.0.0.1  P-t-P:127.0.0.1  Bcast:0.0.0.0  Mask:255.255.255.255
          UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
          RX packets:173754 errors:0 dropped:0 overruns:0 frame:0
          TX packets:143919 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:82388623 (78.5 MiB)  TX bytes:24854901 (23.7 MiB)

venet0:0  Link encap:UNSPEC  HWaddr 00-00-FF-FF-FF-FF-00-00-00-00-00-00-00-00-00-00
          inet addr:<my-ip>  P-t-P:<my-ip>  Bcast:0.0.0.0  Mask:255.255.255.255
          UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1

mail:~# postconf -e 'proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps'

mail:~# /etc/init.d/postfix restart
Stopping mail transport agent: Postfix.
Starting mail transport agent: Postfix.

mail:~# postqueue -f

mail:~# sleep 30 && mailq
-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
C231E48324EA*     487 Thu Jan 12 00:00:04  root@mail.hidesato.com
                                         postmaster@hidesato.com

D62AD4832496*     568 Wed Jan 11 22:08:22  <username>@hidesato.com
                                         <username>@hidesato.com

-- 1 Kbytes in 2 Requests.
Reply With Quote
  #4  
Old 12th January 2006, 23:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Is this a virtual server?

Anyway, after you've run the postconf command and restarted Postfix, has Postfix delivered the mails in the queue?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 13th January 2006, 01:21
squallbsr squallbsr is offline
Junior Member
 
Join Date: Jan 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Virtual Server

Yes, this is a virtual server, no the emails have not gone through.
Reply With Quote
  #6  
Old 13th January 2006, 04:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

What's in the mail log now?
Please post /etc/postfix/main.cf here.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 13th January 2006, 05:04
squallbsr squallbsr is offline
Junior Member
 
Join Date: Jan 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here is the same thing repeated over and over in the mail log...

Code:
Jan 12 21:58:41 mail postfix/virtual[3077]: fatal: mysql:/etc/postfix/mysql-virtual_mailboxes.cf: proxy map is not allowed for security sensitive data
Jan 12 21:58:42 mail postfix/master[22249]: warning: process /usr/lib/postfix/virtual pid 3077 exit status 1
Jan 12 21:58:42 mail postfix/master[22249]: warning: /usr/lib/postfix/virtual: bad command startup -- throttling
Here is main.cf
Code:
mail:~# cat /etc/postfix/main.cf
# See /usr/share/postfix/main.cf.dist for a commented, more complete version

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

myhostname = mail.hidesato.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = localhost, localhost.localdomain
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /home/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_use_tls = yes
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_create_maildirsize = yes
virtual_mailbox_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
unknown_local_recipient_reject_code = 450
mail:~#
Keep in mind that mail works just fine when it goes to another server, the mail client will logonto smtp-tls (mail.hidesato.com) and send the email to the correct server (i.e. hotmail.com). I don't have refused connections, it just cannot deliver local mail. /me scratches head
Reply With Quote
  #8  
Old 14th January 2006, 00:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Have you tried to remove all the proxy: strings in /etc/postfix/main.cf (restart Postfix afterwards)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 14th January 2006, 07:10
squallbsr squallbsr is offline
Junior Member
 
Join Date: Jan 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Proxy removed doesn't help

I remove the proxy: from proxy:mysql:...

Mail still sits in queue. smtp is still chrooted, IMAP-SSL still works fine, SMTP to other mail servers works fine. For some reason it just cannot deliver the mail to one of the MailDir's under /home/vmail (i.e. /home/vmail/hidesato.com/<username>/ OR /home/vmail/mail.hidesato.com/test/)

I would imagine that the proxy items need to be there because of the chroot and not being able to read config from the /etc/postfix directory.

The postfix documentation is confusing because in places talking about virtual hosts and storing all the accounts under one unix account is allowed and can be mapped. But other places talking about the virtual hosts having no privileges on the filesystem and being unable to write to any files. I wish the error messages would lead me to a more conclusive answer...
Reply With Quote
  #10  
Old 15th January 2006, 20:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
 
Default

Quote:
Originally Posted by squallbsr
I would imagine that the proxy items need to be there because of the chroot and not being able to read config from the /etc/postfix directory.
No, that's just a performance tuning. If you use proxy, then there's only one MYSQL connection open which is used by all Postfix processes. If you don't use proxy, then every Postfix process which needs to access the database opens a new connection.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 09:27
Postfix not accepting mail heff Server Operation 13 20th March 2006 13:42
postfix starts and stops why lhatle Installation/Configuration 2 21st December 2005 16:20
postfix related to: Undelivered Mail Returned to Sender Ovidiu Server Operation 5 25th November 2005 13:36
postfix queue setting questions Ovidiu Server Operation 1 21st October 2005 16:05


All times are GMT +2. The time now is 21:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.