Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 6th April 2008, 02:56
wmkconn wmkconn is offline
Junior Member
 
Join Date: Apr 2008
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default Trouble with Postfix setup not working

I am attempting to be a Windows to Ubuntu convert so please excuse my ignorance.

I have installed Postfix, Courier, etc onto UBUNTU 8.04 Beta. I used Falko's "Virtual Users And Domains With Postfix, Courier And MySQL (Ubuntu 7.10)". Everything with well until I was done. It doesn't work and I am extremely frustrated. Had to make a few minor adjustments like apt-get install libdb4.6-dev instead of 4.5 and had to do a apt-get update before that.

Here is my setup and what I am trying to do:

I have 2 FQDN that I can use: example1.com and example2.com

I do not do my own DNS but setup my domains through Dotster. I generally don't use mail.example1.com but rather just use example1 as my mail server name.

I have a static IP that I think I have setup properly on the machine itself because I do have internet access.

My machine name is: Memphis. I do not have a domain setup for my machine. In the main.cf file for postfix I use myhostname=example1.com

I then setup for example1.com and example2.com in the domain table and setup several users for each domain.

Here are some of the log entries:

pop3d: chdir example1/user/: No such file or directory (Do I need to setup a directory on my drive for every user? That is what I was trying to avoid.

postfix/smtpd[12784]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 451 4.3.0 <user@example1.com>: Temporary Lookup failure; from=<user@example1.com> to=<user@example1.com> proto=ESMTP helo=<ME>

I just don't even know where to start. Please help.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 09:40
Postfix: Generic mapping not working DanielB Server Operation 0 28th January 2008 23:41
Postfix: connection refused error tosin Server Operation 1 30th October 2007 17:30
Postfix / smptd not working geetha Server Operation 4 30th May 2007 16:31
postfix setup ok but extension needed hotchilli Server Operation 3 2nd July 2006 18:08


All times are GMT +2. The time now is 00:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.