Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 22nd March 2008, 20:46
knotpc knotpc is offline
Junior Member
 
Join Date: Mar 2008
Location: Colorado
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via Yahoo to knotpc
Default ISPConfig crashes with new SSL using same server name.

Sorry to post this. I searched and did not find what I was looking for.

I am running a new install of ISPConfig on Debian 4.0. During setup I provided the box a name in all setups. Initially ISPConfig was set to https://www.mydomainname.com:81. Which worked great. I then setup my first site http://www.mydomainname.com/, same as the ISP domain. I then added an SSL cert from Godaddy to the domain, using the ISPConfig portal.

The domain http://www.mydomainname.com and https://www.mydomainname.com both load correctly. However the https://www.mydomainname.com:81 no longer works. So the portal is not accessable.

I followed the instructions to use http by editing the http.conf file and editing the config.php file. I then restarted the ISPconfig server. This allows me to use the portal.

I beleive the portal not working was due to a mismatch in the system with https://www.mydomainname.com having a valid SSL but port 81 having its own.

I really want to use the portal with secure SSL and my new certificate. This is where I am stumped. I beleive some edits need to be made to the system, but I am not sure where to start. I thought of creating and "admin" folder like https://www.mydomainname.com/admin then creating a symbolic link to the ISPConfig index.php. But I think that I would still need to edit the system settings to make this work and I am not sure which ones to mess with.

If any of you have a suggestion on how to get this to work correctly I would really appreciate it.

Thanks.

Clint.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php Apps email not going through palkat General 8 21st September 2011 05:35
ISPconfig after installation cannot reach www.xyz.de:81 Figth4Linux Installation/Configuration 23 6th March 2008 22:38
ubuntu 7.1x (server) - ISPConfig - SSL dbrooke Server Operation 1 24th October 2007 19:04
Possible to install backup DNS or better backup whole ISPconfig server ? Snowman General 1 2nd May 2007 14:01
Mailserver Migration To ISPConfig Server asyadiqin Installation/Configuration 1 9th January 2007 10:33


All times are GMT +2. The time now is 12:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.