Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th March 2008, 23:16
sinapsisglobal sinapsisglobal is offline
Junior Member
 
Join Date: Mar 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default new email accounts with incorrect host/domain

I have followed the Howto for installation of Debian Etch, Apache, PHP, MySQL, ISPConfig. Excellent howto!!! Thanks!.

After this was all done, I also installed the standard webmail (uebimiau).

I had a lot of problems being able to log on to webmail (and I could not access POP or SMTP remotely), and after reading quite a few of the threads here I was able to determine that my problem was that my email accounts area created as user@www.mydomain.com and NOT as user@mydomain.com.

After realizing this, I was able to access webmail, and send and receive messages remotely, so everything seems to be working fine.

NONETHELESS, emails of the form user@www.mydomain.com are not very practical.

My site in ISPConfig is created with Host Name: www and Domain Name: mydomain.com, so I figured if I try to remove the hostname and work with just the domain name, and later add a co-domain........... but of course I cant just delete the Host Name...

How can I change my config files or whatever is necessary such that new email accounts created via ISPConfig have the form user@mydomain.com and NOT user@www.mydomain.com??

Thanks in advance for any help.
Reply With Quote
Sponsored Links
  #2  
Old 13th March 2008, 01:17
make-fun make-fun is offline
Member
 
Join Date: Jan 2008
Posts: 92
Thanks: 8
Thanked 8 Times in 7 Posts
Default

Hi there,Hi there,

I'm also still struggling with the way ISPConfig works in that regard…

How ISPConfig does it is that it creates a SystemUser with a prefix of web_… and creates the Maildir/Mailbox in the according web.
For example:
Code:
/var/www/web_1/user/web_1p1/Maildir
I'm sure you've done and noticed this already.

As you then add any Co-Domains ISPConfig creates virtual user in the Postfix- virtusertable with that SystemUser web_…

Another example…
You started with the website mydomain.com, with the Hostname www and then added a CO-Domain leaving the Hostname blank and then set up a webmaster email account, leading to
Code:
webmaster@www.mydomain.com    web_1p1
web_1p1@www.mydomain.com    web_1p1
webmaster@mydomain.com    web_1p1
web_1p1@mydomain.com    web_1p1

in:
/etc/postfix/virtusertable
I too, was a bit confused by that, but thats just the way it's done for now… I've read here this will be changed in version 2.3 maybe and that most of the code is already written and that it is in the SVN — but that post was 1 year old or so.

Anyway, the solution for you would be to set the Mailserver to External for your "main site" www.mydomain.com
Go Site ->Options ->Mailserver: External Mailserver, but leave the setting for the CO-Domain "mydomain.com" at Local Mailserver!!

This will cut out any "xyz@www.mydomain.com" email addresses and shorten your
Code:
/etc/postfix/virtusertable
to
webmaster@mydomain.com    web_1p1
web_1p1@mydomain.com    web_1p1
I would still like to get rid of the "web_1p1@mydomain.com" as it's unnecessary and just a use less email address which can be spamed, but have not found a way doing this :(


Hope this helps

Cheers
Reply With Quote
  #3  
Old 13th March 2008, 10:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,665
Thanks: 819
Thanked 5,316 Times in 4,169 Posts
Default

Quote:
I would still like to get rid of the "web_1p1@mydomain.com" as it's unnecessary and just a use less email address which can be spamed, but have not found a way doing this
That's the way ISPConfig works and it is the way its intended to and we will not change this. Even if you remove it, you would be able to send emails to web_1p1@mydomain.com as web_1p1 is the name of the system user and you can always send emails to linux system users.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 13th March 2008, 11:10
make-fun make-fun is offline
Member
 
Join Date: Jan 2008
Posts: 92
Thanks: 8
Thanked 8 Times in 7 Posts
Default

Quote:
Originally Posted by till
That's the way ISPConfig works and it is the way its intended to and we will not change this.
Hi Till

I was referring to, the "@www.mydomain.com" + "Co-Domain adds email addresses automaticly" situation — isn't that going to be changed?
It's been so many posts I've read that can't find the one where you or Falco were writing about that, sorry.
Anyway, I thought I explain it to sinapsisglobal, how it works in general…

As for mails to a SystemUser… I understand what's happening and there is a way of preventing postfix from excepting those emails. In fact, on another server I complaint to the admin about not being able to quickly send emails to a SystemUser while I'm on the shell ;-)
But I would have to check there how it's done there and who did it…

Hope it'll work for you sinapsisglobal

Cheers
Reply With Quote
  #5  
Old 13th March 2008, 19:13
sinapsisglobal sinapsisglobal is offline
Junior Member
 
Join Date: Mar 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Solved

Hi again.

make-fun, your explanation was very clear and did shed a LOT of light on how things work. So the solution is to simply create the co-domain with no Host Name to make the user@mydomain.com accounts function as required. I do agree it creates additional opportunities for spammers, but it works. The added suggestion of changing Mailserver to external for Host Name www is also very useful to reduce that problem.

Thanks again to all who replied. Wonderful community!!
Reply With Quote
  #6  
Old 14th March 2008, 06:11
make-fun make-fun is offline
Member
 
Join Date: Jan 2008
Posts: 92
Thanks: 8
Thanked 8 Times in 7 Posts
 
Default

Hi sinapsisglobal,

glad your issue is solved ;-)

I'd still like to get the second part solved, regarding the the "useless" email addresses…

@Till
Could this be solved by switching to "Postfix-Style" in
Code:
/home/admispconfig/ispconfig/lib/config.inc.php
I've tried but only scored an empty virtusertable
Code:
###################################
#
# ISPConfig virtusertable Configuration File
#         Version 1.0
#
###################################
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
and
Code:
Relay access denied
So i switched back to the "Sendmail-Style"

Has anyone done this successfully and is there a post where the whole issue is explained, maybe??

Cheers
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
unlink email and ftp accounts daimmo Feature Requests 1 3rd August 2007 12:45
Non /etc/passwd email accounts ezgoen General 1 3rd July 2006 09:52
email forwarding locally consumes all resources rdells General 20 1st May 2006 19:43


All times are GMT +2. The time now is 08:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.