Prev Previous Post   Next Post Next
  #1  
Old 12th March 2008, 12:49
TauTau TauTau is offline
Member
 
Join Date: Oct 2007
Posts: 33
Thanks: 1
Thanked 0 Times in 0 Posts
Default eGroupware and PEAR Problem

Hi,

I'm trying to get egroupware running, but it doesn't see my PEAR installation. This is the output of the setup:

Code:
Passed Überprüfe benötigte PHP Version 4.3+ (empfohlen 5+): 5.2.0-8+etch10 ==> Ja
Passed Überprüfe die php.ini Datei: safe_mode = Off: ini_get('safe_mode')='' = Off
Passed Überprüfe die php.ini Datei: magic_quotes_runtime = Off: ini_get('magic_quotes_runtime')='' = Off
Passed Überprüfe die php.ini Datei: register_globals = Off: ini_get('register_globals')='' = Off
Passed Überprüfe die php.ini Datei: memory_limit >= 24M: ini_get('memory_limit')='32M'
Passed Überprüfe die php.ini Datei: max_execution_time >= 30: ini_get('max_execution_time')='0'
Passed Überprüfe die php.ini Datei: file_uploads = On: ini_get('file_uploads')='1' = On
Passed Überprüfe die php.ini Datei: include_path enthält .: ini_get('include_path')='.:/usr/share/php:/usr/share/php/PEAR'
Passed Überprüfe die php.ini Datei: mbstring.func_overload = 7: ini_get('mbstring.func_overload')='7'
Passed Überprüfe die php.ini Datei: magic_quotes_gpc = Off: ini_get('magic_quotes_gpc')='' = Off
Passed Überprüfe ob die Erweiterung mysql geladen oder ladbar ist: Ja
Warning Überprüfe ob die Erweiterung pgsql geladen oder ladbar ist: Falsch
Die pgsql Erweiterung (php extension) wird benötigt, wenn Sie die pgSQL Datenbank einsetzen wollen.
Warning Überprüfe ob die Erweiterung odbc geladen oder ladbar ist: Falsch
Die odbc Erweiterung (php extension) wird benötigt, wenn Sie die MaxDB, MsSQL or Oracle Datenbank einsetzen wollen.
Warning Überprüfe ob die Erweiterung oci8 geladen oder ladbar ist: Falsch
Die oci Erweiterung (php extension) wird benötigt, wenn Sie die Oracle Datenbank einsetzen wollen.
Passed Überprüfe ob die Erweiterung mbstring geladen oder ladbar ist: Ja
Passed Überprüfe ob die Erweiterung session geladen oder ladbar ist: Ja
Warning Überprüfe ob die Erweiterung ldap geladen oder ladbar ist: Falsch
Die ldap Erweiterung (php extension) wird benötigt für LDAP as Benutzer oder Addressen Speicher, um gegen LDAP oder Aktive Directory zu authetifizieren. Es wird nicht benötigt für eine standard SQL Installation.
Passed Überprüfe ob die Erweiterung imap geladen oder ladbar ist: Ja
Passed Überprüfe ob die Erweiterung gd geladen oder ladbar ist: Ja
Warning Überprüfe ob PEAR installiert ist: Falsch
PEAR wird benötigt von: Calendar (iCal import+export), FeLaMiMail, EMailAdmin, felamimail, Filemanager, SyncML. PEAR (pear.php.net) ist eine PHP Sammlung und ist überlicherweise in einem Packet namens php-pear.
Passed Überprüfe ob PEAR::Net_Socket installiert ist: 999.egw-pear
Warning Überprüfe ob PEAR::Auth_SASL installiert ist: Falsch
PEAR::Auth_SASL wird benötigt von: EMailAdmin, felamimail. PEAR (pear.php.net) ist eine PHP Sammlung und ist überlicherweise in einem Packet namens php-pear.
Passed Überprüfe ob PEAR::Net_IMAP installiert ist: 999.egw-pear
Passed Überprüfe ob PEAR::Net_Sieve installiert ist: 999.egw-pear
Passed Überprüfe ob PEAR::HTTP_WebDAV_Server installiert ist: 999.egw-pear
Passed Überprüfe ob PEAR::Log installiert ist: 999.egw-pear
Passed Überprüfe Datei Zugriffsrechte von . für nicht schreibbar von jedem (world writeable): web10_groupware/web10 drwxrwxr-x
Dieser Test braucht einige Zeit, bitte warten ...
Passed Überprüfe ob der Webserver auf die php.ini Einstellung session.save_path='/var/www/web10/phptmp' schreiben kann: web10_groupware/web10 drwxrwxrwx
Passed Überprüfe ob die Funktion imagecreatefromjpeg verfügbar ist: Ja
the include_path has /usr/share/php, this is where I have PEAR.php and a PEAR directory, so I thought it should be included. I read a lot about problems getting eGroupware running with confixx, because of a set open_basedir, an I though this wouldn't be the case here, but when I run a phpinfo() I get a open_basedir value of:

Code:
	/var/www/web10
so maybe this could be the problem? I tried copying the PEAR.php file to /var/www/web10 but it didn't help....

Any help?

Edit: That site has it's own php.ini, ISPConfig is running with suphp. So I tried setting the value of open_basedir to

Code:
open_basedir = /var/www/web10/:/usr/share/php
but it didn't change within phpinfo(), seems it get overwritten somewhere else?

Last edited by TauTau; 12th March 2008 at 12:59.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Egroupware install bernholdt General 3 24th February 2008 15:28


All times are GMT +2. The time now is 19:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.