Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th March 2008, 14:34
holdenga holdenga is offline
Junior Member
 
Join Date: Mar 2008
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Default ispconfig postfix relay access issue

I have just completed a fresh install of 64bit CentOS 5.1, Ispconfig 2.2.21, and the most current versions of postfix utilizing dovecot and smtp-auth.
I am able to connect to the server with Outlook Express from any network and send outgoing mails. However, if someone attempts to reply to, or originate a message to me from their ISP, they get a message similar to the following:

> Failed Recipient: greg@puredigitalcable.com
> Reason: Remote host said: 553 sorry, relaying denied from your location
> [64.85.3.4] (#5.7.1)


My main.cf file is configured as follows:

#
queue_directory = /var/spool/postfix
#
command_directory = /usr/sbin
#
daemon_directory = /usr/libexec/postfix
#
mail_owner = postfix
#
inet_interfaces = all
mydestination = $myhostname, localhost.$mydomain, localhost
#
unknown_local_recipient_reject_code = 550
#
mynetworks = 10.100.3.0/24, 10.100.2.0/24, 127.0.0.0/8
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
#
debug_peer_level = 2
#
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5
#
sendmail_path = /usr/sbin/sendmail.postfix
#
newaliases_path = /usr/bin/newaliases.postfix
#
mailq_path = /usr/bin/mailq.postfix
#
setgid_group = postdrop
#
html_directory = no
#
manpage_directory = /usr/share/man
#
sample_directory = /usr/share/doc/postfix-2.3.3/samples
#
readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
#
virtual_maps = hash:/etc/postfix/virtusertable


Could someone lend some insight as to how I can resolve this hiccup?

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 9th March 2008, 15:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Please run
Code:
postconf -e 'mydestination = /etc/postfix/local-host-names'
/etc/init.d/postfix restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following 2 Users Say Thank You to falko For This Useful Post:
holdenga (10th March 2008), oriongr (7th April 2008)
  #3  
Old 10th March 2008, 17:54
holdenga holdenga is offline
Junior Member
 
Join Date: Mar 2008
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Bingo! That did the trick! Thank you.

But it created a new problem. Now, senders from other networks are getting the following...

Could not deliver message to the following recipient(s):

Failed Recipient: greg@puredigitalcable.com


Everything else is as it was before (nothing else has changed).

Thanks in advance.
Reply With Quote
  #4  
Old 11th March 2008, 20:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Any errors in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 11th March 2008, 22:00
holdenga holdenga is offline
Junior Member
 
Join Date: Mar 2008
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default Fixed!

I found the problem. I had fat-fingered the dns entry! DOH!

Thanks a ton for the help.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Relay access denied when using SMTP to external recipients Kamran Shah Installation/Configuration 111 14th May 2014 18:10
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 09:40
The PHP binary coming with ISPConfig does not work properly on your system! KalishNikova Installation/Configuration 6 6th November 2007 14:52
Postfix with MySQL backend - Relay access denied klonos HOWTO-Related Questions 2 4th May 2007 19:55
64-bit Debian 3.1 Install Issue naruto Installation/Configuration 14 5th September 2006 04:12


All times are GMT +2. The time now is 23:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.